Join 3,557 readers in helping fund MetaFilter (Hide)


O Roku, where art thou?
January 25, 2014 5:11 PM   Subscribe

Okay, we just bought a new wireless router. Our two smartphones are wifi connected. So are two different computers plus two Nooks. The only thing that refuses to connect is our Roku box. The ONLY thing we use to watch TV. This is Not Good. Roku support was worse than useless. Hive mind, we turn to you. GO!

(just so you know my husband is technically adept, we have done everything we know to do. Nothing is working. He assures me the Roku box isn't broken. It was working with the old router but the old router was only working sporadically and our other devices were having trouble connecting. We needed a new router. It works GREAT with everything else.)

Okay, NOW go.
posted by St. Alia of the Bunnies to Technology (13 answers total)
 
Make sure that your wireless is not hidden. My roku HATES that, and we have to decrease the security to get it to connect. Try different security options, it may just hate whatever protocol you are using.
posted by AlexiaSky at 5:12 PM on January 25


My wireless router has subnetworks (think Network Name, Network Name 1 and Network Name 2). If my phone is not connected to the primary network, then it won't talk to the Roku. Even though all three networks on on the same router.
posted by honeybee413 at 5:23 PM on January 25


What model/brand of router? Which specific Roku model?

Can your Roku see the wireless network at all and just refuses to connect? Or, can it never see your wireless network at all?
posted by bookdragoness at 5:26 PM on January 25


Make sure that if the Roku is one of the first generation that your wireless router is not just sending out a wireless N signal. The first gen Roku's can only read b/g.
posted by deezil at 5:28 PM on January 25 [1 favorite]


Ours is first generation....
posted by St. Alia of the Bunnies at 5:49 PM on January 25


Oh, and it's an N1000. Right now we are using ethernet and it's working.
posted by St. Alia of the Bunnies at 6:08 PM on January 25


I have been reading the Roku forums lately, and seeing lots of people say that "oh, Roku units hate WiFi." Now, I have lousy WiFi in my house, and I blame a lot of the Roku's stuttering on that -- and I would switch to wired networking in a minute if I could.

Sometimes new Roku firmware releases mess things up briefly, and I saw a lot of reports in late December or early January saying that a recent update had hosed a lot of users' WiFi. *shrug*

Have you done a hard reset and added the network anew? I had to do that a couple of times before my v.2 XD "stuck."
posted by wenestvedt at 6:52 PM on January 25


This is maybe not a very helpful answer, but I had an issue last year where I tweaked a setting on my router, and then my Roku wouldn't connect anymore. Changed back to the default, and the other devices wouldn't connect. It didn't make sense. Eventually I threw my hands up and replaced my router firmware with DD-WRT. It's all sunshine and lollipops now. On one hand, I wish I'd figured out the initial problem. On the other hand, I wish I hadn't spent two weeks being frustrated while irrelevant router settings ticked off my Roku.

Maybe Rokus just really hate change.

So if no one else's answers get the job done, try replacement firmware before you give up.
posted by katieinshoes at 6:54 PM on January 25


I had the same problem at my parents' place and nearly went crazy trying to figure it out. The router's gotta be set to broadcast in wireless B mode (or any combination including B, e.g., B/G/N). Otherwise the roku will not be able to connect. Good luck.
posted by xiaolongbao at 8:08 PM on January 25 [1 favorite]


And sorry, I should've mentioned theirs is also 1st-gen...doesn't seem to be a problem for newer models, which must support G/N wireless. I never made it past the first 'red light' in the connection steps until I switched the wireless network over to B/G/N instead of G/N.
posted by xiaolongbao at 9:25 PM on January 25


Troubleshooting steps:

1. Can it see the wireless network?
2. If so, when you try to connect, does it ask you for a password?
3. If so, are you sure you're entering the password correctly? (Please forgive me. My own wireless password had a double-letter in it and I nearly drove myself out of my tree before realizing that due to the shitty interface I was entering only one of the two letters.)
4. Regardless of which point it fails at, does it give you an error message? If so, what is it?
5. Have you tried setting up the wireless network manually using a static IP address, and if so, what settings are you using?
posted by KathrynT at 11:47 PM on January 25


Right now it looks like the wireless B mode is something we need to try. As soon as Ralph has a spare minute I will have him look at this thread and we will go from there.

I suppose it would be the acme of foolishness for me to ask how you set a router to wireless B mode (Ralph might know but I don't.) Or is this something I need to go Google because it's such a stupid question ;-)
posted by St. Alia of the Bunnies at 8:30 AM on January 26


You do it from the router's configuration web page.
posted by KathrynT at 11:09 AM on January 26


« Older I'm in a LTR and my partner is...   |  I'm kind of embarrassed to be ... Newer »

You are not logged in, either login or create an account to post comments