Join 3,433 readers in helping fund MetaFilter (Hide)


Help me convince Word that "ed" doesn't need to be capitalized
January 2, 2014 8:36 AM   Subscribe

I create a lot of school-related Word documents in which I use the word "ed" (short for "education," as in "special ed.") When I do a spelling/grammar check, Word always flags this as a possible capitalization error - even though I've removed "Ed" from the dictionary and have added "ed." It's annoying, because I may use "ed" many times in a single document. Is there a way to get Word to accept uncapitalized "ed" as is, while still running a grammar check that includes checking for capitalization errors? I'm using Word 2007.
posted by Redstart to Computers & Internet (8 answers total) 2 users marked this as a favorite
 
Save, quit, and reload. It's possible that the software hasn't refreshed its definitions since you made those dictionary changes.
posted by valkyryn at 9:29 AM on January 2


Hmm, definitely annoying behavior. I tried a few different things and nothing seems to stick.

Alternate Ideas:

1) If you usually type "ed" instead of "education" to save keystrokes, add "ed" to your list of AutoCorrect options, and have it automatically expand to "education." Then the grammar checker won't complain.

2) Allow the grammar checker to change "ed" to "Ed", but then run a macro that changes them all back. Add the macro to a toolbar button and it's a one-click deal.

3) Combining #1 and #2, you could use a macro to change all occurrences of "education" to "ed". Or "special education" to "special ed" or whatever combo you usually use.

I can help you with the macro if you want to go that route.
posted by SuperSquirrel at 9:29 AM on January 2


Just as an FYI, it's doing this because "Ed" is a proper name (short for names like Edward).
posted by SuperSquirrel at 9:30 AM on January 2


Some ideas:
- When you do spell check, do you choose "ignore ALL" rather than "ignore ONCE" when it highlights ed? That way you only have to acknowledge it once. (I use this with surnames too as it catches when I've mispelled someone's name in one place and not another).

- From Word Options>Proofing, there's a "Settings" button under "When correcting spelling and grammar in Word". From that button, if you deselect "capitalization" it should ignore that type of error. This is more a nuclear option as it won't look for other capitalization errors. Depends how annoying this is...
posted by parkerjackson at 9:47 AM on January 2


I should clarify that I don't have Word set to check grammar and spelling while I type, so it's not marking the word as I type it or changing what I type. But I run a spelling/grammar check when I'm done and it stops at every instance of "ed." Since the "error" it's catching is grammar and not spelling it doesn't give me an "ignore all" option - it gives me an "ignore rule" option, and I assume choosing that would make it ignore any other capitalization errors, which is not terrible but not ideal either.
posted by Redstart at 10:15 AM on January 2


If nothing else works, kind of a silly work-around but it might solve your problem. When your'e ready to spell check, do a find-and-replace to replace all instances of "special ed" with "special Ed". Then the spell check will skip them. Then find-and-replace "special Ed" back to "special ed".
posted by bleep at 11:03 AM on January 2


I found a workaround that's a bit clunky, but might work. I haven't tested it in Word 2007 yet (the home machine has 2010 on it). It takes advantage of AutoCorrect and being able to mark text as "Do Not Proof".
  1. Select one of the instances of "ed" in your document. On the Review tab, click Language and select "Set Proofing Language".
  2. In the dialog box that appears, click the "Do not check spelling or grammar" checkbox, then click "OK".
  3. With "ed" selected, choose File -> Options -> Proofing, then click the "AutoCorrect Options" button.
  4. Ensure the "Replace text as you type" checkbox is checked, then click the "Formatted text" radio button. (When you click the radio button, the "With" box should change slightly, indicating that it's now working with formatted text. Before example; after.)
  5. Next type the text you want to have automatically replaced (probably "ed", if you're confident you won't ever have an actual typo where Ed's name has been accidentally uncapitalized) in the "Replace" box. Click "OK", then "OK" again to close the Options dialog.
Hope this works! A preliminary test seemed successful, but since I don't use the grammar checker much I'm not familiar with its ins and outs.
posted by Lexica at 9:18 AM on January 3


Lexica's suggestion worked! I didn't understand it at first; it seemed to be telling me how to change Ed to ed under the mistaken assumption that Word had autocorrected it for me. But after repeated re-reading, I finally understood how it was supposed to work and how to do it, tried it out, and it seems to be a true solution.

For anyone else reading this in the future who has a similar problem, I'll mention that using the exclusion dictionary doesn't work in this case. I eventually found that I had not actually removed "Ed" from the dictionary, and that it is, in fact, not possible to remove words from the main dictionary. Instead, you can use the exclusion dictionary. You add words to it that you want marked as misspellings even though they are in the main dictionary. I thought adding "Ed" to the exclusion dictionary would solve my problem, but apparently the exclusion dictionary doesn't affect grammar checking for capitalization.
posted by Redstart at 10:41 AM on January 4


« Older I've been developing with Djan...   |  Following on from the recent q... Newer »

You are not logged in, either login or create an account to post comments