Join 3,561 readers in helping fund MetaFilter (Hide)


Google Web Fonts are rendering horribly on my Firefox/Chrome browsers?
September 27, 2013 9:43 AM   Subscribe

I apparently have bad or damaged Google Web Fonts installed on a Windows 7 machine. Fun fact, they are not in the Windows Fonts directory. Text is coming up gnarly, super aliased, big and chunky in both FireFox and Chrome as they appear to be loading a local cache of the font(s) as opposed to hitting Google for them. Where are they? How can I fix this?

Lately I've noticed web pages have been looking rather gnarly with super aliased fonts all junky and cruddy. I messed around with my zoom settings thinking that was what was wonky when I discovered that the web pages all had Google Web Fonts in common. Reading up on the various support/bug tracks led me to believe that the fonts are installed on my machine... okay, sounds like something I would do... except they're not in the Windows fonts directory.

Let's use Google's "Monda" font as an example. It's super junky in Firefox and Chrome, yet it looks just fine in IE because IE is apparently loading it straight from Google.

Screenshot of IE, Firefox, Chrome on the sample text for Monda.

What am I missing? Help computer?
posted by cavalier to Computers & Internet (8 answers total)
 
This is a known problem with Chrome's rendering of web fonts. Check links for possible solutions.

Also, web fonts aren't really installed on the OS, they are managed directly by your browser, so that's why you don't see them in the Fonts folder.
posted by Foci for Analysis at 10:10 AM on September 27, 2013


Chrome and Firefox web fonts don't look that bad to me. Have you tried adjusting your cleartype settings?

Also, the Chrome font rendering problem has been fixed a long time ago.
posted by wongcorgi at 10:15 AM on September 27, 2013


It may be more obvious if you view the image at actual size -- I just noticed imgur is showing it a little shrunk down. The trick is letters with long vertical lines.. . l's, t's, etc, there are these large black chunks showing.

When you say managed directly by browser, is there a cache somewhere to empty them? I don't see it so far searching around Firefox.

The kicker for me is looking at IE, seeing the quality of that text, then looking at FF. Erch.
posted by cavalier at 10:42 AM on September 27, 2013


Since this is affecting both Chrome and Firefox, I suspect it has something to do with your ClearType settings as suggested above. If that doesn't help, try some of the other workarounds from this Firefox support thread.

Web fonts may be cached in the browser cache, which you can clear by choosing "Clear Recent History..." from the Firefox "History" menu, but I doubt this is a problem with the font itself; it looks like the correct font is being used but it's being rendered with ClearType disabled for one reason or another.
posted by mbrubeck at 11:04 AM on September 27, 2013


The problem isn't where the font is coming from, it's how it's being rendered. Most system fonts have hinting which make them look alright without font smoothing, but most web fonts don't have hinting, so they look chunky and ugly when rendered without smoothing. It looks like you don't have font smoothing turned on system-wide, so the fonts are being rendered without antialiasing or ClearType (you can tell because you can see the pixels in the font in the address bar of your browsers). I guess IE smooths web fonts by default even if you don't have font smoothing turned on in Windows because they know most aren't hinted. Anyway, here's a howto for turning on font smoothing.
posted by zsazsa at 11:04 AM on September 27, 2013


In the near future, Chrome will always render Web Fonts with antialiasing regardless of your system settings, specifically to address this problem. You may be able to test this change in a Chrome Canary build.
posted by mbrubeck at 11:09 AM on September 27, 2013


IE has ClearType turned on by default, even when Windows itself doesn't. In fact IE was where ClearType made its first appearance. As of IE9, they don't even let you turn it off any more.
posted by flabdablet at 11:27 AM on September 27, 2013


Well smack me in the face and call me Sherbert --- the expletive darned ClearType was turned off. I didn't even think you could still TURN it off these days. Dios mio. Suddenly, everything is antialiased and pretty and I am an idiot for not checking that.

The more you know... ClearType can be turned off... thanks y'all!
posted by cavalier at 11:55 AM on September 27, 2013


« Older Hiking the Pacific Crest Trail...   |  I find myself in exactly the s... Newer »

You are not logged in, either login or create an account to post comments