Join 3,524 readers in helping fund MetaFilter (Hide)


Apple TV 2 & Home Sharing Hell
September 9, 2013 1:13 PM   Subscribe

I have an ATV2. It asks me to turn on home sharing. I do. ATV insists that i turn on home sharing. It worked in my previous location excepting a few times, where I just unplugged the router and ATV and replugged back in. It worked here on initial setup the first try but a few days later this whole stuff happens. It worked again only after I did a complete factory reset. I have read many of the threads online and perhaps it is a bit of daftness on my part. This previous thread on mefi helped the gentleman with his question. I didn't actually understand it very well. I have an iMac running Snow Leopard. The ATV does connect to Netflix and all other things. Just not my computer.

Some things I have done:
-- Shut down iTunes, reopened and signed on to Home Sharing several times (no luck) in conjunction with turning on/off Home Sharing in ATV first, or second before I did the iTunes bit (no luck)
-- Unplugged ATV and router, plugged back in - no luck
-- Factory reset ATV - worked until the next time I tried.

Thanks for any input.
posted by snap_dragon to Computers & Internet (10 answers total) 1 user marked this as a favorite
 
When I have had this problem (and I have had it occasionally), I have always had success with going to iTunes on the computer, turning off Home Sharing, and then turning on Home Sharing. No need to shut down the program or do anything on the Apple TV. It takes maybe 20-30 seconds to connect, then works no problem. It's not clear if that is what you are describing in your first bullet point there, so I wanted to confirm.
posted by Rock Steady at 1:47 PM on September 9, 2013


It is, but thanks.
posted by snap_dragon at 1:49 PM on September 9, 2013


Any chance you have two different iTunes accounts and are using on on your computer, and the other on your ATV?

Have you rebooted the Mac? Have you checked the firewall settings in the Security panel in OS X's System preferences?
posted by Good Brain at 2:28 PM on September 9, 2013


Agree on rebooting the Mac. We have a power-PC era Mac Mini operating as our media server and a reboot fixes these symptoms for me. It's first, last, and only thing I need to do to get things running again.
posted by m@f at 3:33 PM on September 9, 2013


When I had this problem, it was because my Apple TV was connecting to the 5ghz version of my router while my computer was connecting to the other version. By default, apple's wifi routers give them the same name, and in theory this works. I had to go into my Apple Router's configuration, and select the option to name the 5ghz network something different than the regular network. I then made sure all devices were on the same network, and my sharing woes were over.
posted by snickerdoodle at 4:15 PM on September 9, 2013


I ran into issues with ATV dropping AirPlay connections that in the end seemed to be related to the wireless router firmware not being able to handle the Bonjour routing and a quick Google looks like it may be related in this case as well.

Depending on your router/firmware, you may be able to adjust the multicast settings. If you're using AirPort as a router, it shouldn't have any of these issues but some other wireless routers may. There's some info here but any router-based solution is going to depend on the particular model/firmware, so looking in the manual or Googling " multicast" would get you closer.

In my case, I was only able to solve the problem by flashing the firmware and replacing with Tomato USB, which was relatively simple and painless.

posted by camcgee at 4:16 PM on September 9, 2013


Are you using an Apple AirPort Extreme Base Station? Mine propagates two different networks with the same name; one 802.11g and one 802.11n. I'm sure this is even more complicated on newer versions now that there's another emerging IEEE spec, so keep it in mind if that's your router.
posted by oceanjesse at 4:44 PM on September 9, 2013


I had the exact same issue with an AppleTV 3.

Not in this order (this is how I remembered the steps): Tried another router, resetting the Apple TV (ATV), static IP addresses, checked that firewalls are off, made sure the computer a ATV are on the same router (I also use a switch), enabled disabled home sharing and network sharing, disabled or powered down all other WiFi devices, relocated the router to where it was about seven feet from the ATV unit (signal though ceiling to upstairs), changed the WiFi channel, disabled all WiFi security (we live in the country with no neighbors nearby. I know I have forgotten even more steps...

My workaround. I found that if I restart iTunes, it works for a short time. Since the computer is upstairs I used the host OS remote control feature in Parallels the iOS app to restart iTunes from downstairs.

Second workaround: I tested and found that the ATV never lost the connection to my wife's Win7 laptop with the same version of iTunes. GRRRR....

Third workaround: Picked up a wireless range extender and used an ethernet cable from the ATV to it. It essentially put it in wired mode and not wireless. That worked, but I didn't like the solution.

I heard that Apple had a limited exchange for third generation ATV units with WiFi issues. I took it in and they exchanged it, no questions. Same issue.

My resolution. I followed the (third party) steps online and downgraded from iTunes version 11 to 10. Apple does not have an uninstaller that completely removes iTunes. There are steps online. It works fine now.

I know you have an ATV2, but perhaps some of my steps will help you. Good Luck
posted by Leenie at 5:40 PM on September 9, 2013


Did you try the solution suggested in the previous question (of setting your iMac to use a static IP address)? I've found that doing that resolved some intermittent problems I'd been having with Airplay and with serving video to my Roku via Plex; it may well be the same with Apple TV.
posted by ook at 6:35 PM on September 9, 2013


Thanks for all suggestions. I am sorry I was abruptly away for a few days. The ATV2 seems to be working for now. I unplugged it and the router and let it sit for a bit (10 min) then plugged back in the router, then the ATV.

Not sure this is a real fix as I believe I have done this before, and before that as well and it didn't work. If it happens again I will check to setting it to static IP. If that doesn't work, it is becoming a gift to a friend with warnings. Not worth all that time....thanks so much for your help. I am really surprised that so many folks on so many discussion sites are having this same problem (some due to updates, a little to user error, but mainly to the product itself it seems).
posted by snap_dragon at 7:30 AM on September 11, 2013


« Older My husband was born at Mt. Sin...   |  What's on TV while the atomic ... Newer »

You are not logged in, either login or create an account to post comments