Join 3,556 readers in helping fund MetaFilter (Hide)


Router noob in need of help
June 6, 2013 1:32 PM   Subscribe

Help me make my wireless router work with my XP PC

A few weeks ago I bought a laptop and, a couple days ago, bought a wireless router—a D-Link Wireless N300 Router—to allow me to be connected simultaneously to the net on both my desktop PC (which has Windows XP installed on it) and laptop.

Yesterday I connected the router to my XP machine, my primary machine, as the instructions supplied with the router said to: I put the yellow ethernet wire from my desktop PC into the LAN 1 port on the router and put the blue wire, which was supplied with the router, from the INTERNET port on my router into one of two ports in my DSL modem—the port that used to have a yellow ethernet cable in it that went into my desktop PC (the other port, labeled DSL, has a phone cord that leads to the port on the wall. That, of course, is necessary for a net connection; so I left it as it was).

The laptop came with Windows 8. After checking it—Windows 8—out for ten minutes, I knew it wasn't for me and downgraded to Windows 7. After installing Windows 7, I installed the various drivers for the laptop and, upon finishing that, noticed that Windows detected a signal coming from the router. After some tinkering, I was able to connect to the internet on the laptop. As for the Windows XP machine: It didn't seem to detect anything. I then tried setting up a net connection using various methods—without success.

I'm wondering if perhaps I need a wireless card (or whatever it's called)—which I'm quite certain I don't have installed in my XP machine—installed in my XP machine. I somehow doubt it, as the yellow ethernet cable is directly connected from the router to the desktop machine, which should allow net access. If not that, perhaps upon installing Windows XP on my desktop machine, which was sometime last year, I disabled one or more services in Administrative Tools that must be enabled in order to use a router (I tend to disable various services in Windows to gain an admittedly meager performance boost). Which services, that I may have disabled, should be enabled to make a router work?

Here's the network card and "wireless connectivity" my laptop has:
  • Network Card: 10/100BASE-T Ethernet LAN (RJ-45 connector)
  • Wireless Connectivity: 1x1 802.11a/b/g/n WLAN
This is the Network card my desktop PC has (can't find anything to do with "wireless connectivity" anywhere):
  • 10-Base-T
(Interface: Integrated into motherboard
Technology: Realtek RTL8201E
Data transfer speeds: up to 10/100Mb/s
Transmission standards:10-Base-T Ethernet)

I was going to post all of the specs for the computers, but that would've been overkill. The amount of ram, HDD space, etc. I have won't help anyone solve my issue.

One last thing: As I said in the question title, I'm a noob when it comes to routers. Though I don't do anything I shouldn't do online, I worry that the router will allow guests who use my desktop or laptop easily view my internet browsing history. I certainly don't want guests who use them to be able to easily view what sites I've been browsing and I'm not at all interested in seeing what anyone else has been browsing. I allow guests to browse whichever sites they please as long as the sites won't get me into shit with the law or give me viruses.
posted by GlassHeart to Computers & Internet (6 answers total)
 
Do you have a login for your DSL account? If so, do you (or did you) enter the login information in Windows or directly in your DSL modem's administrator interface?
posted by jingzuo at 2:03 PM on June 6, 2013


Restart your desktop. It's probably still looking for the "old" connection to the DSL modem.
posted by Ferrari328 at 2:07 PM on June 6, 2013


I'm wondering if perhaps I need a wireless card (or whatever it's called)—which I'm quite certain I don't have installed in my XP machine

You shouldn't need any additional hardware here, the ethernet interface built in to the XP machine will handle this fine.

Go to the control panel, and check out "network connections" in there. What shows up under "LAN and high speed"? the realtek interface should show up there.

Right click it, is there a "disable" option? click that, then right click it again and click "enable". If you just see enable at first, well, then you need to enable it.

If it was disabled, mission accomplished.

Next, click start>run and type in "cmd". Once the dos prompt opens, type in "ping google.com" and see what you get. If you get responses saying something like "Reply from ip.add.ress bytes=32 time=35ms" or something then the problem is NOT your network connection, but a configuration issue in windows. If you get "request timed out" then lets move on.

Flip back to the network connections window in the control panel, does the realtek interface shown there say "network cable unplugged"? Do you have a little monitor icon with a red X over it in the taskbar? If so, try switching the cable to another port on the back of the router(2,3, etc) and then try another cable. It is not impossible or unknown for the cable to simply be bad out of the box.

Post back if it doesn't show up under "LAN and high-speed", but check right click my computer(on the start menu or desktop) and click "properties", then go to the hardware tab and click "device manager". Does it show up there? is there a red X or a /!\?
posted by emptythought at 2:11 PM on June 6, 2013


Go into your network settings for XP, and check whether Local Area Connection is connected. It could say "cable unplugged," in which case there's a connection fault, or more likely it'll say it's connected but without internet.

Chances are that XP was given an address by the old DSL, or it was programmed in as a static address (manually entered) at the time DSL was set up. Now, you want it to ask the Wireless AP for an address, and this procedure will do so.

Go to Local Area Connection properties, select TCP/IP, click properties. No matter what's in there, you want to switch it to "get an IP address automatically" (ditto for DNS)

Click okay and okay to get back to network connections, and then watch the tooltray (next to the clock, lower right) for notices-- it'll probably show you're online at this point.

Backup option: spend $20 (or something like that) and get a USB Wireless adapter. Best to get wired up, though.

Normally I charge for this sort of service, but I'll give you the AskMeFi discount.
posted by Sunburnt at 2:13 PM on June 6, 2013


Also, to address your concerns about protecting your router:

1. DO NOT use WEP.
2. DO NOT use WPS.
3. DO use WPA2-PSK with a strong password.
4. DO set a strong administrator password for the router (this is different from your WiFi password, this is for administering the router itself)
5. DO disable remote administration of your router if it is not already disabled.

That should prevent most unauthorized connections to your router, and it should prevent people connected to your router from viewing the router's logs (which contain information about your browsing).

What it will not prevent is people who use your laptop or desktop looking at your browsing history in Firefox or IE or whatever browser you use. That has nothing to do with the way in which you connect to the Internet. You should address that concern by having separate Guest accounts on those computers for guests.
posted by jingzuo at 2:17 PM on June 6, 2013 [1 favorite]


What do you get for an IP address on the "connected" adapters when you type the following in a CMD prompt on both the laptop and XP computer?

ipconfig

If your XP computer's IP starts with 169, then it is not getting a DHCP lease from the router. If it's something different however (like 10.x.x.x or 192.x.x.x) and the gateway is different than your wireless, you might have a static IP configured on the XP client.

To fix this, very easy (as sunburnt suggests above). Open your control panel, open network, and right-click properties on the adapter. Click TCP/IP and click properties. Change both the IP and DNS assignments to automatic.
posted by samsara at 9:12 PM on June 8, 2013


« Older I was at lunch today and asked...   |  I am 37 and shopping for a dre... Newer »
This thread is closed to new comments.