Join 3,436 readers in helping fund MetaFilter (Hide)


Network switch can't access internet behind router
January 2, 2013 3:01 PM   Subscribe

Why can't devices on my new 8-port switch get internet access on my network? I’ve got a new wired network set up in my house and am fine tuning it, getting everything to connect to the internet… Main computer and xbox are working (connected directly to D-Link DGL4300 Wireless router), but the Tivo and anything plugged into the new switch-based jacks aren’t getting to the internet, though they see the network.

Here’s the network layout:

Comcast Cable --> Cable modem --> Router --> Trendnet Gigabit 8-port switch wired from router in upstairs bedroom to the termination point for all wiring in the downstairs closet, where the switch is located.

That switch feeds plugs in the kitchen (1), downstairs bedroom (1), TV room (2), upstairs bedroom (1).

Basically, every plug that comes off of that switch can see the network, but cannot connect to the internet. The Tivo’s network test says that it can’t find the DHCP server. Plugging the laptop directly into the router works fine, as does connecting via wireless.

I've reset the configuration on my router to factory defaults, with no change. All new wiring tests okay. I have shut down everything and brought it all back up from the cable downstream to the devices, with no change. I was able to get the Tivo connected to the internet briefly, after a modem reboot, but then the main computer/router etc wouldn't connect.

Are there specific configuration changes I need to make on my router to allow a downstream switch? What am I missing?
posted by Pantengliopoli to Computers & Internet (28 answers total) 1 user marked this as a favorite
 
Check your DNS settings on the clients. If they're being set (by DHCP) to the address of the router, change them to 8.8.8.8 or 8.8.4.4 or 4.2.2.2 or 4.2.2.1 and try again.
posted by pompomtom at 3:06 PM on January 2, 2013


If it can't find the dhcp server, dns isn't going to be the problem. Try setting your ip manually on your pc and see if you can ping the router over the switch.
posted by empath at 3:07 PM on January 2, 2013


And when you say they see the network, what does that mean, exactly? It may be that they have a link to your switch, but the switch doesn't have a link to your router.
posted by empath at 3:11 PM on January 2, 2013


First check your router's DHCP server settings and make sure the DHCP server isn't set to hand out only a couple addresses (this would be weird and not the router's default setup, but might cause the symptoms you describe.)

Try plugging the laptop into the line from the router that feeds the switch (so, replace the switch with the laptop and see if it can connect that way.) If it doesn't work, bad cable from upstairs. If it does, try plugging it back into the switch and connecting the laptop to the switch with everything else unplugged. If that doesn't work, bad switch.
posted by contraption at 3:15 PM on January 2, 2013


Empath, I think you're correct there -- they "see" the switch as an unidentified public network, but I've got no indication that there's a connection to the router.

DHCP is enabled to provide addresses from .100 to .199 -- I don't see any other limiting factor in those settings. I'll plug the laptop into that router port now...
posted by Pantengliopoli at 3:18 PM on January 2, 2013


And when you say they see the network, what does that mean, exactly? It may be that they have a link to your switch, but the switch doesn't have a link to your router.

I agree. Windows probably says "cable is connected" and possibly even remembers that the home network is called FOOBAR, but can't see anything past the switch.

My guess is that you need a crossover cable between the switch and the router. Many devices will auto-switch when they realize they are connected to a switch, but not all do.

Clarifying: in this scenario, the router is acting as a switch, and like-to-like connections need crossover cables.

Another possibility is that the port on the switch or the router is bad.
posted by gjc at 3:20 PM on January 2, 2013


I'll plug the laptop into that router port now...

Don't just plug right into the port with a short cable, use the same cable that normally feeds the switch!

I was able to get the Tivo connected to the internet briefly, after a modem reboot, but then the main computer/router etc wouldn't connect.

Hang on, this might be a clue. Double-check that the modem is connected to the router's WAN port and that the switch is on a LAN port.
posted by contraption at 3:24 PM on January 2, 2013


I thought about the crossover possibility, but no dice. That router can auto-sense the need for a crossover and do it internally.
posted by contraption at 3:25 PM on January 2, 2013


Okay...

Laptop into the router-port that feeds the switch - works.
Laptop into the cable that terminates in the switch-closet - works.
Laptop into switch via short cable while cable that comes from router is the only other connection -- doesn't work.

I can flip the connection on that cable to be a crossover, but I thought that most devices could auto-sense and do it internally as contraption describes. The switch is brand new, but the DGL4300 is several years old -- perhaps it can't? But I would think only one of the devices needs to be able to...
posted by Pantengliopoli at 3:32 PM on January 2, 2013


And yes, the modem goes to the WAN port and the switch cable (and all others) come from the router's LAN ports. I forgot that when I got the Tivo to connect, the modem went to the switch first, then back to the router, which I changed -- I didn't think that sequence was correct and couldn't get the main computer to connect after the Tivo connected...
posted by Pantengliopoli at 3:34 PM on January 2, 2013


They are *supposed* to do that, but that doesn't mean it works. The switch should have that capability too. In fact, both of them trying to auto-cross might be confusing things.

Also, look at the logs and LAN statistics in the router and see if anything funny comes up.
posted by gjc at 3:34 PM on January 2, 2013


Only one needs to autosense, and virtually all Gigabit ports autosense. I suspect you have a faulty switch. If the switch doesn't include auto-crossover it will almost certainly have a port labelled "Uplink" (possibly with a latching button next to it) that you can use to force a crossover pinout, but D-Link's product page for your router advertises "Auto-Sensing Gigabit Ethernet LAN Ports" and honestly, it would really really be a fluke for that to be the problem in this day and age (I used to run into problems like that every year or two, but since Gigabit became widespread it just doesn't crop up anymore.)
posted by contraption at 3:41 PM on January 2, 2013


(FYI, DLINK has a cool router simulator for other people to look at what the router supports for settings, support.dlink.com/emulators/dgl4300/ )

Id check a couple things on the router:
Basic tab -> network settings -> dynamic dhcp clients table, does it list the devices that don't have access?
How about the dhcp server settings section?

Advanced Tab -> Mac Address Filter : Is it configured to only allow certain machines?

Status Tab -> Logs: I believe this should contain info about DHCP requests, i dont know how its listed though, my dgl-4300 died a while ago.
posted by TheAdamist at 3:46 PM on January 2, 2013


Here a few of the log entries that cropped up while plugging the Tivo and laptop into the switch while it's connected to the router through the wall wiring:

[INFO] Wed Jan 02 15:39:14 2013 UPnP renew entry 255.255.255.255 <> X.X.X.X:57259 <> X.X.X.X:57259 UDP timeout:-1 'Teredo'

[INFO] Wed Jan 02 15:41:07 2013 Blocked incoming TCP connection request from 1X.X.X.X:52765 to X.X.X.X:50713

[INFO] Wed Jan 02 15:42:29 2013 Blocked incoming UDP packet from X.X.X.X:57142 to X.X.X.X:50713

These are all repeated a few times, with some changes to the numbers. Not sure if that helps.

It would figure that the switch might be faulty. Anyway to test that? I have a small 4 port hub that I could put down there instead, see if that works?
posted by Pantengliopoli at 3:46 PM on January 2, 2013


Worth a shot, but if its actually a hub and not a switch, it won't act quite the same with the router.
posted by TheAdamist at 3:50 PM on January 2, 2013


Yeah, try your hub. Even if it's just 10Base-T your router should support it, and the speed won't matter if all you're doing is checking connectivity.
posted by contraption at 3:50 PM on January 2, 2013


Yes, try the hub. Also, edit out your ip address in the last message if you can.
posted by gjc at 3:51 PM on January 2, 2013


Go into status and statistics on the router and see if the LAN connection(s) show any dropped packets or collisions.
posted by gjc at 3:55 PM on January 2, 2013


Thank y'all so much for the help. That little hub was actually a 5-port switch, so I put the router-cable into the uplink port and plugged tivo, laptop etc into it and they all came online immediately. Must be a faulty switch after all, I guess??

I contacted the mods to delete the IP info -- thanks for that as well, didn't even think of it.
posted by Pantengliopoli at 3:55 PM on January 2, 2013


[Changed the IP addresses to Xes per OP request, hope that's ok]
posted by jessamyn at 3:56 PM on January 2, 2013 [1 favorite]


I forgot that when I got the Tivo to connect, the modem went to the switch first, then back to the router, which I changed -- I didn't think that sequence was correct and couldn't get the main computer to connect after the Tivo connected...

Hmm, this does make it seem like the switch is at least partially functional. What happened was that with the TiVo connected straight to the modem alongside the router, you had those two devices racing to grab the one DHCP address allotted by your ISP. The TiVo won, so it got an unfirewalled connection straight to the ISP while the router (and thus the devices behind it) were unable to connect.

I'd still take the switch back to where you bought it and exchange for a new one, chances are you just bought a dud.
posted by contraption at 4:00 PM on January 2, 2013


Sounds like bad switch is the answer.
posted by gjc at 4:02 PM on January 2, 2013


You could try plugging the line from the router into a non-uplink port on the working switch and see if it keeps working, which would confirm that your router is really capable of auto-crossover. I'd be surprised if it didn't, but I've been surprised before.
posted by contraption at 4:04 PM on January 2, 2013


That was my thought for the Tivo fluke as well, contraption. I'll box up the dud.

Thanks again y'all! It was getting frustrating after fishing all that cable...
posted by Pantengliopoli at 4:04 PM on January 2, 2013


Thanks contraption - confirmed that the router does auto-crossover. Must just have been a totally bum switch...
posted by Pantengliopoli at 4:12 PM on January 2, 2013


BTW, I've got a couple TrendNet gigabit switches, and they also support auto-crossover. None have given me any trouble on my somewhat sprawling home network.
posted by zsazsa at 4:27 PM on January 2, 2013 [1 favorite]


Just FYI, auto crossover appears to be a requirement for gigabit communication: https://en.wikipedia.org/wiki/Auto-MDIX#Auto-MDIX
posted by defcom1 at 5:28 AM on January 3, 2013


defcom1, I read that article yesterday myself and took it to mean that it's not an official requirement of the standard, but that in practice it's always done. Even so, never underestimate the tendency for manufacturers to skimp on something that's not officially part of a standard, or even to throw out features that are required by the standard if they think nobody will notice.
posted by contraption at 11:17 AM on January 3, 2013


« Older Please help me make sense of a...   |  Should we get involved in SEC/... Newer »
This thread is closed to new comments.