Join 3,512 readers in helping fund MetaFilter (Hide)


Can't Connect both Windows Latop & iPad to VerizonFIOS wifi simultaneously
November 3, 2012 5:44 AM   Subscribe

Annoying Verizon FIOS wireless router issue: if iPad/iPhone are on the wireless network, Windows laptop machines will not connect to wireless network. If I turn off WiFi on iPad/iPhone and restart the router, Windows machines get on WiFi right away. But after Windows machines are connected to WiFi, starting up WiFi on the iPad will almost always cause the Windows machines to drop their connections. More after the jump...

Some more details:
1. The FIOS router (model #MI424WR) is the standard one given by Verizon. All computers/devices are connected wirelessly to the router (there is no computer with a network/LAN connection to the router). Picture of router here.
2. I do not know how to access the router's configuration settings to modify any settings.
3. By "restarting the router" I mean turning it off, waiting 15 seconds, and then turning it back on. I am doing this several times a day now because of the above issue.
4. The Windows machines: 1 is running XP Pro, one is running Windows 7.
5. There are a bunch of other devices that connect to the WiFi, including an HP printer, a Roku, and an HD TV with wireless capabilities.

Looking for suggestions on how to resolve this issue so I can run iPad and Windows laptop on WiFi simultaneously. I fear issue #2 above may be a show-stopper, but would appreciate any advice. Thanks.
posted by Ike_Arumba to Computers & Internet (13 answers total) 5 users marked this as a favorite
 
One more important detail:

Windows XP-Pro laptop is using the Intel Centrino Advanced-N 620 driver. Windows 7 laptop is using the Intel Centrino Advanced-N 6205 driver. However, a third desktop PC running Vista will ALWAYS connect to the WiFi regardless of iPad scenario . The PC is is using the Broadcom 802.11g Network Adaptor driver.

Could this be a Windows driver issue?
posted by Ike_Arumba at 6:00 AM on November 3, 2012


Point 2 may be mitigated by this or this. I'd despair of troubleshooting this issue without knowing what the router's doing.
posted by pompomtom at 6:07 AM on November 3, 2012


Do you have the Rev. F version of that router? It has a known problem with constantly overflowing its NAT table. That said, it should take at least a day or two for that to manifest.
posted by pla at 6:13 AM on November 3, 2012


Thank you pompomtom! I am now able to access the router's config settings. Suggestions on where to go from there?

pla: Yes, it is Rev. F. But the issue show up instantly.
posted by Ike_Arumba at 6:16 AM on November 3, 2012


I am on a Rev F router too and thought that the reason my Windows devices would never connect with any degree of stability was the cursed NAT table issue. I am neither a torrent user or a PC gamer so this was particularly frustrating. Incidentally, my iOS devices always connected properly during this time.

What was actually happening is this:

1) Booting up a Windows device after a certain period of inactivity forced the router to assign a fresh DHCP lease to that device. This did not always occur instantly for whatever reason.

2) Bonjour (mDNSResponder.exe) running on my Windows devices as an adjunct to iTunes wrote in 0.0.0.0 as the default gateway for my network, which ordinarily causes no problems - but where the correct default gateway had not been configured by the DHCP lease, it caused the Windows devices to shit the bed. The router had already assigned them a DHCP lease so rebooting them didn't help, but the Windows devices tried to connect to 0.0.0.0 instead of the real default gateway so there was no connectivity.

Because you have iDevices, it seems likely to me that you have iTunes installed on your PCs and might be facing the same problem.

Therefore, I suggest"

1) Running services.msc and setting the Bonjour service to Manual startup on all Windows devices and

2) Then rebooting both these devices and the router (unplug the latter for 30 seconds or so and then turn it back on).

If this is your problem, this should fix it - the MI424WR is a joke but it's tough to imagine a scenario where the iPad is the culprit and causes the router to fail.
posted by Inspector.Gadget at 6:37 AM on November 3, 2012 [1 favorite]


Holy crap, Inspector.Gadget, that seems to have worked. I now have my iDevices and laptops connected simultaneously. Hopefully this will last. Thank you so much. I never would have figured that out myself.

Thanks to everyone who chimed in.
posted by Ike_Arumba at 7:25 AM on November 3, 2012


There's something to be said for spending money to get out from under ancient technology that can't be upgraded to current software. As in, a brand new netbook, underpowered as it is by today's standards, is probably leaps and bounds faster than that old laptop. XP network drivers were bad, wireless even worse.

Also consider setting up a separate wifi access point. Put the old machines on 802.11b/g and the new stuff on the 802.11n frequencies. This might be your simplest solution.
posted by wkearney99 at 7:41 AM on November 3, 2012 [1 favorite]


I jumped the gun on marking this as resolved. Both windows pc's have fallen off the WiFi again. Are there other suggestions in terms of router settings I could try? I am just using the factory default settings following the reset.
posted by Ike_Arumba at 9:30 AM on November 3, 2012


One place to start is the Event Viewer tool in Windows. Generally the "Administrative Events" filter under "Custom Views" in the leftmost panel will capture any records of problematic network activity.
posted by Inspector.Gadget at 9:49 AM on November 3, 2012


This is both random and bizarre, but! Is it possible that the two iDevices are interrupting DHCP to your Windows devices a la this scenario?
posted by Lynsey at 3:44 PM on November 3, 2012


Before throwing in the towel on my Verizon unit (that is its wireless function) I had real problems getting the settings to 'stick' without a physical wired connection.

The problems I had were different, but it might be worth looking at your settings that way.

I've since shut off the wireless function on the Verizon unit (using it only as a FiOS router) and then using an Airport Extreme unit I picked up used. Great signal, rock solid and have been very pleased with Trouble-free it has been, compared to all the grief the Verizon wireless was giving me.
posted by scooterdog at 6:52 PM on November 3, 2012


scooterdog, thank you, but I am unclear as to what you are suggesting. What does "shut off the wireless function on the Verizon unit (using it only as a FiOS router)" mean? To me, wireless function is the sole purpose of the FiOS router... perhaps I am in the dark on this?

Are you saying you plugged in an Airport Extreme router to the FIOS router and used it instead?

I would appreciate a follow-up message with some more details with exactly what you did as I am interested in following your lead -- just need some help understanding what you saying / what actions I can take. Thanks!!
posted by Ike_Arumba at 7:44 PM on November 3, 2012


Ike,

I believe scooterdog is suggesting that you disable the wireless network feature in the FiOS router and plug another wireless router into one of the Ethernet ports on the back. This will work just fine. You should have the option of using any wireless router in Bridge or AP mode, meaning they won't try to perform NAT and will pass DHCP requests through to the other network segment.

As a step further you can set the FiOS router in Bridge mode such that it no longer serves DHCP leases or performs NAT, and use another router behind it to do all of those and provide wireless. This means you would not plug anything but that second router into the Ethernet of the FiOS router.

This last option is what I'd do because it minimizes the roles of the carrier router, which I've found can't be trusted due to odd bugs like you've noticed. I would buy an Airport Extreme and set it up as I described.
posted by odinsdream at 12:25 AM on November 4, 2012 [1 favorite]


« Older Using a different surname - pr...   |  Is taking a short NOLS (Nation... Newer »
This thread is closed to new comments.