Join 3,417 readers in helping fund MetaFilter (Hide)


not the brightest bulb in the monitor
September 22, 2012 11:19 PM   Subscribe

My iMac is doing something weird with brightness. It's not showing up at full brightness except every once in a while for a second after the display has slept.

My screen seemed dim and I keep going in to turn in the brightness but it's at full brightness according to the display options. I noticed this when I came back from display sleep; the screen is bright for a moment and then it dims back down, making it sort of flash a bit.

The iMac is from 2009, so it's not this issue. I'd think that the monitor itself had just dimmed over time if it weren't for the brightness it displays after coming back from display sleep.
posted by NoraReed to Computers & Internet (16 answers total)
 
Do you have "automatically adjust brightness as ambient light changes" set in System Preferences (the Displays pane, I think)?
posted by hattifattener at 11:44 PM on September 22, 2012


There's no checkbox for that for me. I don't think my mac has a light sensor at all.
posted by NoraReed at 11:50 PM on September 22, 2012


Try resetting the SMC. From Apple's support site:
1. Shut down the computer.
2. Unplug the computer's power cord.
3. Wait fifteen seconds.
4. Attach the computer's power cord.
5. Wait five seconds, then press the power button to turn on the computer.
posted by tepidmonkey at 11:50 PM on September 22, 2012


I should've said: I tried that already.
posted by NoraReed at 11:53 PM on September 22, 2012


Do you have the diagnostics disc to hand? If not get it. Have you tried resetting the PRAM? Which OSX, is it fully patched?

Seems a bit young but I'd suspect the display or controller was generally failing if the brightness varied without cause. In the short term ensure you have an external display to hand.
posted by epo at 2:13 AM on September 23, 2012


Ah! With 10.8 on my I7 iMac I have noticed that the screen sometimes flashes white briefly when waking from sleep with the screen blanked. Annoying and I have a hunch it might be Firefox but I haven't tracked it down yet.
posted by epo at 2:19 AM on September 23, 2012


Epo, if our computers are doing the same thing-- and it sounds related-- I don't use Firefox. (Chrome and Stainless instead.) I notice it even if I'm not running any programs (I tested it last time I reset the SMC).

I'm running Snow Leopard. It is fully updated.
posted by NoraReed at 2:22 AM on September 23, 2012


I'm on 10.8.2 and it didn't happen before 10.8 but that might be coincidental. I'll run my diagnostics and take this to memail unless there is a wider discussion.
posted by epo at 2:34 AM on September 23, 2012


My 2009 iMac had a similar issue, where it was always in "automatically adjust brightness" mode (even if the preference was unset). I'm not sure if this is exactly your problem, but I fixed it with the terminal command "sudo pmset -c halfdim 0" as described here.
posted by nemp at 3:54 AM on September 23, 2012


Your computer has an ambient light sensor. They've been standard for a long time (some G5's had them I think)
posted by Packed Lunch at 5:12 AM on September 23, 2012


A little down on the apple support site link in tepidmonkey's post: try also to remove and re-insert the battery.
posted by Namlit at 6:08 AM on September 23, 2012


Go into your preferences and try switching your color profile ( Preferences>Displays>Color) and see if that doesn't kick the system into behaving properly. If you're like most users, you've probably left it set on iMac. Switch it to something like sRGB and see if the brightness issue goes away. If it does, you can probably switch it back to iMac and be ok. Sometimes, systems just need to overwrite the prefs to correct isues.
posted by Thorzdad at 6:39 AM on September 23, 2012


It's possibly a hardware problem. OS X tends to turn features on and off as it detects or doesn't detect certain bits of hardware, so if you don't have the "automatically adjust..." checkbox where it should normally be, then it might be because the sensor is malfunctioning. If that's the case, your computer is probably slightly wiggling out by trying to use a preference file that expects the sensor to behave.

Can you manually crank the brightness back up in the displays pref pane?
posted by Devils Rancher at 7:04 AM on September 23, 2012


Have you installed Shady or a similar app that dims the screen for you?
posted by katrielalex at 9:07 AM on September 23, 2012


I have recalibrated my color profile. Using other color profiles make the screen lighter, not brighter, and changing the profile back and forth doesn't seem to kick the machine into doing what I want.

I cannot remove a battery. It is a desktop machine. There aren't any removable parts of any kind.

I did at one point have apps that dimmed the screen. I uninstalled them ages ago, though, and this is a relatively recent problem.

It is a at full brightness in the Displays pane. The "flashing" it does after sleep mode is brighter than that. I want it at the brightness of that flashing all the time.

The sudo command didn't work. I also tried resetting PRAM without success, though it's possible that I wasn't holding the keys down properly, so I will retry that later.

Is there any way to check the hardware and see a) if I have an ambient light sensor and b) if it's working? To test it?
posted by NoraReed at 12:15 PM on September 23, 2012


I did the pmset thing as the half dim was an annoyance. I also had some old colour profiles listed which I couldn't delete using system preferences. I got rid of these using the command line (I renamed all but the one I wanted to keep) then rebooted so that system preferences showed only one. I have not seen my post-wake screen flash since doing that but it is early days.

My googling suggests that my 27" iMac does not have a light sensor and the display preference panel contains a manual brightness slider.

Another harmless bit of voodoo is to do a combo update just in case. Unless I have other issues I will wait until 10.8.3 before doing this but if you have detritus from your screen dimming apps it might help.
posted by epo at 3:58 AM on September 24, 2012


« Older Need to get up to speed on Key...   |  HistoricalFictionFilter: I'm l... Newer »
This thread is closed to new comments.