Clearly too dumb to be doing this, Ubuntu wireless no worky
August 26, 2012 2:55 PM   Subscribe

Wireless no longer working after upgrade to Ubuntu's Precise Pangolin. I've got just enough knowledge to be confused. Please explain what to do like I'm 5 years old.

So this seems to explain the problem and what to do (wireless suddenly stopped working and tries and tries to connect, would ask over and over for my password).

I did manage to download and install Wicd as a network manager. Now I guess I am supposed to disable NetworkManager and enable Wicd, but I don't know how to do that.

(I did finally find a terminal window and typed this into it, on the advice of some page I can't find again now, but I'm pretty sure I was in the wrong directory, because even though I restarted it didn't do anything.)
# settings NetworkManager disable
# settings wicd enable
Help. I don't really care to learn a whole bunch about the inner workings here, I just want my wireless to work. I only put Ubuntu on this netbook because it was so slow as to be unusable with Windows. And now that the whole interface has changed with this update, I had a hard time even figuring out how to get to Terminal.
posted by fiercecupcake to Computers & Internet (9 answers total)
 
Hi! I am also fairly inept at fixing problems with my laptop running Precise Pangolin, so I hope someone who knows what they're talking about comes in here soon. However, as a sanity check, do you have any other computers around, and are they able to connect to the wireless network? Because I have a problem with the same symptoms on a semi-regular basis, and restarting the wireless router usually fixes it. If your other computer(s) are also failing to connect, that might be worth a try. I'm just using the default network manager, not Wicd.
posted by zeptoweasel at 5:33 PM on August 26, 2012


I feel your pain. You might want to take a look at the forum "Networking & Wireless" over at ubuntuforums.org.. Good luck!
posted by Mister Bijou at 9:16 PM on August 26, 2012


"And now that the whole interface has changed with this update, I had a hard time even figuring out how to get to Terminal."
You might want to try Linux Mint.
Perhaps Linux Mint Xfce if your hardware is on the slow side.
LM has a more traditional user interface, so at least you'll be able to find stuff.
It's hard to help with your networking trouble without specific information about your computer / wireless card.
posted by Thug at 7:57 AM on August 27, 2012


This is why I stopped upgrading Ubuntu.
posted by srboisvert at 8:02 AM on August 27, 2012


OK. The wireless router is fine; my phone and other computers can pick it up and use it.

I've looked in forums and all I see is more command-line stuff I don't understand.

I can find the specs when I get home.

Two more questions, then:

-how do I get to the directory that allows me to make that settings change, referenced in the OP?

-is there a way to undo the upgrade easily or otherwise change the version of Ubuntu I've installed?

Thanks :]
posted by fiercecupcake at 10:24 AM on August 27, 2012


how do I get to the directory that allows me to make that settings change, referenced in the OP?

I don't see that any package in Ubuntu's standard repositories includes a command named 'settings'. It's possible that something somewhere defines a system-wide shell alias though; that would be harder to search for. So I think you may have received bad information on that.

I'm running Precise, but haven't used NetworkManager. Per the link in your question, though, it looks like to disable NetworkManager you run

sudo gedit /etc/NetworkManager/NetworkManager.conf

and change managed=false to managed=true under [ifupdown].

This probably won't take effect automatically, and you'll have to restart (or this would probably work:)

sudo service network-manager stop

I do run wicd, and so far as I recall, it starts by default, but doesn't do anything until you tell it to. If you run

ps -ef|fgrep wicd

do you see a reference to wicd-daemon.py?

I expect you have the wicd client in your system menu someplace; if you don't see it, run

wicd-gtk

in a terminal, and you can configure wicd, including what networks it should automatically connect to at start-up.
posted by Zed at 12:57 PM on August 27, 2012


I forgot to answer this one:

is there a way to undo the upgrade easily or otherwise change the version of Ubuntu I've installed

No. There's no good way to go backwards with a release upgrade.
posted by Zed at 8:05 PM on August 27, 2012


Thank you thank you thank you. When I got home last night I couldn't even get it to connect with the ethernet cable...then this morning right before I left, it did. So I haven't even gotten to try anything.

I'm disheartened that I can't go backwards and kind of wishing I could start over, but I don't feel like backing everything up again right this second.
posted by fiercecupcake at 10:35 AM on August 28, 2012


I had time today for the first time all week to fuck around with it. Here's what I did:

- checked for/installed updates in Update Manager -- none of them appeared to have anything to do with networking, but whatever
- restarted computer
- still didn't work
- deleted my network from the list of connections
- made a new access point which also didn't work
- deleted that
- tried again to connect to my network

And something magically worked. I'm still holding my breath. Thanks for y'all's patience. I was beginning to resign myself to having a non-netbook.
posted by fiercecupcake at 1:57 PM on September 1, 2012


« Older Recommend me a good quality fo...   |  Recommendation Letters filter:... Newer »
This thread is closed to new comments.