Join 3,551 readers in helping fund MetaFilter (Hide)


How to get Mac mail to use the right account?
August 21, 2012 9:34 AM   Subscribe

Mac mail sends with one gmail account but the recipient sees it sent from another gmail account. Help?

I have the Mac mail app on my 2011 MBP. I have one Microsoft exchange account and 3 gmail accounts set up in mail and all receive mail just fine.

If I send an email with gmail1 and check my sent email, it shows as being sent from gmail1. When I get a response, however, the response always comes to gmail3. When I look at the email that was sent (via the reply), it shows as being sent from gmail3.

I don't want gmail3 to be used for important emails. I can receive emails sent directly to gmail1 without issue, so my mailbox is not full. I check the drop down menu in the new email box and I am definitely choosing the right gmail account.

Why do all my emails seem to go out through gmail3 even though I want them (and try to force them) through gmail1? How can I fix this?
posted by sarae to Computers & Internet (4 answers total) 2 users marked this as a favorite
 
Check the SMTP sender. Mail on Mac is a bit weird, but your default sender is probably set to gmail3.
posted by Burhanistan at 9:37 AM on August 21, 2012


Ah okay, the SMTP was offline for that account. I do have 2 step authentication on it and just gave it a new password so it works fine now, but is there something I can do to make sure it doesn't go offline without warning again?

Thanks!
posted by sarae at 9:54 AM on August 21, 2012


In account settings, make sure each account is set to only use its SMTP account. There's a box you can check for "use only this account".
posted by supercres at 9:58 AM on August 21, 2012


Great, problem solved. Thanks again.
posted by sarae at 9:59 AM on August 21, 2012


« Older What is this mystery substance...   |  Why does my apartment door no ... Newer »
This thread is closed to new comments.