Join 3,572 readers in helping fund MetaFilter (Hide)


No, Firefox, Don't reload it!!!
April 21, 2012 6:29 PM   Subscribe

How do I make Firefox not reload the page that made it crash?

Firefox doesn't lock up very often. But once in a while it does, and I have to kill it with the Task Manager. (Win7-64) Problem is, next time I run it, it helpfully reloads all the tabs it had open when it was forcibly terminated, including the one that locked it up the previous time. The only way to escape getting locked up again is to be quick on the trigger and hit its "close" button before it freezes.

How do I make it not do this? What I want, in these cases, is for it to start up the way it usually does, with only my designated start page being loaded. I want it to not be helpful. I want it to not restore all the pages I had open.

Understand that it doesn't do this routinely. Ordinarily, if I'm through with it and hit the close button, the next time it starts I only get my designated start page. (Which is exactly what I want.)

This only happens if I terminate Firefox using the Task Manager. I don't want it to do so in this case, either.
posted by Chocolate Pickle to Computers & Internet (5 answers total) 2 users marked this as a favorite
 
You can always disconnect your internet connection before restarting it. (this is not the elegant way to do it, but it would work just fine)
posted by sciencegeek at 6:34 PM on April 21, 2012 [1 favorite]


Does this work for you? The answer is reproduced below in case the link gets moved or deleted at some point:


Set the pref browser.sessionstore.max_resumed_crashes to 0 on the about:config page to get the about:sessionrestore page immediately with the first restart after a crash has occurred or the Task Manager was used to close Firefox.

That will allow you to deselect the tab(s) that you do not want to reopen, but will allow to reopen other tabs.

See:

http://kb.mozillazine.org/Session_Restore#Restoring_a_session_after_a_crash
http://kb.mozillazine.org/Browser.sessionstore.max_resumed_crashes

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

Use the Filter bar at to top of the about:config page to locate a preference more easily.
Preferences that have been modified show as bold(user set).
Preferences can be reset to the default or changed via the right-click context menu.
posted by jdwhite at 6:38 PM on April 21, 2012 [1 favorite]


Try the Session Manager addon to gain super-power control over your tabs when Firefox crashes. It's saved my sanity many times....
posted by rumbles at 6:55 PM on April 21, 2012


Actually, it looks like the answer I wanted was to change
browser.sessionstore.resume_from_crash
to false. But JDWhite's answer pointed me in the correct direction.
posted by Chocolate Pickle at 7:03 PM on April 21, 2012


Since you're clearly using Windows, maybe typing or copying a URL into the "Run" field and hitting Go? (As long as Ffox is your default browser.) I can't deliberately crash it to test this, but am pretty sure it would be the most painless solution.
posted by aqsakal at 3:26 AM on April 22, 2012


« Older Looking for a blog, podcast, o...   |  Upcoming Honeymoon: I want to ... Newer »
This thread is closed to new comments.