Join 3,517 readers in helping fund MetaFilter (Hide)


Why won't you remember me, firefox?!
February 13, 2012 12:41 PM   Subscribe

Why doesn't my browser remember me on one partciular site when accessed from my desktop when it does on my laptop?

There's a site I use that has a log-in page with a Username and a Password field (it's the Open University but I don't think it's to do with the site). On my laptop, these fields autocomplete. On my desktop, they don't. Same browser on both computers - Firefox 10.0.1 and pretty much the same add-ons. Other sites log-ins do autocomplete.

Any ideas how I fix this? My username is a letter followed by a string of numbers so I have to look it up each time I log in, which is really annoying.

Thanks!
posted by xchmp to Computers & Internet (7 answers total)
 
Is it possible you told Firefox never to remember you for that site on that computer? These are the instructions for 9.0.1 so they may not be right, but probably it's similar: Go to tools --> Options --> Security, then click "Exceptions" next to "Remember passwords for sites" and see if you accidentally made it an exception.
posted by brainmouse at 12:49 PM on February 13, 2012


Hm that would make sense, but I just checked and the password exceptions list is empty. The remember password for sites option is ticked.
posted by xchmp at 12:54 PM on February 13, 2012


I also tried disabling all my add-ons and logging in, but no option to remember the password comes up.
posted by xchmp at 12:55 PM on February 13, 2012


The <form> element includes this attribute: autocomplete="off". This attribute is designed specifically to disable auto-complete so that sensitive information is not stored if, for example, you were to log at the public library. It not part of the standard (or wasn't, maybe it's in html5) but is enforced by a lot of the scanning software that sites with certain security requirements use to monitor their compliance.

So, long story short, my guess is that the attribute wasn't there when you first logged-in on your laptop, but was added before you tried logging on the desktop. I don't know of any work-arounds, but that doesn't mean they don't exist.
posted by Dano St at 1:15 PM on February 13, 2012


I'm on my phone right now so I can't link to it, but there is a Greasemonkey script that removes the autocomplete=off attribute. Hopefully that gives you a starting point to look for it.
posted by stopgap at 1:27 PM on February 13, 2012


Thanks! I've installed the force autocomplete greasemonkey script which looks like it should do what I want. Weirdly, the page now remembers the password but it still doesn't remember the user name.
posted by xchmp at 1:40 PM on February 13, 2012


Got it working. For some reason Firefox had added the site to the saved passwords list, but hadn't added in the usename. I deleted it from the list, logged in again and now it remembers my details. Thanks everyone!
posted by xchmp at 1:50 PM on February 13, 2012


« Older I bought my beloved 13" M...   |  How do I sync Outlook between ... Newer »
This thread is closed to new comments.