Join 3,441 readers in helping fund MetaFilter (Hide)


PDFs on Firefox for Mac
January 16, 2012 2:59 PM   Subscribe

PDFs on Firefox for Mac: No matter what hacks I try, it seems that I cannot get the PDF Plugin for Firefox on Mac OS X to work with either Firefox 9 or Firefox 10 beta. I feel like I must be doing something wrong because evidently other folks have gotten it to work. Would be grateful if anyone could walk me through the best way to get this extension working again.

In case it matters, I am running Snow Leopard 10.6.8. I also do not wish to switch to another browser. Thank you so much.
posted by Conrad Cornelius o'Donald o'Dell to Computers & Internet (4 answers total) 2 users marked this as a favorite
 
Have you tried this?
posted by drpynchon at 3:42 PM on January 16, 2012


Yes, I have. At the point where I try to install the modified extension, I receive an error telling me it is not compatible.
posted by Conrad Cornelius o'Donald o'Dell at 3:53 PM on January 16, 2012


The PDF Plugin addon you referred to seems to be unmaintained, unfortunately. Even if you can find a hack that gets it to work, it hasn't been updated in over two years, so any security bugs aren't getting fixed.

There are a couple of other options:

1. The Schubert|it PDF Browser Plugin. In my experience it works fine in both 32- and 64-bit mode, and in any recent Firefox. Note that it's only free for non-commercial use.

2. Some fine folks at Mozilla are working on an in-browser PDF viewer, like Chrome has. You should be able to install it by clicking here. Their work is still a bit experimental, but I tried it out briefly and it seemed to work, again in both 32- and 64-bit mode. Hopefully it will be integrated into Firefox as standard one of these days, but I wouldn't expect it to happen too soon...maybe around Firefox 17?

If you try either of these, don't forget to disable your old PDF Plugin. If in your attempts to get that plugin working you forced Firefox into 32-bit mode, you probably want to disable that setting, though it's not critical.
posted by vasi at 3:53 PM on January 16, 2012 [1 favorite]


Amazingly enough, I just got it to work. To actually install the extension, I had to open the browser in Safe Mode. For some reason, that finally let the add-on install. (I tried this because I wondered if perhaps there was a conflict with another extension that was preventing the install. I still don't know if there was, but at least the install went through.) The add-on still did not work, though.

So I tried the second half of the instructions at the link that drpynchon posted. They were almost right, but not quite. Specifically, this part:
• Go up one level to the [gibberish].default folder. You should see a file called extensions.ini. Open this file in your text editor.

• Look for an entry that ends with colesbury@gmail.com.xpi.

• Remove the '.xpi' extension.

• Save and exit.

• Back in the extensions folder, double-click on colesbury@gmail.com.xpi. This should expand it into a folder named colesbury@gmail.com. If necessary, delete the previous .xpi file.
Launch Firefox 5. It should properly display PDFs in the browser now
The file called "extensions.ini" did not actually contain a line ending with "colesbury@gmail.com.xpi," perhaps because of the unorthodox way I installed the extension (i.e., in Safe Mode). I added that line in, though, and tried restarting. Still no luck, so I followed the remaining steps (removing the ".xpi" extension from its line in the extensions.ini file and expanding the colesbury@ folder). That finally did the trick! (I did not have to delete the original .xpi file, and I won't tempt fate by trying.)

A huge relief to finally be able to see PDF files in-line once more — though I'm still pretty amazed that this crucial feature is absent from Firefox.

Anyhow, vasi, thanks for the alternate suggestions — I may yet need them some day! And drpynchon, your response prompted me to try that procedure once more, so thank you as well.
posted by Conrad Cornelius o'Donald o'Dell at 4:13 PM on January 16, 2012


« Older My two bottom front teeth has ...   |  Does anyone know of a four-par... Newer »
This thread is closed to new comments.