Join 3,440 readers in helping fund MetaFilter (Hide)


How to temporarily disable SpeedStep?
December 19, 2011 2:17 PM   Subscribe

The Binding of Isaac runs really quite poorly on my PC. I think SpeedStep the problem. How can I force my PC to run at maximum speed for the duration of the game?

I love The Binding of Isaac, but it has real performance problems on my PC, particularly on the later levels when all sorts of nonsense is being thrown around. After googling I saw it suggested that SpeedStep might be the problem, and -- running the game in a window with CPU-Z open -- it really does leave the CPU on the lower speed for most of the time it's running. Rebooting and killing SpeedStep in the BIOS sorts the problem, but that's not a permanent solution: my PC spends most of its time not playing Isaac and I don't want it humming away at full speed when it doesn't need to be.

Is there something I can do, within Windows, to force the CPU to full speed, for the duration of the game?

My PC is a Core 2 Duo e7200 (overclocked to just over 3.5ghz from its native 2.5) on Windows 7 64 SP1. Isaac runs in Flash, if that helps.
posted by ArmyOfKittens to Computers & Internet (4 answers total)
 
Apparently you can do it through the Windows power settings.
posted by pombe at 2:35 PM on December 19, 2011


I tried that before without success, but I checked again for completeness: it still throttles down to ~2.2ghz and stays there with Isaac loaded.
posted by ArmyOfKittens at 3:24 PM on December 19, 2011


Is it possible that your computer is refusing to go to a higher speed due to heat issues?
posted by The Lamplighter at 10:21 PM on December 19, 2011


I don't believe so. The temps are fine even when Prime95ing and it sits happily at full speed when playing Skyrim et al.
posted by ArmyOfKittens at 10:32 PM on December 19, 2011


« Older I will be in Hong Kong for 12 ...   |  Jeep Cherokee filter. I think... Newer »
This thread is closed to new comments.