Skip

Hanged by the neck until dead, in Firefox
November 6, 2011 2:50 PM   Subscribe

Firefox hangs. All the time. I tried to fix it. But I can't.

Firefox no work please hope.

The problem:
Firefox stops reponding every 10-15 minutes, for about 20 seconds, then usually recovers. sometimes I have to close and reopen Firefox. This happens regardless of site. It is maddening.
IE8 does not have this problem at all, but it sucks in many other ways, obviously, so.
An error message:
About three times a week AVG 2012 will give me a pop up in IE *or* Firefox that says something like "AVG has detected a high rate of memory usage from browser. Please close and reopen browser for better performance."
Some data (don't know what is relevant):
Firefox 7.0.1, no newer updates available
Theme is default
Enabled plug-ins: Acrobat 10.1.1.33, iTunes App Detector 1.0.1.1, Quicktime 7.6.9.0, Flash 11.0.1.152, and system plugins

Operating System:
Win 7 Home Premium

Computer:
iBUYPOWER AMD Phenom II X4 955 Processor 3.20GHz 4GB 64-bit (Bought new May 2011)

Anti-malware:
Spybot Search and Destroy updated 11/6/2011
AVG 2012 free edition updated 11/6/2011
Scanned with both 11/6/11 after update; nothing found
What I have done:
I completed the standard diagnostic steps, which included clearing the cache, disabling plug-ins, disabling non-default theme, updating Firefox, using Firefox in safe mode, and un-installing! and re-installing! Firefox.
Please note: I think I did these things, but some of the steps were confusing to me. Responses like "You must not have teched the tech, pH you big dummy. Go to C:>Windows>Whatever. Open the..." are totally welcome and appreciated.
posted by pH Indicating Socks to Computers & Internet (24 answers total) 8 users marked this as a favorite
 
I know this isn't a solution to your Firefox problem, but have you tried Chrome? It's much faster and does not hang nearly as often as Firefox.

You might also want to try disabling Flash to see if that's what's causing the problem. When I see memory leaks they're usually from Flash.
posted by iamscott at 2:52 PM on November 6, 2011 [2 favorites]


Do this happen in previous versions?

Have tried displaying some of the plugins? Do what at a time, see if that helps.
posted by Brandon Blatcher at 3:00 PM on November 6, 2011


Try disabling Surf-Shield in AVG -- I think Surf-Shield inspects HTTP traffic and, on my laptop, it also seems to consume a lot of CPU and slow down Firefox a lot. It seemed to help me, maybe it will help you too.

(Open AVG by double-clicking its icon in the system tray; in the AVG main screen, click on LinkScanner; in the LinkScanner screen, unselect Surf-Shield.)

(This will make AVG grumble about not being fully protected. If you decide to leave Surf-Shield off, you can AVG grumble less by, in the AVG main window, choosing menu Tools->Advanced Settings and changing the Ignore Error Status setting to ignore LinkScanner warnings.)

AVG likes to warn me that Firefox is using a lot of memory too -- LIKE THAT'S NEWS TO ME FIREFOX HAS ALWAYS USED A LOT OF MEMORY. I decided I didn't need that warning; you can turn it off in AVG's Advanced Settings, Appearance, uncheck "Display AVG Advisor performance notifications."
posted by We had a deal, Kyle at 3:05 PM on November 6, 2011


You mention plugins but not extensions. Do you have any extensions installed and running? For me, Firefox would just use more and more memory until it bogged down the whole computer. Something that helped me for unknown reasons was disabling Tab Mix Plus. That sucks because I love Tab Mix Plus, but for some reason it causes me problems, or rather seems to exacerbate them. I still get a steady increase in memory used, but it just doesn't go up as high as it used to. Firefox just doesn't seem to like having a lot of tabs opened, and then even when you close them that memory figure just hovers really high instead of going down. Gotta kill it and restart it to get it to go back to normal.
posted by Askr at 3:06 PM on November 6, 2011 [1 favorite]


I can only tell you that I've had this same problem for a couple of months now and never figured it out. In frustration I just started using Chrome as my primary browser, but I'll be watching this to see if anything works.
posted by Roman Graves at 3:39 PM on November 6, 2011


Last time I had a problem like this, which has been a while, deleting my profile fixed it. You might be able to get away with using Sync to back up your bookmarks and such, so they get moved over to the new profile.
posted by wierdo at 4:02 PM on November 6, 2011


I'm having this same experience with Firefox 7.0.1, but on a Mac with OSX 10.6.8. For whatever that's worth.
posted by ottereroticist at 4:11 PM on November 6, 2011


I've used Firefox for many years but the latest version (7.0.1 on Windows) is dreadful and I'm seriously considering switching to Chrome full time.
posted by humph at 4:22 PM on November 6, 2011 [1 favorite]


OK, I deleted my profile as Weirdo suggested using the instructions for finding it here, uninstalled Firefox 7.0.1, and downgraded to Firefox 3.6.23 (the only still-supported prior version) since so many of you report the same issue. Too soon to tell, but I'll report.

(Good call on surf-shield Kyle -- but I always have that disabled because, yes, it is a sea-anchor. Good to know I can make AVG stop some of its notifications, I didn't know I could do that.)

So WTF? If the hanging thing is not a peculiarity of my set-up, or something I did -- if it is 7.0.1 itself -- how is this great honking issue still in the wild? Does anyone use 7.0.1 ever? Wouldn't something like this that essentially makes Firefox unusable be an emergency for somebody?
posted by pH Indicating Socks at 5:29 PM on November 6, 2011


And oh yeah -- I was using add-ons and plug-ins interchangeably to include extensions, themes, everything not vanilla Firefox. I disabled all of that -- still had the problem. I clean-installed a new copy of 7.0.1 (though without deleting my profile) which obviously did not have any add-ons yet -- still had the problem.
posted by pH Indicating Socks at 5:43 PM on November 6, 2011


So I'm streaming the new Downton Abbey now in 3.6.23 -- fingers crossed.
posted by pH Indicating Socks at 5:45 PM on November 6, 2011


Did 7.0.1 still not work with a new profile?
posted by wierdo at 6:27 PM on November 6, 2011


I didn't try that, so I cannot say. But 3.6.23 (with a new profile) works awesome! No hangs! Yay!
posted by pH Indicating Socks at 7:44 PM on November 6, 2011


I had loads of trouble with Firefox - not at first, but just in the last year and a half or so - and I switched to Chrome. LOVE IT! What a difference! If you can't resolve the hanging any other way, try Chrome.
posted by aryma at 12:29 AM on November 7, 2011


how is this great honking issue still in the wild?

Basically, because it's open source and free so there's no one fielding irate customer calls or feeling it's specifically their responsibility.

Firefox is terrible at memory management and has been for some time now. I don't know if the code of the browser has gotten worse as versions go on, or if it's that we're more likely to have multiple tabs open these days with resource-intensive sites like Facebook and Gmail. But it is a real, serious problem with the software that can't be sloughed off on the usual suspects like extensions. I like it enough that I still use it, for now, but I acknowledge performance will degrade the longer I leave it open. So I restart it a lot.
posted by drjimmy11 at 12:49 AM on November 7, 2011 [1 favorite]


Yes, Firefox 3.6.23. Much better than anything after FF 4.0, or whatever....
posted by rumbles at 1:56 AM on November 7, 2011


I got tired of this exact problem just last week. solution, as others have said, is chrome.
posted by OHenryPacey at 10:49 AM on November 7, 2011


Hey there- I work for Mozilla. I'm glad you found a solution that works for you, though I apologize it required a downgrade. Obviously we'd love to fix this issue- if you're experiencing these painful hangs, can you try 7.0.1 with a new profile and let me know how it worked? I'm going to try to get someone from the browser team to help diagnose this so we can solve the problem.
posted by potch at 11:12 AM on November 7, 2011


pH, did you have any extensions (different from plugins, alas) installed? You can check by launching Firefox and selecting Tools from the menu-bar, followed by Add-ons.
posted by potch at 11:19 AM on November 7, 2011


A coworker has suggested using this extension as a way to clean up your bookmarks/history database. We've noticed there seem to be gremlins in this section of the code, and are working to chase them out. That's not an excuse, but it is an explanation of what we think is going on. Long-time Firefox users are prone to this due having accumulated years and years of data.
posted by potch at 11:24 AM on November 7, 2011


I also work for Mozilla! (hey potch!) I am fairly new, and trying to find the best 'self-rescue and diagnosis kit'. Until then, try some of the hints in: http://blog.bonardo.net/2011/09/30/is-your-firefor-freezing-at-regular-intervals.

FF8 also launches tomorrow, and might help with your problems as well!
posted by gregglind at 11:24 AM on November 7, 2011


Apologies for the pile on, but I'm also a Mozillian - I'm a developer who works on the Firefox front-end. It would be really valuable to hear about whether using 7.0.1 with a new profile fixes your problems. That safe mode didn't help suggests that your issue wasn't add-on related. If something in your profile is causing the hangs, it would be valuable to know what, so that we can hopefully solve the problem. I'd be happy to look into it further if you're up to it, either here or via email (gavin at mozilla dot com).

Contrary to what drjimmy1 suggests, we have a whole team of people dedicated to fielding customer complaints and prioritizing pain points for our development team to fix, but sometimes there are issues we have a hard time reproducing, which require getting better feedback from the people seeing the problems. We're hard at work both on fixing already-identified issues (Firefox 7 has significantly better memory use than previous versions), and on developing systems that will better allow us to identify pain points that we might not be experiencing ourselves.
posted by mrgavins at 2:05 PM on November 7, 2011


Hey, hey, hey -- don't misunderstand me.

I did all that stuff -- Standard diagnostic step one, restart, use Firefox, oh fudge still hanging, standard diagnostic step two, restart... Standard diagnostic step end, stuff I did not comprehend that sounded much like "you may just be hosed"... then ask Metafilter -- when I know there is Chrome, and Safari, and and, BECAUSE I love my Firefox. If Firefox were a man I would marry him, even if we are going through a rough patch right now.

It does seem that I had the issue you linked to Greg, because the hanging was indeed at regular intervals, regardless of what I was doing at the time.

Keep being awesome you Mozillans with your kickass browser. Since it may help you help others, I'll try 7.0.1 again and memail you.
posted by pH Indicating Socks at 9:24 PM on November 7, 2011


Firefox is terrible at memory management and has been for some time now.

It used to be awful, but actually I've noticed that it's gotten a lot better -- less hoggy and a lot less leaky -- in recent releases.
posted by We had a deal, Kyle at 6:21 PM on November 8, 2011


« Older I'm looking for advice on a de...   |  Bad smells filter through the ... Newer »
This thread is closed to new comments.


Post