Join 3,552 readers in helping fund MetaFilter (Hide)


Word won't type my square brackets and more!
October 25, 2011 7:43 AM   Subscribe

Microsoft Word 2010 doesn't seem to recognize some of my keyboard inputs. Maybe due to the language my keyboard is set. Can't figure how to customize or otherwise tell it that a [set keyboard shortcut] is already equated to a [set character].

Word, like Windows, is set in English.
My keyboard is set to "French(Canada) - Canadian French" which usually allows me a range of English and French signs, very useful for someone always switching between both languages (often in the same piece of work).

It implies, tough, that lots of signs are crammed in the same setup and so many useful things have to be accessed by using CTRL + ALT + [key] shortcuts (ex: those square brackets I've just typed are done with such as shortcut)

The problem is, I just switched from Open Office to Word 2010 but it seems that this new text editor doesn't recognizes or overrides most of my CTRL+ALT+[key] inputs. Especially glaring, I cannot type the square brackets in Word like I've always been able to everywhere else (even in my old crummy Word from Office 2000).

I know where I can customize keyboard shortcuts, but all I can figure out is to assign a shortcut to an action like "CTRL+ALT+[¸key] = Action: open insert symbol menu" but not to directly inserting a specific symbol itself, like "CTRL+ALT+["¸]" key] = ]"

Anyone knows how I can fix or customize this? (Hope I'm making sense!)

Thank you!
posted by CelebrenIthil to Technology (5 answers total)
 
Should mention I've tried to go from English as default to French(Canada) here which I think made a few CTRL+ALT+[key] stuff work again but square brackets still elude me.
My Keyboard is a Logitech Access Keyboard 600 but the French version of whom I can't find a picture anywhere. Here is the somewhat similar layout on the Spanish version (for lack of a better picture) with the two keys I use for bracket in red.
posted by CelebrenIthil at 8:14 AM on October 25, 2011


I've been hanging back on this one, hoping someone with a copy of Word 2010 to hand would answer, but... well, here are some pointers to articles that might help.

First, trying to get Word to play nicely:

Do you have multiple keyboard maps installed? If so, each application can have a different keyboard map set, and Word could be defaulting to a US or Canadian English keyboard map, while Open Office and everything else on your computer has been set to Canadian French. This is my best guess for what's going on. This article or this one might help. Note that keyboard map is independent of system or application language - I have Firefox set to British English but I can use a Japanese keyboard map with it if I want to.

Second, getting Word to accept user-defined shortcuts:

This article says you can assign shortcuts to symbols you use frequently, but doesn't say specifically how - the implication is that it should be obvious once you've found the right menu item. There are details here (item 4) for an older version of Word; perhaps that helps you make sense of Word 2010's interface?

Third, the last resort:

Failing all else, there's always Character Map; and as that article points out, if you have a numeric keypad, you could also memorise the character codes for your frequently-used characters and enter them using Alt and the character code. Not ideal though, I acknowledge.
posted by ManyLeggedCreature at 9:31 AM on October 25, 2011


Yeah, I was going to suggest the character map that ManyLeggedCreature suggested.

You can also try this:

1) You say you know how to customize specific keyboard commands (i.e. by clicking "Word Options", "Keyboard Shortcuts: Customize", and then entering the Alt+combination for a specific function.

1a) In the "Categories" panel, there is a section called "Common Symbols" with a bunch of French characters. Why not create a keyboard shortcut for these characters and just stick to an English keyboard?

1b) In the "Categories" panel, there is a section called "Auto Text". Why not create auto text for each of the symbols you desire and then create a keyboard shortcut for these auto text entries?

2)If you know how to create Macros, you can record a really simple macro that basically inserts the character you want. When you configure the macro settings, you can specify that you would like to call it using a keyboard shortcut

3) I used to just switch between the EN and FR keyboard. Usually you can do this by pressing CTRL+Shift or ALT+Shift. You can configure it in the Keyboard setup settings
posted by bitteroldman at 10:03 AM on October 25, 2011


Thanks, both of you!

What finally worked out, with a lot of trial and error in the Categories, I managed to clear the obscure function that was assigned to one of the key, which in turn allowed it do the square bracket as usual. For some reason I never managed to clear the other but I overrode it with an square bracket I finally found out not under symbols but in a category called "essentials". :)
posted by CelebrenIthil at 5:21 PM on October 25, 2011


Glad this worked out for you!
posted by bitteroldman at 10:32 AM on October 26, 2011


« Older I'm a newbie to the world of p...   |  I'm obese and recently went on... Newer »
This thread is closed to new comments.