Why does changing my keyboard layout in Windows change my editing language in Word?
October 4, 2010 4:40 AM   Subscribe

I often write in several languages (French, Dutch, and English) and so I use multiple keyboard layouts (on Windows 7) and multiple editing languages (in Microsoft Office 2007). I find that when I have Word open and I change the keyboard setting in Windows (from US to US-International or vice-versa), Microsoft Word will change the editing language back to English (United States), Word's default language, no matter what other language (Dutch or French) I was working in at the time.

Here is a screenshot to demonstrate what I am talking about. When I change the keyboard input style in Windows (right), the language in Word (left) will always change back to English (United States). Is there any way that I can arrange it so that changing the keyboard layout in Windows does not affect the language settings in Word?
posted by dhens to Computers & Internet (4 answers total) 3 users marked this as a favorite
 
Slightly off topic: but I don't understand the 'so' in the phrase 'and so I use multiple keyboard layouts'.

What's the use of changing from QWERTY to QZERTY or AZERTY? If you just use the US International Keyboard setting continuously, all the accents needed can be found by using silent keys.

I mean, I have to write in four different languages regularly, each with its own grammar and dictionary, three of them using diacritics, and having to change keyboard setting as well for that would make it nightmarish.
posted by ijsbrand at 4:48 AM on October 4, 2010


I use the standard US international layout for Dutch and English, I thought everyone did this? I use different layouts for Russian and Arabic and when I change the keyboard language to Arabic the spellcheck language in Word switches to Arabic as well.
posted by atrazine at 4:56 AM on October 4, 2010


Windows doesn't actually let you select a keyboard style independent of a language; the two are bound together into something called an "input language". I suspect that Word is not actually changing back to its default editing language on Language Bar selections, merely tracking the language half of the input language chosen from the bar.

Your language bar menu at present is only showing two options, and I'll bet you a dollar that although the keyboard layouts for those are US and International, the language they're both associated with is English (US).

What would probably work better for you is having three input languages installed and available on your language bar: English (US) + US Standard keyboard, Dutch + US International keyboard, French + US International keyboard. Visit the Languages control panel to set these up.
posted by flabdablet at 4:59 AM on October 4, 2010 [1 favorite]


ijsbrand: I do not like quotation marks being dead keys, especially when I write in English and I don't need them. Hence why I switch.

flabdablet: That looks like it will do quite nicely! (PS: The setting is called "Region and Language" in Windows 7 Control Panel.)
posted by dhens at 5:09 AM on October 4, 2010


« Older Slammer Time   |   Troubled small town cop uncovers a big secret:... Newer »
This thread is closed to new comments.