Join 3,523 readers in helping fund MetaFilter (Hide)


Why are Turntable.fm and Chrome not friends?
July 6, 2011 5:34 PM   Subscribe

How can I make turntable.fm work with Google Chrome? I've uninstalled and updated to the most recent version (12.0.742.112), Flash is up to date, AdBlock is disabled, and I still don't get a log-in button on the page.
posted by MsMacbeth to Computers & Internet (9 answers total)
 
I tired it on Mac OS X 10.6.7 with Chrome and I get the landing page with the "How to get in:
If you have a facebook friend already on turntable, you're in! Just sign in below" with the "Login with Facebook button"
posted by Captain_Science at 6:14 PM on July 6, 2011


I'm not sure if they've broken the FB login on purpose to limit users. The link goes here if you can use it manually. FWIW I could only get it to load in FF.
posted by msbutah at 6:24 PM on July 6, 2011


I get the same thing as captain_science with Chrome and Windows 7. Mayhap you could take a screenshot and show us what it looks like? (Cmd + Shift + 3 in OS X, then drag to take a screenshot. In Windows 7 and Vista, use the Snipping Tool from the Start Menu, then you can upload to http://imgur.com (among other places).)
posted by !Jim at 7:20 PM on July 6, 2011


Here's what I get: http://imgur.com/AxLwh.jpg

The text that says "Login with Facebook" is not clickable. I get the same unclickable page using Chrome on a Vista machine as well as on a Mac running something fairly recent. Page works fine in Firefox. It's not the end of the world to be running two browsers, but it's kind of annoying.
posted by MsMacbeth at 7:33 PM on July 6, 2011


Hmm.... msbutah's link seems to have worked for me in Chrome, with AdBlock off, on OS X 10.6.8. It brings me to a FB login page that just says "Log in to use your Facebook account with turntable". I didn't try it, though.
posted by Room 641-A at 7:59 PM on July 6, 2011


Hmm... when I load the page, it looks like that briefly before the Facebook buttons loads. Is it possible you have some variant of NoScript (preventing javascript from running) or have javascript disabled?

Another possibility is that you have Facebook Connect disabled somehow. There was a Mefi post some time ago with instructions for doing so. Does any of that look familiar to you?

If none of that sounds familiar, try doing this: go to turntables.fm, make sure it finishes loading, then right click anywhere on the page and click "Inspect Element" then click on Console in the Window or Pane that appears, and paste in any errors or anything you see there.
posted by !Jim at 10:58 PM on July 6, 2011


!Jim might be on to something with NoScript of Facebook Connect turned off. I've been using turntable.fm with Chrome on XP and Ubuntu for the past month or so.
posted by kendrak at 11:15 PM on July 6, 2011


Check your chrome extensions for something that might be interfering
posted by gryftir at 1:32 AM on July 7, 2011


Aha! It wasn't the Facebook Connect disabling that !Jim linked to, but an extension called Facebook Disconnect. So this is mostly a d'oh! moment for me, but thanks for the help!
posted by MsMacbeth at 6:44 AM on July 7, 2011


« Older I know you aren't my doctor, b...   |  obsessive litter box behavior ... Newer »
This thread is closed to new comments.