How to fix flaky/slow connection on Windows 7 PC
June 16, 2011 9:39 PM   Subscribe

The wireless internet connection on my PC has been incredibly slow and drops out frequently, even with two totally different adapters. What's going on?

I have a custom-built PC with Windows 7 that I've been using for the past 3 years with no problems. Recently, I've been having issues with my wireless internet connection. It will show 4 or 5 bars, and under "status," it will say that I have a 24mbps connection, but in trying to actually browse the web, my speed is unbearably slow (we're talking much less than 56k speeds here). Also, I get frequent disconnects where the network gets lost and has to be found again.

I should say that I started having these problems with a PCI-based adapter that I originally put in the PC when I bought it. I figured that the problems were due to the adapter failing, so I bought a USB-based wireless adapter but am having the same issues. Connection speeds on all of my other computers and devices connected to my WiFi network are fine.

What could possibly be going wrong and causing this slowwwwness?
posted by mrbob14 to Computers & Internet (11 answers total) 3 users marked this as a favorite
 
Interference. How many other networks are in your area? Have you tried switching channels? Channels 1, 6 and 11 are the best bets.
posted by Mister Fabulous at 10:04 PM on June 16, 2011


Download and run InSSIDer.

It will show you your network adaptor, plus all other networks within reach, including how strong they are, and which channels they're using. I would guess that you're going to find that a lot of other people are using the same channel you are, and you can fix your problem by changing channels on your adaptor.
posted by Chocolate Pickle at 10:19 PM on June 16, 2011


Your wireless link has two ends. You've replaced one, and it didn't fix things. Try replacing the other. Wireless routers are often not the most reliable devices in the world.

Interference is definitely a possibility. Did you acquire a cordless phone at about the same time your wireless got flaky? Some of those operate on the same 2.4GHz radio band as WiFi, and will break WiFi connections whenever the phone is in use. Best portable phones to get if you have WiFi are DECT (not W-DECT) types.

If your signal strength shows as 5 bars, I'm surprised you're not also seeing a 54Mb/s connection. The fact that your devices have negotiated a lower connection speed points to flakiness in one or the other, or interference.
posted by flabdablet at 11:21 PM on June 16, 2011


WiFi channels overlap considerably, by the way. Channel 1 doesn't generally interfere with channel 11, but either will interfere very slightly with channel 6 and vice versa. The closer are the channel numbers used by a pair of access points, the more physical separation is needed between the wireless networks they service to avoid network slowdowns.
posted by flabdablet at 11:25 PM on June 16, 2011


Probably interference as others have said: you can have a strong signal but interference can still destroy your throughput.

One option would be to use the 802.11a 5GHz spectrum allocation instead of the 2.4GHz one: it's often much less congested as there are fewer adaptors around that can use it.
posted by pharm at 1:34 AM on June 17, 2011


Well, switching the channel from 11 to 6 seems to have made a difference, at least for the time being. Odd that only one computer would be having issues when all the other devices in my house (cell phones, iBook, Win7 laptop, PS3, two Win7 desktops, PS3, and Wii) have no WiFi issues whatsoever.
posted by mrbob14 at 7:04 AM on June 17, 2011


6 is also a common channel. I would try channels that are NOT 1, 6 and 11.

Things that cause interference are cordless phones, microwaves, and things like that that emit radiation. Also big solid things can block or absorb signal such as walls, refidgerators...

Try placing your router in a closer, better location. Also consider replacing the router like flabdablet said.
posted by cp7 at 7:13 AM on June 17, 2011


The computer that's having issues is probably the one closest to the source of interference.

Trying channels that are not 1, 6 or 11 may or may not work better. If the interfering device is another computer or WAP operating on channel 8 or 9, then it will probably splatter channels 6 and 11 to some extent, channel 3 scarcely at all, and channel 1 even less than channel 3.

If you do a site scan from the computer that was having trouble and you see decent signal strength from other people's networks on high-numbered channels, then best thing you can do is move your own network to channel 1. The only time channel 6 should be the best choice is if you can see interfering networks on low channels as well as high ones.
posted by flabdablet at 7:41 AM on June 17, 2011


I would try channels that are NOT 1, 6 and 11.

That's bad manners. You're not supposed to do that. (When you select channel 6, you're actually using channels 4, 5, 6, 7, and 8. That's how the channels really work.)
posted by Chocolate Pickle at 8:03 AM on June 17, 2011


Well, the odd thing is that I live in a pretty rural area and am not even seeing any outside networks. I realize that doesn't completely rule out interference, but it is making it a head scratcher for me. At any rate, things are still going smoothly at the moment on channel 6.
posted by mrbob14 at 8:33 AM on June 17, 2011


You might be seeing a bit of multipath interference then, and changing channels might have moved the resulting dead spots around enough that the affected computer is no longer sitting in one.

If you cut over from 802.11g to 802.11n and use MIMO-capable cards and a multi-aerial router, you can actually make multipath work for you instead of against.
posted by flabdablet at 8:58 AM on June 17, 2011


« Older Assuming that the Beatles had ...   |  What does it mean to "des... Newer »
This thread is closed to new comments.