Join 3,496 readers in helping fund MetaFilter (Hide)


Vid problems on LCD projector
May 11, 2005 2:20 PM   Subscribe

The school where I teach recently purchased a LCD projector and I'm having some trouble getting it to play video... [mi]

It's a Hitachi cp-x328 and it seems to be working fine, until i try to play a video file (ie: avi, .mpg, vts type files) in windows media player or powerdvd. quicktime converts/plays the aforementioned files fine (vts, of course being the exception). but wmp and powerdvd just show a blank screen on the projector image, despite the fact that the laptop dispaly is showing the playback fine. all the other desktop features are still visible on the projector's display, but the video window is just black. the children will not accept this.

both the laptop and the projector are set to 60hz. the projector's set to auto select the video input type, but even when i manually switch to ntsc i still get no video playback. however, the projector's picking up the audio signal fine. what am i missing? the problem seems like it should be simple enough to solve, but i'm stumped.
posted by RockyChrysler to Computers & Internet (5 answers total)
 
The problem is with your video card's settings. The video is probably being displayed in an overlay produced by the video card's hardware-based acceleration. For some reason, this overlay is not piped into the video-out on a lot of video cards, and you end up seeing a black box on the projector hooked up to the video-out. The solution is to turn off hardware-based graphics acceleration (typically found under Advanced settings of the graphics or display menu within Control Panel, just turn Hardware Acceleration to None).

A better explanation here.
posted by Mercaptan at 2:32 PM on May 11, 2005


It sounds like the video card in your laptop is using a video overlay and isn't designed to output that overlay over the connector to the projector.

Try turning off overlays in Windows Media Player:

Go to Tools -> Options -> Performance -> Video Acceleration -> Advanced, and in the Video Acceleration Settings box, uncheck the Use overlays box.

Since you can see the desktop just fine, and it's just motion that isn't being shown, this is almost invariably an issue with the specific laptop/video card combination you're using, not the projector. If you can give us more info on the laptop, we might be able to help more.
posted by eschatfische at 2:33 PM on May 11, 2005


eschatfische: Interesting, so what's the benefit of using an overlay then? Or is this just another way of not having WMP use video acceleration?
posted by Mercaptan at 2:36 PM on May 11, 2005


The laptop likely has a keyboard function key that you can hit to set it to a mode in which it outputs the overlay. I can't be more specific without knowing the laptop model, but every laptop I've seen has a modifier key labeled something like "fn", which, when held down, activates a set of special functions tied to other keys on the keyboard. These'll be things like numlock, adjust brightness, etc. If you see such a key with an icon indicating what looks like a monitor screen, or a pair of screens, give it a try when you're plugged into the projector.

There's likely also be a way to do this using the control panel.

More info on the laptop would be useful...
posted by mr_roboto at 3:25 PM on May 11, 2005


projector/laptop video playback is working!

thanks; your fast answers were all very helpful!
posted by RockyChrysler at 4:05 PM on May 11, 2005


« Older Fill in the blank: "Don't...   |  I can't dance. ... Newer »
This thread is closed to new comments.