Skip

Why is Google Earth so messed up on my laptop?
May 3, 2011 1:00 AM   Subscribe

Google Earth looks totally screwed up on my Toshiba laptop with Windows 7. A grid of squares overlays all the maps. I've tried unclicking everything to no avail. Googling has not helped. Here's what it looks like. http://imgur.com/M9967.jpg
posted by wsg to Computers & Internet (5 answers total)
 
I tried uninstalling, rebooting and re-installing.
posted by wsg at 1:12 AM on May 3, 2011


try switching DirectX and OpenGL modus?
posted by Akeem at 1:51 AM on May 3, 2011


The colored squares are part of a Google Earth layer indicating coverage by various satellite services. When you say you've tried unclicking everything, do you mean layers? You can normally clear all of them at once by unchecking "Primary Database" in the Layers section of the sidebar. I'm not sure what to do if the layers are actually stuck and not going away when unclicked. Does the sidebar actually show the layers as unchecked, by the way, or are the checkboxes not responding and remaining checked when clicked on?

You can try asking at the official Google Earth Help Forum ("Problems and Errors" section). They're monitored by Google employees and occasionally get direct answers when the problem is both repeatable and solvable on their end. Make sure to mention the exact details of the problem (such as your Google Earth version number and whether layer checkboxes are responding to clicks).
posted by Rhaomi at 3:41 AM on May 3, 2011


I have a Toshiba laptop and Windows 7, went into Google Earth, found your problem. It's in Layers > Spot Image. You can uncheck this in the Sidebar.
posted by jara1953 at 4:54 AM on May 3, 2011


Thanks, all, for your help! jara1953 nailed it. I did not see that. You're the bomb.
posted by wsg at 10:13 AM on May 3, 2011


« Older How does a RMB 650k salary in ...   |  Help me pick out a $50 birthda... Newer »
This thread is closed to new comments.


Post