Join 3,514 readers in helping fund MetaFilter (Hide)


Plz help me get to data partition on XP desktop.
April 7, 2011 7:52 AM   Subscribe

XP. Trying to get backed up files off old desktop computer. Using windows explorer, I cannot 'see' a partition on secondary hard drive, like the partition is hidden. But I *can* see the files when I search for *.mp3 or *.jpg or *.txt over the whole machine; they can be seen, through search facility, read only, in a partition that doesn't even show up in win explorer. I'm not certain if I somehow hid that partition and if I did I've no idea how I did it. I want to get these files off that desktop and to a place I can access them anywhere anytime, but right now I can't access them at all. Any help you can provide greatly appreciated.

I bought some storage from google, can upload to it using Gladinet front-end, went to the old desktop to grab what I'm after and ... WTF?

First drive C: has OS and program files etc. Another 200gig drive, one partition shows up as G: in Windows explorer, shows it as being right at 100gig, not 200gig. (I have two cd drives D E and then the G: drive/partition shows up -- no F: drive/partition.) Can see nothing else on that physical disk, cannot see the F: partition, EXCEPT when I search on .mp3 files over the whole machine, search result comes up with all the .mp3's (or .jpg or .txt or whatever other backed up files) that I knew/know are on that old computer. So in search results I can see the files I want to grab but cannot get to them. So Windows knows they're there when using search but windows explorer isn't seeing them ... Now what?

Oddly, when I hooked up an external USB hard disk to dump the data onto, it shows up as F:, even though in the search results it shows clearly that the files I want are on the F: partition of the 200gig drive. When I remove the USB drive no F: drive shows up in win explorer, still shows up in the search results.

It's a real wrist-slitter in that I can see those files in the search results but cannot cut or copy them out of the search results. I want to get these files off this old machine so I can format it and send it off to Craigslist-land as a cheapie for someone who needs an old XP puter.

Skill level -- I know *some* about computers, ie "This is a keyboard" and "This is a mouse." and "This flat thing here, that's called a screen." etc. Which is to say that I'm not terribly conversant in your world, plz talk to me like you would your Aunt Myrtle in Indiana, wants to find all her cat pictures off a partition she can't see...
posted by dancestoblue to Computers & Internet (4 answers total)
 
You're not seeing the files - you're seeing the results of searching a previously-built index of those files.

In Control Panel -> Administrative Tools -> Disk Management you'll have the option to right-click on that partition and assign a drive letter to it, if it doesn't have one. If it's just missing the letter, and there's nothing else wrong with it, it will just appear in Explorer right away.

Be _extremely careful_ when you're doing this, because the option to format that partition may be presented to you and you absolutely do not want to do that.

If that doesn't work, let us know, because you have a harder problem.
posted by mhoye at 8:09 AM on April 7, 2011


Try this:

Start > Control Panel > Performance and Maintenance > Administrative Tools > Computer Management

Open up Storage > Disk Management in the tree view on the left.

You should see a nice informational view of your disks and partitions. That's a good place to start in identifying any problems.

[on preview, what mhoye said]

Incidentally, do you have TweakUI installed? It usually shows up in Control Panel somewhere I think. TweakUI gives you the option to hide drives from Explorer. Something like that could well be the issue.
posted by le morte de bea arthur at 8:10 AM on April 7, 2011


While in the Disk Management snap-in, you might see partitions with no drive letter assigned, you could then right-click and assign them a free letter to see if that brings your missing one back online.

Another thing worth trying is to turn your hidden and protected files on in Explorer so that will regularly show up when browsing (these are off by default to protect crucial files from being deleted). To do this...open My Computer, click on Tools then Options. Click on the View tab and uncheck "Hide Protected System Files" and any other similar settings around that area. (going from memory).
posted by samsara at 8:32 AM on April 7, 2011


XP can be not very smart about assigning drive letters to removable drives. Try this: plug in your external drive, then go into Disk Management. Using the process the other posters have mentioned, change the drive letter assigned to the external drive; make it a fairly high one, like J or N or something. You'll get a warning that says something to the effect that "Changing this drive letter may make it impossible to run some programs that rely on this drive letter." It's okay to say "Yes, I'm sure" to this one. Once you've done that, exit out of the Disk Manager, then reboot your system. Once the system comes back up, you should be able to access the other partition as F.

WARNING: Please don't click on "Format this disk" or anything like it. Also, I'm not your computer tech, if you accidentally do format your disk you can lose data, I'm not responsible, etc. Be careful.
posted by no relation at 9:26 AM on April 7, 2011


« Older I need a list of quintessentia...   |  I took a picture and posted it... Newer »
This thread is closed to new comments.