Join 3,416 readers in helping fund MetaFilter (Hide)


I get the internet, my housemate doesn't - but we're both connecting to the network. What gives?
March 2, 2011 10:16 PM   Subscribe

Internet connection issues in bachelor pad of two pseudo-luddites. Both macs. Both show connection to our dedicated, password protected network. I get internet connection, my housemate doesn't. What's up?

Thanks in advance.

We recently moved into a new place. The modem and router things are connected via cable modem in my bedroom. I use a MacBook Pro. My internet works fine.

My housemate, whose computer is on the other side of my bedroom, no more than 5 feet from the router, and, while it shows he's connected to the network, doesn't have internet access. He's using a mac mini.

We're using comcast, who apparently can't help us.

Anyone know what the problem might be?

Thanks again for your help and time. You guys rule!
posted by Lutoslawski to Computers & Internet (15 answers total)
 
Assuming he's tried restarting? Turning airport on and off?
posted by Patbon at 10:32 PM on March 2, 2011


Does he have proxy server settings populated in his browser?
posted by Burhanistan at 10:34 PM on March 2, 2011


Tried all the turning on and off, going through the diagnostic help thing, etc.

Burhanistan - how would I find out if he does or not?
posted by Lutoslawski at 10:49 PM on March 2, 2011


Here. His should either be empty or identical to yours.
posted by Burhanistan at 11:04 PM on March 2, 2011


Assuming he's using Safari.
posted by Burhanistan at 11:05 PM on March 2, 2011


If he's 5 feet from the router, have him turn off his wifi. Attach a cable from one of the open ports on the router to the ethernet port on the mac mini. Problem solved...and he's got a faster than wifi connection.
posted by hal_c_on at 2:27 AM on March 3, 2011 [1 favorite]


Try the other things people mentioned. Specifically what hal_c_on says. If he can get access to the internet when wired in, then the issue is with his wireless settings and not the computer. Here are other thigns to try

- is the problem happening with only one browser, or all browsers [if only one, suspect proxy settings]?
- are you sure your friend is connecting to YOUR network and not just some random linksys network?
- Can he do other internet stuff when connected but not surf [like ftp or Skype. if so there may be DNS issues or something weird with traffic through the http:// port]
- Did you step through the assistant in the system preferences? Go to System Preferences - Network - click on Airport on the left and then click "Assist me." button on the bottom. Click "diagnostics" when the window comes up. Step through it. What does it say at the end?
posted by jessamyn at 5:57 AM on March 3, 2011


Check your network settings and make sure you both have the same gateway and DNS servers.
posted by empath at 6:35 AM on March 3, 2011


then have him try to ping the gateway and dns servers to make sure he can get to them.
posted by empath at 6:36 AM on March 3, 2011


Thanks everyone! Were still having issues, and I apologize for going to bed last night without dropping a note.


If he's 5 feet from the router, have him turn off his wifi. Attach a cable from one of the open ports on the router to the ethernet port on the mac mini. Problem solved...and he's got a faster than wifi connection.


Yeah, we're considering that option. We'd have to put a hole in the wall, and we're trying to avoid that, but if all else fails, yep.

Jessamyn - No, there's no connection on any browser. We're both running Firefox, but we tried Safari as well. None of the other internet stuff works (no skype either, etc.) We did go through the system preferences stuff, and it always ended in 'we can't solve your problem, contact network administrator.' And yeah, I'm sure he's connecting to our network and not someone else's.

Empath - I'm going to check on those suggestions. Thanks!
posted by Lutoslawski at 9:15 AM on March 3, 2011


It could be a million things. First, can you pop up the terminal and ping the router (if you can figure out its IP address?) Can you ping google.com? Type "ping google.com" or "ping someipaddress" and hit enter.

... If time goes by and you can't get anywhere, memail me, I do this kind of thing all day and am local to you and could probably take a look and get you going.
posted by floam at 11:00 AM on March 3, 2011 [1 favorite]


If your cable modem is what you're both connecting to, it may be configured to hand out only one IP address.
posted by rhizome at 1:24 PM on March 3, 2011


Try going into router settings and adding permissions for devices (MAC addresses.) I solved a problem like this on Sunday, this was the only fix, esp for Apple devices (iPhone and Macbook).
posted by Riverine at 5:12 PM on March 3, 2011


Before putting a hole in the wall, MOVE the computer into the same room, attach the cable to the computer and the router and see if its working. If so...then you know the problem is the wireless and you can either work on that or punch a hole in the wall...or get a long enough cable so that you don't have to.
posted by hal_c_on at 11:39 PM on March 3, 2011


Ok, thanks everyone for all the input! We're going to try the last couple suggestions today and see if we can get it working. Will keep you updated. Again, thank you thank you for your time and advice.
posted by Lutoslawski at 9:41 AM on March 4, 2011


« Older How do I go about seeing a the...   |  I'm going somewhere this weeke... Newer »
This thread is closed to new comments.