Join 3,496 readers in helping fund MetaFilter (Hide)


Like a midget ninja.
December 13, 2010 8:11 AM   Subscribe

Why can't I watch YouTube videos in Google Chrome?

YouTube videos recently up and quit playing nice with Chrome. Videos are playing the audio fine, but the video plays every 20th frame or so - very short and choppy. Possibly relevant details:

- Windows XP
- Google Chrome v. 8.0.552.215
- Happens with any and all YT videos, they all work fine in FF when I tab over to it to play them there, which is getting annoying.
- Other videos (ESPN, CNN, etc.) all work fine on other sites.
- I've cleared the cache multiple times now in Chrome to no effect.

Any ideas? (Kind of like this mostly-unanswered question recently but different enough that I thought mine might be a different issue.)
posted by allkindsoftime to Computers & Internet (6 answers total)
 
Youtube is probably seeing you are using Google Chrome and is trying to use the html5 video player. Use that link to see if you are opted in.
posted by ChrisHartley at 8:21 AM on December 13, 2010 [1 favorite]


Failing that, uninstall Chrome, reinstall chrome, reinstall flash.
posted by dougrayrankin at 9:37 AM on December 13, 2010


You probably need to (re-)install Flash.
posted by jeffamaphone at 9:48 AM on December 13, 2010


Are you using adblock? I've noticed that every now and then chrome, adblock and youtube don't play nice together. If you are using adblock try turning it off and see if youtube starts working again.
posted by aspo at 10:09 AM on December 13, 2010


[YouTube engineer here who works on, among other things, latency/developing world connections and HTML5]

Ahh, so you're in Africa? That explains it.

Recently we launched a super-low-bitrate format in Africa as a trial. This was due to numerous complaints from people with very slow connections. We're doing some tests with it as the "default" format. It should have normalish audio but extremely choppy video (because it's only like 46 Kbps).

You _should_ be able to change the resolution by using the control bar (it should say "240p Light" somewhere to the right of the slider, try clicking on that and see if you can choose "360p").

It occurs to me that there should be a way to opt out of this better for users who know their connection is fine but happen to be served by one of the generally slower ISPs. I'll add that for Wednesday.

Let me know if changing to 360p fixes it. If for some reason you're not seeing that option let me know that too!

---
(Leaving this part of my answer here b/c it's relevant to what other people said... but I wrote this before I checked your location!)

Installing/uninstalling Flash will have no effect, as Chrome has its own built-in version of Flash.

If this was happening prior to Wednesday, it could be the HTML5 thing (which should be fine but doesn't always play nice). But since Wednesday's push we are only serving that to beta/dev channels (Chrome 9+) again. As a side note here, if you see the choppiness look in the controls bar near where the resolution (360p, 480p, etc) is listed, if you see a badge saying "HTML5" you're in the html5 player. You can opt-out if you've been opted-in by clicking on that or right-clicking on the player and selecting "About HTML5" which will take you to where you can opt-out.
posted by wildcrdj at 11:55 AM on December 13, 2010 [7 favorites]


So you _should_ be seeing this only on the "Feather" page, most easily identifiable by a big green box on the right hand side that says "We have detected you are visiting with a potentially slow connection".

Choosing either "Just this once" or "Permanently" should opt you out of both Feather and 240p Light accordingly, so if you know your connection can handle it, or you're willing to pause and wait for buffering before playing, just go ahead and "Permanently" opt out of Feather.

I'm fixing a small bug but I think this should already work, let me know (here or via MeFiMail) if it doesn't for some reason.
posted by wildcrdj at 4:56 PM on December 14, 2010


« Older Want marketing department argu...   |  I want to decorate a rec room ... Newer »
This thread is closed to new comments.