Join 3,432 readers in helping fund MetaFilter (Hide)


Two WRT54G routers - Am I doing this right?
May 25, 2010 10:29 AM   Subscribe

Optimizing my home network, using a pair of Linksys WRT54G wireless routers + Tomato. Best practices?

Home wired + wireless network. Two WRT54G wireless routers, both running the latest Tomato build:

First WRT54G (v.1) in the basement, running DHCP. Printer and home computer plugged in to this router via Cat5.

Second WRT54G (v.3) is upstairs, connected to the first router by Cat5, with wireless on but DHCP disabled. HD TiVo plugged in via Cat5.

Both routers are configured to run as access points plus WDS. Both routers set to use WEP security (because the wireless adapter for our older Series 2 TiVo can't handle anything else). Same SSID, same passphrases, same channel.

As far as I can tell everything is working correctly - but the wireless strength seems to be less than I expected. Our older TiVo for example has a really weak signal. I'm wondering if the routers are too close together - it's a small house, and I doubt the Cat5 cable between the routers is longer than 50 feet - would that cause a problem? iStumbler sees them both, but for some reason only shows security on one of the routers (the other is listed as "open"). Additionally, I have an auto-sensing program on my Mac (MarcoPolo) that determines location based on things like SSID, and since adding the second router it flakes out every minute or so, switching my location back and forth, which is really annoying. Is this possibly a result of a bad setup, interference, or just my computer being handed off between routers? Like I said, things seem like they're working; all the devices are connecting (iPhones, TiVos, Wii) but they aren't all getting the signal strength I expected. Quality of connection is ranging between 25-50, for devices within just a few feet of the router(s).

I'm even starting to wonder if I need to enable WDS at all for this to work. From what I can tell, WDS is usually used when the routers are NOT connected to each other, but I want them to stay wired (speed matters, especially for Netflix streaming to the HD TiVo). Any suggestions?
posted by caution live frogs to Computers & Internet (7 answers total) 4 users marked this as a favorite
 
Same SSID, same passphrases, same channel.

You need them to be on different channels. I believe Tomato can autoselect channels, which would be fine, or you can use the built-in "site survey" feature to pick two good ones. 1, 6, and 11 are the standard ones to use because using the others will result in overlap. If you find that the area your in is very congested, though, those in-between channels might end up being your best bet.
posted by contraption at 11:09 AM on May 25, 2010


you're. bleh.
posted by contraption at 11:10 AM on May 25, 2010


Different channels? All the documentation I have seen says they need the same channels for automatic hand-off to work between routers. Tomato FAQ, Wikipedia, random Google searches - they all say use the same channel.
posted by caution live frogs at 11:28 AM on May 25, 2010


Oh, I see, WDS does need them to be on the same channel. Every time I've done a setup like you describe, I've done it without WDS, with the same SSID and key but different channels and roaming has worked great. Since your scenario doesn't seem to get any benefit from WDS, I'd recommend turning it off and trying it in the traditional way.
posted by contraption at 11:39 AM on May 25, 2010


I don't understand why you are using WDS, and I'm not convinced you even need two wireless access points. Disable the WDS and put your routers on channels, ideally channels separated from each other and any other wireless networks by as far as possible.. As long as you have the same SSID & encryption key, you should be able to get seamless roaming. Experiment and see whether you get get better coverage with wireless enabled on both, or just one or another.

If you get acceptable coverage with just one, consider putting the other in client mode and using it to connect your older Tivo (I assume it has a wired ethernet interface too) so you can use WPA+AES encryption, rather than WEP.
posted by Good Brain at 5:06 PM on May 25, 2010


Your mistake is enabling WDS
From Wikipedia (emphasis mine)
A Wireless Distribution System (WDS) is a system that enables the wireless interconnection of access points in an IEEE 802.11 network. It allows a wireless network to be expanded using multiple access points without the need for a wired backbone to link them, as is traditionally required. The notable advantage of WDS over other solutions is that it preserves the MAC addresses of client frames across links between access points.[1]

You have a wired backbone. Turn off WDS. Use different channels (one of each 1, 6, or 11 assuming you're in the US). Same SSID and password / security type.
posted by defcom1 at 5:17 PM on May 25, 2010


That seems to have done it - thanks!
posted by caution live frogs at 2:39 PM on May 31, 2010


« Older Looking for recommendations fo...   |  Movie Or Television Show with ... Newer »
This thread is closed to new comments.