Join 3,553 readers in helping fund MetaFilter (Hide)


How did I change my keyboard settings (and how do I change them back)?
February 16, 2005 9:17 AM   Subscribe

The keyboard settings on my laptop changed (seemingly without cause or explanation) in the middle of a computing session. Did I do something to cause this? How do I fix it? [MI]

I have a Sony VAIO that is relatively new, purchased within the last six months. I was working on a project and took a break, and when I returned, some of the letter keys now produce numbers.

m = 0
j = 1
k = 2
l = 3
u =4
i = 5
o = 6

Most of the keys still work correctly, but some others also produce non-number results that aren't right. "p" gives me back an asterisk, for example. Did I change a setting somehow to cause this that is an easy fix? Or is it a maintenance issue?
posted by jeffmshaw to Computers & Internet (7 answers total)
 
You turned on the number lock. This is designed to replicate the 10-key pad you'd find on the side of a standard keyboard.
Look on your keyboard for a "fn" function key. Then look at the number keys at the top of the keyboard. One of them should have either a crude drawing of a 10-key pad, or "num lock." Hold "fn" + "num lock" to turn off this setting.
posted by Coffeemate at 9:23 AM on February 16, 2005


Turn off "function lock." There should be a key on your board that says "function lock"

Notice on the M, J K... etc. keys the little purple numbers corrosponding to your error chart there.

Holding down function + M = 0

There's a "lock" key for function, like caps lock, so it's always on "function"

Make sense?
posted by nitsuj at 9:25 AM on February 16, 2005


7,8 and 9 are still 7, 8 and 9, right? Sounds like you've got an alternative numerical pad setting (for those who touch-type and like having the numbers in pad format, as on a standard keyboard). I don't know how this functions for this particular model, but I shouldn't think it's anything you'd need to take it back to the shop for.
posted by altolinguistic at 9:26 AM on February 16, 2005


I have a Thinkpad which likes to enter this mode without user intervention, especially vexing when trying to enter the Windows 2000 password where all you see are asterisks as you type oblivious to the fact that you are actually entering numbers instead of letters. I don't know how yours works, but on mine I type shift-numlock to exit this mode.
posted by caddis at 10:05 AM on February 16, 2005


My Toshiba 1110 throws itself into some sort of freaky "let's pretend the CTRL key is pressed all the time" mode. It seems to be caused by some mystical combination of CTRL, SHIFT, FN, and ALT keys. Sometimes I can get it to turn off, sometimes I have to reboot...
posted by five fresh fish at 11:34 AM on February 16, 2005


I agree with what Coffeemate said, simply because my Sager "does" that all the time (nope, not my fault!!!). Check around for numlock - it can be confusing on a lappie at first.
posted by melt away at 11:57 AM on February 16, 2005


Thanks, all, for the diagnoses and suggestions. I'm posting again to express gratitude and to mention that, like caddis' Thinkpad, my VAIO requires shift-numlock, not fn-numlock, to get out of number lock mode.
posted by jeffmshaw at 7:06 PM on February 16, 2005


« Older Conferences and trade shows. W...   |  I'm trying to remember a parti... Newer »
This thread is closed to new comments.