Join 3,377 readers in helping fund MetaFilter (Hide)


wordpress insanity: link the domain URL to a static front page
March 16, 2010 9:45 PM   Subscribe

How can I link my domain URL (www.domain.com) to a static homepage on Wordpress. Please don't say "change the reading setting", because that totally doesn't work.

Hello everyone~

I'm trying to build a simple website for someone using Wordpress. (We've chosen Wordpress for various reasons and at this point in time, it is impossible to change our decision.) We've both agreed that for design and aesthetic purposes, we don't want the domain URL to display a blog posts page, as is default for wordpress. That is, when we type www.domainhere.com, we want a static page with a welcome message to display.

A bit more info before I go on:

- The wordpress site I am building is hosted with Yahoo Web Hosting. So, it is Wordpress thru Yahoo... (does that make sense/any difference?)
- It is installed in a subdirectory of the domain called "site", so when viewing the website, clicking the header will direct you to www.domain.com/site. But at the same time, simply typing in www.domain.com will take you to the same page, presuambly because I selected the "make this my homepage" option in Yahoo, when setting up the wordpress account. So www.domain.com and www.domain.com/site look (at least on the surface?) the same.

Back to my question: I've been searching for a way to change the front page to a static page, but I keep getting the "change reading settings" solution -- where you create two new pages, one titled "Home" and the other titled "Blog", and then set "Home" as the front page and "news" as the post page in the admin>settings>reading panel.

HOWEVER, my problem is this: when I type in www.domain.com, I don't get the static "Home" page I created, obviously, because the static page's URL would be www.domain.com/site/home (I hope that I'm making this clear).

How can I link the domain URL (www.domain.com) to a post-free static page? I'm not too worried about the clicking the header and being directed to www.domain.com/site thing, since I've installed a navigation bar plugin that uses an "a href" type thing to link to different parts of the site.

I just want to be able to type in www.domain.com and get the static front page.

Sorry if my question is stupid, but this is the first time I've ever tried to build a site using Wordpress (which was chosen primarily, because I didn't want to have to build a site from scratch -coding skills are pathetic- and because it will be much easier for my friend to update the site himself.

Thanks!
posted by joyeuxamelie to Computers & Internet (7 answers total)
 
URL forwarding from the domain name registrar?
posted by FlamingBore at 9:50 PM on March 16, 2010


sorry, but what exactly does that mean/entail?
posted by joyeuxamelie at 9:51 PM on March 16, 2010


joy, we need more details on where you bought your domain and how your wordpress site is being hosted. Tell us who you are paying for each of these things.
posted by bigmusic at 9:54 PM on March 16, 2010


i'm pretty sure everything is being paid to Yahoo.

Yahoo Webhosting offers the options of building your site using :
A) their ugly templates
B) building from scratch, using something like Frontpage
C) using wordpress as a platform (sorry if that's the wrong term)

We chose wordpress, because I can't code... I can however, customize a basic blog template to make it look a lot different -- mostly using widgets and such.

When you log into your account in Yahoo web hosting, you can choose to setup a wordpress account...through Yahoo I guess? So that's what we did.
posted by joyeuxamelie at 10:00 PM on March 16, 2010


I think (because this is worded very confusingly) that you need to:

1. Get rid of the "site" subdomain and put the site directly on your domain. I'm not sure why you'd install the main webpage to a subdomain--it makes no sense in terms of design or navigation. If, for whatever reason, you want your site header to link to someplace else (say, a blog post), just change the link URL.
2. Create a blog post with the content you want for the static page. Go to appearance->editor->Main Index Template (index.php) and remove any of the code related to the bloggy stuff--date, time, comments, etc.

This is what I did on my professional website (www.phoebenorth.com/ - self link for example purposes only, promise!). The linked pages in the header are just "pages", whereas the main page is a blog entry. There may be a simpler/more elegant way to do it, but this worked for me.
posted by PhoBWanKenobi at 10:10 PM on March 16, 2010


Your problem is probably related to the way Yahoo is automatically installing wordpress for you (i.e., in a subdirectory called "site" and then aliasing http://www.domain.com to http://www.domain.com/site/ -- probably via an .htaccess file). You need to move your WordPress install to the root level of your site (up one directory) and then things will work like you expect.

You should be able to just install a fresh copy of WordPress there, change the wp-config.php file to match the one in /site/ and then change the WordPress address (URL) under Settings > General from http://www.domain.com/site/ to http://www.domain.com/

I'm not familiar with Yahoo hosting specifically, but this approach might work for you. Good luck!
posted by maniactown at 11:01 PM on March 16, 2010


"Your problem is probably related to the way Yahoo is automatically installing wordpress for you (i.e., in a subdirectory called "site" and then aliasing http://www.domain.com to http://www.domain.com/site/ -- probably via an .htaccess file)"

I think you are right. When I set up the blog, I was not given the option to install in directly into the domain.com folder. I had to create a subdirectory.

Thank you for the info, maniactown!

For some reason, after about 10 minutes and bulk updating the pages under the edit pages section, I got the home page and blog page to act as I wanted them to... !?

But if the site starts acting up, I'll try out your solution.
posted by joyeuxamelie at 12:09 AM on March 17, 2010


« Older What is the job market like in...   |  He's the man of my dreams (lit... Newer »
This thread is closed to new comments.