Skip

Make Droid Play Nice with My Network
March 1, 2010 10:40 AM   Subscribe

Got my Motorola Droid. Love my Droid. However, Verizon's impressive map doesn't seem to include the cell phone black hole which is my neighborhood. I was hoping to hook my Droid to our home wireless network to avoid the slow connection problem, and dutifully inputted our WEP key, but all efforts to get the Droid on home network have been a bust. I did check the Droid user forums and download a couple of apps -- still no luck. What else can I do besides return my Droid? (Which ain't gonna happen.)
posted by bearwife to Technology (9 answers total)
 
is it just not seeing the network? What exactly is the problem? What version is your OS?
posted by Espoo2 at 10:54 AM on March 1, 2010


What's the make and model of your router? After you figure that out, go to the manufacturer's website, get the newest firmware, and flash the router with it.

After it reboots, turn off the wireless security to try to diagnose if it's a droid problem or a wifi security problem.

Once you can get online, go back and turn on wifi security, except switch to WPA2. There is a well known security flaw in WEP.
posted by sharkfu at 10:58 AM on March 1, 2010


what is your home router? perhaps it's DHCP service is hung and a reboot would let your droid get an IP address. Have you tried turning off wep and seeing if it can connect on an open network? we really need more details to do more than just guess wildly :)
posted by jrishel at 10:59 AM on March 1, 2010


If your using WEP encrpytion on your router currnetly, youll probably have to upgrade to WPA Personal
posted by rosswald at 11:18 AM on March 1, 2010


Without more information about your setup and things you've tried, these would be the steps I would take:

Turn off wireless (WEP) security. Can the the Droid connect to the open wireless network?

If yes, re-enable wireless security (and definitely choose WPA/WPA2 if at all possible, as WEP is non-secure). Can the phone connect now? Double and triple check that the password is entered correctly.

If the phone could not connect to the open wireless or to your re-enabled security, take the phone to a friends' place and try to connect to their network.

If the phone can connect to another open and/or secure wireless network it suggests the issue is with your router. Is your router set up for MAC address filtering? MAC address filtering would prevent your phone from connecting to the router even if the password was correct. If that's the case you need to either disable MAC address filtering (it's not particularly useful from a security standpoint anyway) or figure out your phone's MAC address and add it to the list in the router settings.

If that still didn't work I'd reset the router completely (often there is a little button you can press with a paper clip while the router is unplugged) and set up the wireless network again, and I'd try selecting different wireless channels on the off chance that interference from other networks is causing problems. If that didn't fix things I'd buy a new router.

If the phone couldn't connect to any wireless networks at all, since you tried it at a friends', then it's time to take the phone to Verizon for troubleshooting.
posted by 6550 at 11:19 AM on March 1, 2010


Thanks all. Good questions, some of which I can't answer right now as I'm at work and away from home router.

The Droid IS seeing the home network, though with a fair to good signal, whereas all other wireless detecting devices like laptops see the signal as strong. It does not connect, though: it tries and says it failed. I'm haven't tried other wireless networks except the one at work, which is problematic for all devices on a regular basis and which I don't need to connect the Droid to anyway.

The reason I'm not willing to take the Droid to Verizon is that they don't troubleshoot, they give you a refurbished replacement phone. No thanks.

I will check on router make and try your suggestions tonight.
posted by bearwife at 11:41 AM on March 1, 2010


Oh, and the Motorola Droid OS is Android 2.0.
posted by bearwife at 11:44 AM on March 1, 2010


Forget wireless security. Just set MAC filtering and only allow the Droid and whatever you want on your network.
posted by i_am_a_Jedi at 3:08 PM on March 1, 2010


please don't use MAC filtering. It's less than useless.
from http://blogs.zdnet.com/Ou/?p=43

MAC filtering: This is like handing a security guard a pad of paper with a list of names. Then when someone comes up to the door and wants entry, the security guard looks at the person's name tag and compares it to his list of names and determines whether to open the door or not. Do you see a problem here? All someone needs to do is watch an authorized person go in and forge a name tag with that person's name. The comparison to a wireless LAN here is that the name tag is the MAC address. The MAC address is just a 12 digit long HEX number that can be viewed in clear text with a sniffer. A sniffer to a hacker is like a hammer to a carpenter except the sniffer is free. Once the MAC address is seen in the clear, it takes about 10 seconds to cut-paste a legitimate MAC address in to the wireless Ethernet adapter settings and the whole scheme is defeated. MAC filtering is absolutely worthless since it is one of the easiest schemes to attack. The shocking thing is that so many large organizations still waste the time to implement these things. The bottom line is, MAC filtering takes the most effort to manage with zero ROI (return on investment) in terms of security gain.
posted by defcom1 at 3:14 PM on March 1, 2010


« Older What are some really good vege...   |  Kansas City filter: Where sho... Newer »
This thread is closed to new comments.


Post