Join 3,433 readers in helping fund MetaFilter (Hide)


Facebook's taken over my GMail
February 1, 2010 1:22 PM   Subscribe

When I log into Gmail, Firefox redirects me to a page on Facebook. What gives?

Over the past couple of days, when I log into GMail (even using the secure site), I am redirected to a page on Facebook that says the following:
----------------
We've redirected you to this page as a precaution

Some websites may try to trick users into providing information or otherwise risking their online security, through a process called clickjacking. The website you were on may not have meant any harm, but we brought you here as an extra safety measure.
----------------

I've tried this with Firefox on a Mac and on a PC, and get this issue on both.

Any suggestions?
posted by reenum to Computers & Internet (10 answers total) 1 user marked this as a favorite
 
Have you already cleared all of your browser history?
posted by Burhanistan at 1:30 PM on February 1, 2010


I've been intermittently having a similar problem (usually Facebook redirecting to Myspace) and it turns out to be a bug in my wireless router: a Linksys WRT160N v3. If that's the source of your problem, see here and here for more details, including a workaround (but no real fix yet).
posted by The Tensor at 1:42 PM on February 1, 2010 [1 favorite]


Can you type the URL directly into the address bar and hit enter?

https://mail.google.com

If that redirects you then it sounds like someone has control over your internet connection from somewhere between your pc and your ISP. You mentioned trying this on multiple computers. Were they at the same location. i.e. were they both using the same internet connection? It is possible that your modem was compromised and someone has put in a mapping at the hardware level to redirect certain URLs.

If you aren't able to connect to gmail by typing in the URL directly, try shutting off your cable or dsl modem and turning it back on. If that doesn't work try doing a reset to default settings on the modem. You'll have to look up the specifics of how to do that for whatever modem you have but it usually amounts to holding in the power or reset button for a ten count while another button is held in also.

The Tensor's addition made while I was typing this also references a modem level remapping.

posted by Babblesort at 1:45 PM on February 1, 2010


The computers are in different locations. The Mac is my home PC and the Windows machine is my PC at work.
posted by reenum at 3:13 PM on February 1, 2010


I've cleared my browser history multiple times.
posted by reenum at 3:13 PM on February 1, 2010


What URL are you using to access Gmail?
posted by ErikaB at 3:26 PM on February 1, 2010


Like Babblesort asked, did you try typing in the URL directly? Or are you relying on a bookmark? If you are relying on a bookmark, this might be the problem.
posted by whiskeyspider at 3:29 PM on February 1, 2010


I have tried typing in 'gmail.com' as well as using a bookmark and auto complete.
posted by reenum at 5:20 PM on February 1, 2010


Have you tried other browsers with the same results? How about starting Firefox in safe mode? Since it's two different operating systems and two different locations, the only common thing I can think of is some whacky malfunction in a extension that is installed in both your versions of Firefox.
posted by donnagirl at 7:48 PM on February 1, 2010


gmail and facebook both use openId. Is it possible you selected the options to link your logins, and are now being redirected becasue of that?
posted by nalyd at 5:08 AM on February 2, 2010


« Older Investigating a New York City ...   |  Where in or around the Austin,... Newer »
This thread is closed to new comments.