Skip

Why has my Firefox slowed down?
January 17, 2005 8:49 AM   Subscribe

Why has my Firefox slowed down? It started a few day ago. Sometimes it takes several minutes for a page to load. Some only partially load, then stop. Some don't load at all. Not every page is this way, but I'd say about 20% suffer from one of these problems. IE is zipping right along though. I did a virus check, ran Spy-bot and Ad-Aware and cleaned up my registry. Yet the problem persists. Oh, I'm running 1.0 and XP Pro.
posted by zorro astor to Computers & Internet (8 answers total)
 
How long have you had firefox running? Firefox 1.0 is still not very well optimized ... I had two tabs open the other day (I'd had Firefox running continuously for about 18-20 hours, about half of which I wasn't using it), and the process in Task Manager was almost 600MB. That, admittedly, is an outlier.

If FF is doing this when you're just starting it could be that your profile has become corrupted. Were you using Firefox before the 1.0 release?

Also, check out http://forums.mozillazine.org/ if you haven't. The people there are, on balance, friendly and helpful (unless you post a tech support question in the builds group), but please search before asking. :)

Anyway, is there any consistent time or consistent URL that causes this problem? Does it happen immediately when you restart Firefox? Do you have any plugins installed in Firefox?
posted by socratic at 9:22 AM on January 17, 2005


Odd...I have seen at least a half-dozen incidents of this over the last couple of days. No answers on my part, unfortunately...just wanted to point out that it doesn't seem to be just you.
posted by davidmsc at 10:39 AM on January 17, 2005


I had exactly these symptoms, about a month ago. I came to believe it was my network connection (cable modem, 802.11g, WPA) rather than Firefox. Believe it or not, the thing seemed to fix it was changing the default IP address of my router.
posted by coelecanth at 11:27 AM on January 17, 2005


Well, like I say, IE is loading the pages as quickly as it always has, which is currently much faster than Firefox.
posted by zorro astor at 11:43 AM on January 17, 2005


It could conceivably be a caching issue, either someting corrupt in the cache on your computer or something wonky with the way Firefox is checking the cache.

I'll tell you the problem I've been having, and it's about to drive me insane. If I click on a very large file (say, larger than 250kb) in Firefox and my personal firewall is running, Firefox locks up and it's nearly impossible to get anything done in Windows until the file (apparently) finishes downloading. If I disable the firewall, the download goes on without a hitch. "A ha!" you might say, "It must be the firewall!" But, alas, it's happened with two different firewalls, and, more importantly, it doesn't happen with IE.

Do you have the AdBlock extension installed or anything similar? I've noticed pages hanging when the browser couldn't successfully talk to an ad server because I had it blocked.
posted by socratic at 1:52 PM on January 17, 2005


firefox 1.0 currently has a memory leak issue, which may be the cause for the slow loading times, there are two or three modifications you can make to the config file to help with the cache size and possible memory leaks. More info Here. Additionally, you can perform a search for "Firefox Secrets"

Hope this helps.
posted by djdrue at 3:47 PM on January 17, 2005


It's possible it was adblock. I used to have it configured to remove ads instead of just hide them. Some webpage, hotmail or yahoo I think, needed to load an ad or graphic for the page to continue loading. The fact that adblock kept removing the image just started an endless loop where the page replaced the ad (surely some javascript) and adblock removed them. Gridlock. It was annoying until I figured out what was going on. Just hide the ads, it's the same effect.

Zorro Aster: try posting this problem over at the mozilla zine forums, do a search first. I'll be they can help you out.
posted by sic at 3:56 PM on January 17, 2005


Firefox slowed down for me recently, when I added an extension called autoform. Have you made any changes like that? Uninstalling that extension has fixed the problem for me.
posted by acridrabbit at 9:03 AM on January 18, 2005


« Older Aside from the recent blockbus...   |  Is it possible to set up a tel... Newer »
This thread is closed to new comments.


Post