Join 3,363 readers in helping fund MetaFilter (Hide)


iTunes keeps reordering my songs!
November 12, 2009 12:06 PM   Subscribe

iTunes won't order/list/play songs in an album in the order of the track number. I have specified the correct track number of the songs in the info thing, but it won't sort according to that field within an album. Is there some way to get around this?

I am downloading albums (from friends' bands) to my computer, and then dragging those folders and dropping them in the "Automatically Add to iTunes" folder (which was created by iTunes 9, I think). iTunes then does some magic which makes the songs appear in iTunes (and is organizing them in the iTunes Music Folder). But the songs are in the wrong order. Is there some other way to add albums to iTunes? I thought this drag and drop thing would keep everything nice and organized, but perhaps not. This is only happening with these downloaded albums, not with albums I buy through iTunes. (I searched around for answers, but they were so varied, I wasn't sure what to do. I am not an iTunes power user, but I would like to be).

I have a Windows 7 computer with iTunes 9. Thanks.
posted by bluefly to Computers & Internet (7 answers total) 1 user marked this as a favorite
 
I noticed this as an issue before. First, make sure the tracks are correctly numbered within iTunes (1 of 12, 2 of 12, etc...) Then, fill out the disc fields as that's where it really seems to get fouled up. Even if you technically only have one "disc", make sure you select all songs, edit their collective info and then enter '1 of 1' in that disc field, and then hit OK. Hopefully that'll get you ordered OK.
posted by Rewind at 12:15 PM on November 12, 2009


Are these albums with multiple artists? I find setting the "compilation" flag for an album helps alot with getting itunes to group tracks together correctly.
posted by nomisxid at 12:17 PM on November 12, 2009


A few buggers I've found:

If some of the tracks are labeled "Disc 1 of 1" but others just have that blank, they don't order right.

If the "Album Artist" is not consistent then sometimes they won't order right.
posted by arniec at 12:17 PM on November 12, 2009


iTunes 9 for Mac had a bug in it that failed to acknowledge disc order properly, so you would get an album with discs A and B ordered A.1, B.1, A.2, B.2, etc. If this is the problem you're seeing, update to the most recent version of iTunes and it should be corrected. I'm on iTunes 9.0.2 for Mac and no longer see this problem. I don't know whether this bug appeared and/or has been corrected on Windows iTunes, but maybe someone who uses it on Windows can tell you.

Otherwise nthing check the tags, specifically Title, Album Artist, Disc # of #, and the compilation flag.
posted by immlass at 12:24 PM on November 12, 2009


If the above advice isn't clear enough. Click on "Music" and then search for the title of the album until only those songs on that album appear. Then click on a song and click COMMAND+I (Get Info) and set the tracks to the correct order (1 of 12, 2 of 12, 3 of 12, etc, etc) until you have done this for all the songs. Then you can click the header for "a;bum: and they should show in order.
posted by terrapin at 12:30 PM on November 12, 2009


I haven't looked this up lately, so apologies if this isn't in sync with iTunes9, but it should be. ITunes will order album tracks according to the metadata for them. You do not say if there is any apparent order or scheme to how iTunes orders your downloads. I will assume that you are aware that clicking on the header for any column will reorder the playlist ascending/descending for whatever the column order is (artist by alpha/artist by year/artist by album; etc).

If the metadata for the songs you import does not reflect the album order as you expect, then an MP3 editor will be your friend--and an MP3 editor will be your friend if you are downloading substantially anyway, because you will encounter mistagged, misspelled, misordered material.

I am still using a diesel-powered XP-pro computer, so I do not know whether Magic MP3 Tagger works on W7, but it is open source, so it probably is only a short matter of time.

Disclaimer: Download responsibly. Don't drink & download.
posted by beelzbubba at 12:32 PM on November 12, 2009


It was the Disc 1 of 1 thing that did it. Not only did I have to list a disc number, but I also had to click on the little check mark next those fields. I had already put in the track numbers, but that wasn't enough. Thanks so much!
posted by bluefly at 12:36 PM on November 12, 2009


« Older I have a three year anniversar...   |  Figuring out if a bank loan ha... Newer »
This thread is closed to new comments.