Join 3,512 readers in helping fund MetaFilter (Hide)


Laptop audio feedback.
October 20, 2009 9:11 AM   Subscribe

Gremlins have taken over my laptop and now I get extremely loud audio feedback.

In the last few days the audio has somehow become screwed up on my laptop.
`
There is very loud audio feedback, which gets even worse when I begin to close the lid. It does stop when the lid is completely closed.

Also, audio cannot be played through the external speakers, which are connected via USB. Although headphones do work.

Yesterday, the problem was the complete opposite; I could only get audio through the external speakers and headphones, but not the built in speakers.

It seems that the built in microphone is keyed as the sound of touching the laptop seem to be amplified.

If I play something online that does have audio, it overrides the feedback. And for some reason it is no longer recognizing the CD drive. Sigh.

It is an IBM T42 running XP. I've tried to update audio drivers, but I cannot tell if it has been successful. This has been complicated by the fact that I had to wipe my hard drive several months ago. The person who reinstalled XP somehow erased all of the IBM info, including the serial number and customer ID. Thus, I cannot get support from IBM.

Any thoughts on how to fix this? It's driving me crazy.
posted by Juicylicious to Computers & Internet (5 answers total)
 
Hrm. I don't know jack about IBM's but

1. if you still have the IBM diag cd (or however IBM does diags for those laptops) you can check it (probably) to make sure that the problem is strictly with the o.s. and not with the hardware itself. I.e. if it still feeds back running an audio test from the diagnostics outside of windows (because you either booted to a cd or it has them onboard in the bios), then the problem is greater than just your windows install.

2. If you never use the internal mic, you could open the audio settings either from the speaker icon that (might) shows in your system tray next to the time by double clicking it, and muting the 'mic' fader, or you can access it from the sounds/audio icon that should appear in the control panel and do the same thing. Of course this means you won't be able to use the mic. You can also try just adjusting the mic fader level before muting it.
posted by bitterkitten at 9:53 AM on October 20, 2009


the muting the mic fader should just be muting the playback. there should be a seperate recording mixer.

I'd mute that! I'd also try removing the usb speakers to make sure it's not an error involving those.
posted by CharlesV42 at 10:02 AM on October 20, 2009


Is it possible your fried your sound card?

Here's a story of my own stupidity back in college: I had a few sets of powered computer speakers in storage and kept their AC adapters all in a box together. One day I hooked up one of the sets to my computer before plugging it in, then grabbed an AC adapter from the box without looking at it other than to see if the connector fit, and plugged it in. POP! went my poor overloaded speakers, but worse, POP! went my computer. The charge went straight through the speakers, up the cable and into my laptop. Of course my sound hardware had to be integrated, not a discrete card, and so my whole motherboard was killed. The computer was a high-end model only a couple months old; that was one of the most expensive and stupid mistakes I've ever made.

It sounds like you're experiencing the crazy, nonsensical behavior I had after that. The computer still worked in a lot of ways but it tended to do its own weird things too. It got progressively worse over time until it was totally unusable. I don't think it's possible to predict the anomalies you'll get from damaged hardware, so your situation could be the same as mine and manifest itself differently. For you sake, I hope it's not the same as mine. That sucked.
posted by The Winsome Parker Lewis at 10:05 AM on October 20, 2009


Charles - Ah you are right. I forgot you have to open the mixer and go to Options -> Properties -> radio button for 'Adjust volume for recording' and 'Ok' to get the Mic option.
posted by bitterkitten at 10:10 AM on October 20, 2009


The external speakers have been removed and no luck. I tested them on another laptop, interestingly they no longer project any sound, although the mute button works on them. Odd.

I muted the mic in playback. That stopped the feedback. I could not find a mute option under recording. Hopefully, I can still use my headset mic for ventrilo.

Thank you for helping me figure this out :)
posted by Juicylicious at 10:23 AM on October 20, 2009


« Older MS SQL Pros, I need your help!...   |  I need to do some empirical re... Newer »
This thread is closed to new comments.