Skip

Computer slowing for no reason!
August 21, 2009 9:54 AM   Subscribe

Why did my laptop (Vista) started slowing down dramatically for no reason? This is after I rebooted (many times), and turned off half the startup programs, ran anti-virus programs and AdAware.

Today, I was using my laptop (Vista), had a couple of programs running, but nothing insanely memory-hungry -- Excel, Word, Publisher, SigmaPlot, EndNote, Chrome --, when all of a sudden, my computer started slowing VERY noticeably. When I am working within a single program, my computer works fine. When I switch programs, it takes a while before the other program opens. This is very frustrating, because I am a heavy Alt-Tab user, and while five seconds doesn't seem like a long time, it does in Alt-Tab world.

Anyway, I tried all the usual suspects -- rebooted, turning off start-up programs, checking the computer for malware. No luck.

Please help me!
posted by moiraine to Computers & Internet (15 answers total) 4 users marked this as a favorite
 
Try running spybot and malwarebytes. Not all anti-malware programs catch everything. Did you recently visit a website that you never been to before?

Another cause I can think of is windows or your anti-virus trying to update. Or the add-on microsoft or googledesktop file search applications.
posted by royalsong at 10:00 AM on August 21, 2009


I'll pass along what was said to me once when I asked a very similar question: get Process Explorer and try to see if there's something eating CPU like it's none of its business. (The Task Manager can't usually tell you in as much detail as PE.)
posted by Iosephus at 10:04 AM on August 21, 2009


What does the task manager say? Sort it by CPU. Is anything pegged at 99%? How does your RAM usage look?
posted by damn dirty ape at 10:04 AM on August 21, 2009


CPU and Physical memory look normal -- mostly below 50%, depending on what I'm doing.
I installed a Windows update the night before -- could that be the problem?
Process Explorer is a really good tool, but doesn't seem to identify the problem.

However, I turned off all the 'visual effects', and now my computer looks really barren, but that seemed to have solved the problem. But I always had it turned on, and I never noticed any lag before.
posted by moiraine at 10:15 AM on August 21, 2009


Anything pegged at 50%? If you have dual-cores then a peg at 50 or 49% means something is tying up one core entirely.
posted by damn dirty ape at 10:17 AM on August 21, 2009


I wonder if you've accidentally gotten yourself into a power-saving mode? In the tray, look for the battery-charging icon and click it. You may be in a mode which throttles back the CPUs. (You can also check it from the Control Panel.)

On my Vista laptop there are hot key sequences which change the power saving mode. Sometimes I mistype them by accident, and the change can be quite dramatic. You may have done the same thing and not realized it.
posted by Chocolate Pickle at 10:39 AM on August 21, 2009 [1 favorite]


What's your HDD activity light doing when the system is idle? If it seems pretty active, dig around in control panel and pull up the search Indexing control panel and see if the search indexer is busy. It's supposed to reduce activity automatically, but that doesn't always seem to be the case. If that doesn't look like the problem, but HDD activity is still high, use process explorer and add columns for IO Delta: Read, Write, Other and see what processes are most active in any of those areas. What are they? What are the #s?
posted by Good Brain at 11:25 AM on August 21, 2009


Maybe you're running too hot? Get speedfan and see if your temperature is high. Then, clean out the fan and the heat sink and anywhere else where heat should be escaping but isn't.
posted by msbrauer at 12:19 PM on August 21, 2009


"However, I turned off all the 'visual effects', and now my computer looks really barren, but that seemed to have solved the problem."

Ironically, the very first 2 things I do to a Vista machine are: 1.) Disable System Restore (its a resource hog, wastes valuable HDD space) and 2.) Turn off all visual effects (set everything back to "Classic Windows" look) ...... Those 2 changes alone will probably double your speed/responsiveness.

A graphics problem could definitely make Alt-Tabbing slowdown. And if turning off visual effects made that much difference in speed, that could also point to a graphics problem. I think the first thing I would do is check for updated video card drivers. (check manufacturers website). .... and run a full Disk Defrag
posted by jmnugent at 2:36 PM on August 21, 2009


My entire day today is given to repairing a Windows XP machine with a failing hard drive. The only clue something was wrong was the machine got slow. Finally found some SMART reports showing a bunch of errors; disk errors can cause the whole OS to hang, stupidly.
posted by Nelson at 2:44 PM on August 21, 2009


Make sure you didn't kill Task Scheduler and Readyboost. You might think you don't need them, but they do other things besides their stated purpose that make the computer faster. If you don't want tasks to run, go into the "tasks" task of the computer management thing and delete them there.

See if the hard disk is full, or needs to be defragged, as well as run the manufacturer's hard disk diagnostic.

If you have a decent graphics card, turning off the visual effects should make no difference. With Aero Glass, the workspace is rendered in the graphics card, not on the main processor.

(And if you do have aero glass turned on, alt-tab is cooler looking. Also try windowkey-tab.)
posted by gjc at 3:37 PM on August 21, 2009


My husband just uninstalled IE8 because the memory leak was lagging his computer so badly. Since you applied an update recently, could Explorer be (part of) the problem?
posted by elfgirl at 8:04 AM on August 22, 2009


elfgirl- yeah, it screws with the sidebar. Excellent point!

Try turning off the sidebar and seeing if the sluggishness goes away. If it does, uninstall ie8 until they fix it.
posted by gjc at 11:17 AM on August 22, 2009


I have tried:

1) Turning off auto updates for antivirus/ windows
2) Choosing Best Performance
3) Disable System Restore and Search Indexer

I don't have IE. Anyway, CPU is down to 3%, but RAM usage remains about 51%. This is a one-year old computer with 4GB worth of RAM. Something called svchost.exe localsystemnetworkrestricted takes up a big portion of that. When I turn it off, I'm down to 48% RAM.

Any other suggestions? All this has been an exercise in patience!
posted by moiraine at 8:08 AM on August 23, 2009


I also ran defrag.
posted by moiraine at 8:08 AM on August 23, 2009


« Older Medicalfilter: I kissed someon...   |  Are there less expensive alter... Newer »
This thread is closed to new comments.


Post