Join 3,374 readers in helping fund MetaFilter (Hide)


Why won't firefox display pages correctly?
May 6, 2009 4:11 PM   Subscribe

What is wrong with my firefox? It seems like firefox has forgotten how to display backgrounds and colors on web pages. I don't know anything about css or html, so I don't really know what the problem is, but I posted a couple screenshots of two pages and the error console for one in this album. I have tried completely uninstalling and reinstalling firefox, but with no luck. Chrome and Safari work fine. This is on an Acer Aspire One running Windows XP.
posted by runcibleshaw to Computers & Internet (10 answers total)
 
Are you using Adblock Plus? You may have a filter rule set up that blocks a lot of separate CSS files loaded by HTML pages.
posted by Inspector.Gadget at 4:17 PM on May 6, 2009


From the look of your screenshots, it might be the kind of thing that happens when a bad or half-loaded css or image is cached, and the cached version is locked or otherwise never again replaced. You say you uninstalled, but what if you just find the cache folder and kill it?
posted by rokusan at 4:19 PM on May 6, 2009


View > Page Style > Basic Style?
posted by kindall at 4:31 PM on May 6, 2009


@inspector.gadget I'm not using any extensions. This is a brand new install.

@rokusan I have completely uninstalled firefox, including all the leftover profile folders, caches, prefetch data, etc. I have also tried clearing the cache. No difference

@kindall It was already set to basic style. Changing it to "no style" changes the layout, but still no background colors.
posted by runcibleshaw at 4:39 PM on May 6, 2009


What happens on a complete refresh? That usually does the trick for me.

I would agree, though, my Firefox has been doing the above quite a bit more often recently.
posted by messylissa at 4:48 PM on May 6, 2009


If I completely refresh the page? Nothing. This is on every webpage. AskMe background is white. MeFi background is white.
posted by runcibleshaw at 4:53 PM on May 6, 2009


I asked about killing the cache folder yourself because if a file/directory can't be removed by the uninstaller, and/or can't be replaced by the re-installation, it just chugs past that happily, skipping those files... so you install in the same place, you will end up with the same folder full of the same problematic files. Checking the installer logs could tell you if this happened, but it's easier to track down the folders, kill them by hand, make sure they're gone, and then run Firefox again. No need to reinstall.
posted by rokusan at 5:12 PM on May 6, 2009


Heh. Fixed it. I don't remember when, but at some point I must have turned on the accessibility options and set them to "high contrast". Weird that it only affected firefox though.
posted by runcibleshaw at 5:14 PM on May 6, 2009


Go to Tools - Options - Content - Colors. Is "Allow pages to use their own colors" checked? If I uncheck it, pages look like yours do, but I have no idea how it would get unchecked.
posted by donnagirl at 5:14 PM on May 6, 2009


Thanks for this question. The Content - Colors tip from donnagirl fixed this issue for me.
posted by SPrintF at 9:37 PM on May 6, 2009


« Older Which online emailing systems ...   |  Help me spend my $100 Mechanic... Newer »
This thread is closed to new comments.