Join 3,430 readers in helping fund MetaFilter (Hide)


Technophobe seeks help wrangling Dolby 5.1 into plain old stereo
April 30, 2009 9:29 AM   Subscribe

More and more DVDs are coming encoded with Dolby surround sound and many don't have an alternate Dolby stereo option. The resulting sound has way too much background noise mixed in, making it hard to hear the dialogue. Usually, we turn down the volume and turn on the closed captions. Is there another way or am I forced to spend hundreds on a surround-sound system?

We don't have cable and wouldn't choose to spend money on an entertainment system for the TV. We use the TV for (max) 8 hours a week -- for Netflix movies (the source of the problem), video games (Wii, PS2), and as a clone display for my laptop for a couple of TV shows.

It's a standard tube TV (not flatscreen, not HD), purchased circa 2001, with front inputs (currently connected to a switchbox for the aforementioned peripherals).

If you know of anything easy and cheap that can help, please let me know. Links and step-by-step instructions are especially useful. Thanks!
posted by parilous to Technology (15 answers total) 4 users marked this as a favorite
 
Play DVDs on your laptop (assuming Windows) and use a recent build of ffdshow-tryouts or AC3Filter as your audio decoder in some DirectShow application (Windows Media Player, Media Player Classic, Media Player Classic Home Cinema, etc.). In the ffdshow audio config, enable the "Mixer" option, and set it downmix to stereo. Then enable the "Volume" option, and give the center channel a moderate volume boost and the left and right channels a smaller volume boost. Play around with this until the dialogue vs. noise level is to your liking.
posted by Inspector.Gadget at 9:33 AM on April 30, 2009


Or for AC3filter, just set the downmix and channel boost in the simple config panel.
posted by Inspector.Gadget at 9:34 AM on April 30, 2009


Buy a cheap set of surround computer speakers (<$50) and an optical cord. If you don't want to mess with the wiring don't hook up the rear speakers.
posted by wongcorgi at 9:38 AM on April 30, 2009 [1 favorite]


Does your DVD player have a setup option in the player menu to downmix AC3 5.1 into stereo output? Mine does, and it's an $80 DVD Recorder from Wal-Mart.
posted by ostranenie at 9:41 AM on April 30, 2009 [2 favorites]


Some DVD players have a setting that jacks up the volume in the center channel. This is sometimes called 'quiet mode' or 'night mode' or similar. Might help--it's probably worth poking around in the menus and experimenting, anyway.
posted by box at 9:42 AM on April 30, 2009 [2 favorites]


Use a pair of stereo headphones. Use a boostaroo headphone amp/splitter for up to three sets of headphones.
posted by plokent at 10:03 AM on April 30, 2009


That shouldn't happen - either your DVD player or your TV is doing something funky. Check your DVD player settings - it needs to be configured for downmixed stereo or 2.0 output.
posted by Mwongozi at 10:20 AM on April 30, 2009


Wow! What great ideas so far! I appreciate the variety so if one thing doesn't work, another might...
posted by parilous at 10:21 AM on April 30, 2009


If you can adjust the levels of the mix, pull up the level on the center channel.
posted by Netzapper at 12:40 PM on April 30, 2009


I'm confused. Are you saying you just want plain old stereo, or mono?

I agree with Mwongozi. You shouldn't be having this problem, and you shouldn't have to spend a dime to fix it. I don't have a surround setup and everything sounds fine to me.

I suspect that either your TV or your DVD player isn't set up right. Somehow, you're in surround mode and listening to just the left and right. This is quite different than stereo left and right. Stereo left and right gives you all of the audio. Surround left and right only leaves you without the center and rears, which means you're missing the dialogue that tends to go to the center channel.

Make sure everything is set up to stereo and you'll get the results you're looking for.
posted by 2oh1 at 1:22 PM on April 30, 2009


yeah, most DVDs that I've watched have a 2.1 option in the sound setup. You have to do it separately for each DVD, but it should be there.
posted by rhizome at 1:57 PM on April 30, 2009


what 2oh1 said. Your DVD player should be properly downmixing the Dolby Digital to stereo. It doesn't seem to be doing that. Check your player's settings menu, probably.
posted by neckro23 at 3:30 PM on April 30, 2009


Mwongozi: I have the DVD "audio downmix" set to "Normal" (as opposed to "Dolby Surround") and the "digital out" set to "Off" (as opposed to "on", when I can modify the Dolby Digital settings). Is there another setting I should be looking for?

2oh1: I want plain stereo, not surround sound stereo (5.1).

rhizome: I'm sorry that I wasn't clear: it's not EVERY movie, but about 1 in 20 that have this problem. Five that I can think of off-hand are:
# "Princess Mononoke"
# "BURN-E" (the bonus movie on "Wall-E")
# "Bolt"
# "Monster House"
# "Kingpin" (the TV series)

None of them have the option of just plain old Dolby stereo. Other DVDs do -- we're in the middle of watching "Deep Space Nine" and though I have to change it every time I turn on the DVD player, it goes to plain stereo with the press of a button.
posted by parilous at 10:42 PM on April 30, 2009


As an experiment, try the "Dolby Surround" option. The player might mean Dolby Pro Logic (which is compatible with stereo).
posted by neckro23 at 12:40 PM on May 1, 2009


Conclusion: On a whim, I re-set the settings to "default". It worked. I don't know HOW it happened or WHY the settings were changed and I could've sworn that I had already tried it before. But oh... sweet relief!
posted by parilous at 12:01 PM on February 12, 2010


« Older I'm trying to create a convinc...   |  Does anyone know how to use Lo... Newer »
This thread is closed to new comments.