Join 3,432 readers in helping fund MetaFilter (Hide)


Say, did I just lose my internet?
April 4, 2009 7:35 PM   Subscribe

All of the websites I don't have explicitly bookmarked have stopped loading for me. On any wireless connection. Help.

So, I'm on a wireless connection, using gmail...when all of a sudden it switches suddenly to gmail offline, implying that I've lost the connection. (For what it's worth, using airport on a black macbook, mozilla firefox - happy to offer any other details as needed.) I'm still, according to Airport, connected to the local linksys.

Check a site I've got bookmarked on the bar, Wikipedia (natch). Works fine. Go to TheSneeze.com, which I don't have bookmarked. I get a "Failed to Connect - Firefox can't establish a connection to the server at thesneeze.com."

I realize, and test, that all websites that I don't have explicitly bookmarked are getting this response.

I go to a local place with wireless. This continues to happen, with an entirely different wifi connection. I restart. It continues.

I can't access gmail, or, well, just about anything online except for a few things I have bookmarked here - I can only help this goes through. Any help is urgently needed and sincerely appreciated.

(If this is relevant, I recently downloaded the .prefpane on WiFi.com, reading a decent review of its predecessor, Whisher, on a site or two. I found no real use for it, and removed it.)
posted by Ash3000 to Computers & Internet (19 answers total)
 
Have you installed any new firewall/antivirus/web filtering programs recently?
posted by JuiceBoxHero at 7:43 PM on April 4, 2009


The only thing I've recently downloaded, on Friday, is the wifi.com prefpane - didn't find anything particularly helpful about it, deleted the prefpane, and found this starting to happen last night - went to a cafe today, and still had this problem.
posted by Ash3000 at 7:45 PM on April 4, 2009


DNS service down, so only sites where the DNS is cached are working perhaps...?

Try doing a NSlookup on a site you know works, and one you know doesn't work -- if the first works and the other fails, then that's your problem.
posted by glider at 7:48 PM on April 4, 2009


Is it possible to do NSlookup on osX?
posted by Ash3000 at 7:51 PM on April 4, 2009


It should cache the websites you've visited lately, not just the ones you've bookmarked. You can use the Network Utility for lookup and/or ping. It sounds more like a security issue to me- like the bookmarked pages are in a trusted zone or something.

I assume that you're sure that on the pages you CAN get to, they're 100% up-to-date and not cached, right?
posted by JuiceBoxHero at 7:56 PM on April 4, 2009


Agreed that it seems to be sites I've listed lately, as some of the sites I've bookmarked are not appearing properly - and they're definitely not cached, e.g. the latest reviews on Metacritic are showing up, etc.

Just did a ping test - got a response on sites that work, got a "no route to host" on a site that's not loading. Any next steps?

And thanks so much for the help on this, it's truly much appreciated here.
posted by Ash3000 at 8:01 PM on April 4, 2009


Did you ping by site name or IP? If you havent tried by IP, try 132.235.8.140 That's Ohio University's main page. (A site I figured you hadn't visited.) You can also put that IP in your web browser and see if anything comes up.

"No route to host" could mean the DNS isn't resolving. Try checking your network settings and verify that you don't have anything in there that shouldn't be. If you'd like, you can program OpenDNS as your DNS servers and see if that changes anything. I'm actively using them now, so I know they're "up".

208.67.222.222
208.67.220.220
posted by JuiceBoxHero at 8:12 PM on April 4, 2009


Did so with site name for www.thesneeze.com - just did so with 132.235.8.140, and it loaded 100% fine in my browser, and also received a ping response. (Have never visited the Ohio University site before.)
posted by Ash3000 at 8:18 PM on April 4, 2009


Do you use static DNS servers or did the file you installed change your preferences to them?
posted by christhelongtimelurker at 8:19 PM on April 4, 2009


Oh, forgot to add that it's still otherwise not loading anything else it hasn't been loading.
posted by Ash3000 at 8:19 PM on April 4, 2009


Hey chris,
No idea - I'm a bit illiterate when it comes to the nuts and bolts of networks, unfortunately.
posted by Ash3000 at 8:20 PM on April 4, 2009


I'm not a Mac user, but somewhere in your system preferences screen should be a network settings section. Inside there somewhere should be an option where you can set/adjust your DNS servers. Usually these are autopopulated by your ISP when you connect. However, you can manually set them (static) to be specific servers. These servers are accessed directly by IP.

If you can find this setting, see if anything is actually manually set, or if it is set to auto-fill from your DHCP server. If it's set static, clear it out. If it's set to DHCP, try using the OpenDNS IP addresses I listed above.
posted by JuiceBoxHero at 8:31 PM on April 4, 2009


Went into network settings, added those as DNS addresses - none were listed previously, so I'm getting they're auto-filled. Added those. Then, nothing loaded, at all, including the cached sites (e.g. askmetafilter came up as "unknown host" when pinged). Just removed DNS addresses again. Back to square one with non-cached sites not showing up. Writing quickly b/c don't know if connection will die again.
posted by Ash3000 at 8:54 PM on April 4, 2009


Try checking your firewall too... In your System Preferences, select Security and adjust the firewall. Try switching it all the way off and try your pings and web pages again. Also, are you having the same problem with Safari?
posted by JuiceBoxHero at 9:06 PM on April 4, 2009


Have no firewall on. Also, identical with Safari.
posted by Ash3000 at 10:46 PM on April 4, 2009


1) Try plugging into your router with an Ethernet cable. If this works, then the problem is somewhere in the Airport part of your Network configuration.

2) Look under Network --> Airport (or Ethernet too if you have the same problem when hardwired) and look at the "Proxies" tab. There should be nothing checked, and most of the boxes should not be filled in. The only thing checked on my machine, which I have not changed, is "Use Passive FTP Mode (PASV)" and "Bypass proxy settings for these Hosts & Domains:" has "*.local" listed.

3) Also check the TCP/IP tab, and make sure Configure IP6 is set to "Off".
posted by bengarland at 5:28 AM on April 5, 2009


Also, when in doubt, reboot the machine and your wi-fi router.
posted by bengarland at 5:29 AM on April 5, 2009


You're not running Peer Guardian are you?
posted by bengarland at 5:47 AM on April 5, 2009


Ash3000: It is possible to do NSLookup on OS X. Just open a terminal window and type "nslookup [hostname]" where [hostname] is the name of the site you are looking for. For example:


crazyray$ nslookup yahoo.com
Server: 192.168.1.1
Address: 192.168.1.1#53

Non-authoritative answer:
Name: yahoo.com
Address: 206.190.60.37
Name: yahoo.com
Address: 68.180.206.184


Also, it is very likely that your wifi DNS or routing is being hosed up by the installation of the Mac OS X Beta client for wifi.com. Did it come with an unistaller?
posted by crazyray at 12:07 PM on April 5, 2009


« Older CrockpotFilter: "Falling-...   |  Obscure New England? I've see... Newer »
This thread is closed to new comments.