Skip

Why can't I get DVDs to play properly?
December 2, 2008 6:08 PM   Subscribe

How can I get DVDs to play smoothly on my computer? Whether from a disc or an ISO file on the hard drive I cannot get a DVD to play without it skipping on my computer.

As far as I can tell it's just audio skipping. The video might be skipping as well, though. It feels like it could be, but I might just be reacting to the audio.

I've rewound and rewatched sections when they skip and they don't skip in the same place or at all the second time around.

I'm using VLC. I'm running an AMD X2 3800 (dual core 2ghz) with 2 gigs of RAM on XP. I'm not overclocking. My DVD drive is PATA and the hard drive I'm currently using is SATA over USB.

I've recently replaced my RAM with no improvement (memtest gives me no errors). I upgraded my sound card from the onboard to a Creative X-Fi to fix video game sound issues, but that hasn't fixed it. I reinstalled XP recently partly because of this and I'm all patched up.

I've tried shutting else everything down. I shouldn't have to do that though, really. My CPU is usually around 4%. Every once and awhile it'll spike to 11 or 15%, but the spikes don't seem to correspond with the skipping.

Any suggestions would be great. I'm getting really annoyed.
posted by ODiV to Computers & Internet (19 answers total) 1 user marked this as a favorite
 
Try Media Player Classic. It's free, plays just about every movie format out there, not sure about ISOs though, but it's a quick download.

If that doesn't do it, I would make sure my audio and video drivers were up to date.
posted by parallax7d at 6:16 PM on December 2, 2008


It doesn't explain the DVD-drive issues, but I've never gotten high-quality video - even sub-DVD levels - to play smoothly over USB. I assume when you say "the hard drive I'm using," you're referring to the ISO location - if you're booting off of that USB drive, VLC might be caching onto it as it plays back, and that'd be a nasty bottleneck.
posted by Tomorrowful at 6:16 PM on December 2, 2008


Oh, also try copying the video onto your desktop before playing it. If it doesn't skip there then you know it's not the computer or the software, but the connection to the external drive.
posted by parallax7d at 6:18 PM on December 2, 2008


I had this exact same thing happen in my last computer. Turned out to be the DVD drive was messed up. Never found a solution for it, other than to buy a new one. They're cheap now, though.
posted by metalheart at 6:40 PM on December 2, 2008


This probably isn't the cause, but have you checked whether hardware acceleration is turned on? I accidentally turned it off on my PC a year or so ago and it really screwed up DVD playback.

Maybe you could try playing the disc with a Linux live disc with DVD support (like Puppy Linux) to see if the problem is software or hardware based.
posted by fearthehat at 7:19 PM on December 2, 2008


Check to make sure all of your drives are in DMA, and not PIO, mode.
posted by dansdata at 7:56 PM on December 2, 2008 [1 favorite]


I've rewound and rewatched sections when they skip and they don't skip in the same place or at all the second time around.

This strongly implicates the drive, because on the second pass it's playing out of the RAM cache.

What operating system are you running?
posted by Class Goat at 8:25 PM on December 2, 2008


(Sorry, I just saw that you said you were using XP.)
posted by Class Goat at 8:26 PM on December 2, 2008


Video is definitely skipping along with the audio. Just watched a bit without audio and it's very obvious. Don't know how I missed it.

Media Player Classic doesn't seem to play ISO files.

Changed my caching to 1500ms in VLC without noticeable effect.

Hardware acceleration is on.

Drives are in DMA mode.

I'll transfer an ISO to my internal drive and see if that makes a difference. I'm going to be pissed if I can't watch this over USB though since I bought a Drobo (no firewire) awhile ago with the main purpose of storing my DVDs for a media centre. The drive I'm using at the moment is just a single drive in an enclosure.

I will try a linux live CD and report back, as well. I've got one kicking around.

I have problems both with the external drive and with the optical drive so I kind of pushed aside the idea that there could be a problem with the optical drive itself. Also, I've been backing up DVDs without issue. I'll try a new optical drive though, since they're cheap and I plan to build a new system come January anyway.

I took the external to work and watched part of an ISO over lunch with VLC on Vista and I didn't get any skipping problems. Same amount of RAM, but a slightly better processor. Still, we've had DVD playback capability for ages on computers so I can't imagine it's a horsepower issue.
posted by ODiV at 9:25 PM on December 2, 2008


Like metalheart, when we had this problem, it turned out to be the dvd drive and we eventually just replaced it.
posted by gudrun at 10:33 PM on December 2, 2008


Try MPlayer, because you can use a command line option or config file setting to increase the amount of memory cache it uses.

Also, are you certain that the USB port you've plugged your drive into is actually working reliably at USB2 high speed (480 mbps) instead of USB1 full speed (12 mbps)? If you're plugged into a front panel port on your case, try a back panel port instead. Some cases use totally crappy wiring looms to connect the front panel USB ports to the mobo, and this can cause USB2 errors and/or fallback to USB1.
posted by flabdablet at 11:46 PM on December 2, 2008


There's no way it's a horsepower issue. A 400 MHz Pentium II is powerful enough to play DVDs, and your computer should be blazingly much faster than that. And hardware acceleration one way or the other shouldn't be an issue, either. MPEG2 (which is what is used on DVDs) isn't all that complex to decode.

Flabdablet's point about the USB port probably isn't helpful because Windows tends to bitch and moan when a USB2 device is plugged into a USB1 port. (You get a popup.) But if you're using a USB1 cable, you could be having handshake problems. Try a different cable, one known to be good.
posted by Class Goat at 12:30 AM on December 3, 2008


A different point: no free and legal player program can play ISO files because there's a per-unit license fee to legally use the codecs.

That's why I had to pay to get DVD playback with Zoom player, which is now my standard DVD player program. (I bought the "professional" level, because I didn't need any of the extra features.)
posted by Class Goat at 12:35 AM on December 3, 2008


While it's true that Windows will indeed whinge about disconnect/reconnect events that end up being USB1 reconnects, it may still be the case that rubbish front-panel cables are causing timeouts and retries at USB2 speeds without provoking Windows UI activity. Might be worth looking in the Event Viewer for disk-related errors and warnings.

In any case, it's always worth trying switching to a back panel USB port if there's USB weirdness involving a front panel socket, because back panel ports are typically mounted directly to a PCB rather than being connected via cable of possibly dubious quality.
posted by flabdablet at 12:46 AM on December 3, 2008


VLC has always done this for me.

It's not unwatchable but it's annoying. I use Codeine or MPlayer now and keep VLC around in case I have something that won't play anything else. I'd go with Codeine if it works on Windows - you'll have to check, it's worth it though, the playback is perfectly smooth.
posted by mannequito at 4:13 AM on December 3, 2008


Okay. Copying the ISO from the USB drive to the internal one resulted in nearly skip free playback. So did swapping out the optical drive. Looks like I had two separate issues masquerading as some sort of general media playback issue.

Annoyed that I'm getting the skipping over USB since a USB drive is how I'm planning on storing my files. I'm plugging directly into a motherboard USB port and it's definitely not USB 1 (would MPEG2 even play over USB 1? Seems way too slow at 12Mbps). I've got a USB 2 PCI card, so I could try that.

Still haven't tried the linux live CD.

Codeine looks like linux only and I'm an idiot and can't figure out how to play a DVD with MPlayer. I think I'll stick with VLC anyway, since it's playing smoothly from my internal drive.

Thanks for your help, everyone. I'm on the right track.
posted by ODiV at 7:31 AM on December 4, 2008


Oh, and I haven't tried a different USB cable yet either.
posted by ODiV at 7:35 AM on December 4, 2008


Just to be clear on USB cables: the one I'm dubious about is the one inside your case that connects the front panel USB socket to the mobo. Those are often totally crappy. The fast check for that is to see whether the problem still occurs when your external drive is plugged into a back-panel USB socket, since those are usually directly soldered to the mobo rather than having a cable in between.

If moving the USB plug from a front panel socket to a back panel socket makes no difference, then it's time to make sure your external USB cable is USB2 rated. If it was supplied with an external drive, it will be; if with a printer, maybe not.
posted by flabdablet at 3:40 PM on December 4, 2008


To make MPlayer a little more Windows-friendly, you might want to try using it with the MPUI front end.
posted by flabdablet at 3:44 PM on December 4, 2008


« Older The pediatrician says my two-w...   |  How are people deploying web a... Newer »
This thread is closed to new comments.


Post