Join 3,554 readers in helping fund MetaFilter (Hide)


How can I use my host's SMTP to send mail when I have my address set to forward incoming mail?
October 27, 2008 11:18 PM   Subscribe

How can I use my name@my-domain.com email address to send email, if the same address is set to forward incoming mail to another address?

I am using Mac OS 10.5, Mail.app, and an iPhone.

I have a site and domain name -- let's say it's my-domain.com -- hosted by 1and1.com. I use name@my-domain.com as my primary email address, but I have set my host to forward incoming email at that address to a MobileMe account: name@me.com. I want to continue to give out name@my-domain.com as my email address. I want to, for the time being, continue to use MobileMe (name@me.com) for my actual mailbox.

The rub is, because mail that's sent to name@my-domain.com is currently forwarding to name@me.com, any replies I send come from name@me.com. I have tried to set up Mail.app to use my web host's outgoing SMTP server (smtp.1and1.com), using the settings they describe (Port 25, Password authentication, etc), but it does not work; it gives the error "The server stmp.1and1.com cannot be contacted on port 25." I expect this is because I don't have a real "mailbox" set up with the host using that email address, only a forwarder.

So the question: is there any way to have my outgoing mail come from name@my-domain.com? For example, is there maybe a way to set up a @my-domain.com mailbox and have MobileMe go out and pull new messages into my @me.com address? Or can I somehow set up Mail.app to use my host 1and1's SMTP server to send mail, when the same email address is set to forward incoming mail? Or is there another service I can use to make this work?

Cheers, and thanks in advance.
posted by churl to Computers & Internet (12 answers total) 2 users marked this as a favorite
 
You correctly identified you need to use your host's smtp server to send mail if you want it to look right.
I would guess the error is because there is a problem connecting on port 25, rather than something about mailboxes.
I don't use 1and1 but some ISPs don't allow connections from external networks on port 25 to cut down on spam.
Does 1and1 have a support forum etc?
if you want to check the network connectivity, telnet to smtp.1and1.com on port 25, it will display exactly what your mail client sees when it connects (or fails to).
posted by bystander at 12:09 AM on October 28, 2008


You can use Google Apps for your Domain to set up some similar magic; I think you can still send mail from an account that is otherwise forwarding mail. I'm sorry I don't have the time to go through the entire process right now to confirm, though.
posted by disillusioned at 12:10 AM on October 28, 2008


If you can't connect to port 25, it's probably your ISP. Does 1and1 allow SMTP to port 465 or 587? Those are the typical alternative TCP ports for mail handling. Note that 465 is the default SSL port, and you'll need to turn on SSL to use that.

Note that we haven't gotten to the point where we find out if your account at 1and1 allows SMTP relaying, rather than the forwarding you've described. We have to first solve the basic connectivity issue with the SMTP server.
posted by chengjih at 12:23 AM on October 28, 2008


Try setting your phone and mail client to use port 587. That's the SMTP submission port, and it's designed for users that have accounts on the remote SMTP server to do just what you want (relay). On iPhone, change your outbound mail server to smtp.1and1.com:587 .. on your client, just change the port to 587. Leave all authentication settings in place and I bet it works. (This is what I do to relay through the mail server I operate, because virtually all Internet providers block port 25 outbound to "random" servers)
posted by fireoyster at 12:26 AM on October 28, 2008


These are much quicker replies than I expected. This is all extremely informative, thank you!

I just sent a test email, and I'm able to send email from other accounts, such as Gmail's SMTP server and my work's SMTP server, on port 25, with my ISP (which is comcast).

I've tried setting smtp.1and1.com to specify port 465, and then 587, and neither yielded different results.

Out of suspicion, I logged into my host's site (1and1.com) and changed name@my-domain.com to a normal 'mailbox', instead of a 'forwarder.' Then I set up Mail.app to check this mailbox. Once I did this, I was able to send outgoing emails using my host's SMTP server. These emails had the correct name@my-domain.com return address.

But once I changed name@my-domain.com back to being a 'forwarder' address (not a "mailbox") on my host's site, I could no longer send emails from that same SMTP server. Instead, I receive the dialog, "The SMTP server smtp.1and1.com rejected the password for user name@my-domain.com. Please re-enter your password, or cancel." This dialog would not accept the password that previously worked.
posted by churl at 1:49 AM on October 28, 2008


PS if it's still of any use, I can telnet to the SMTP server on port 25 (as bystander asked). The result is:

$ telnet smtp.1and1.com 25
Trying 74.208.5.2...
Connected to smtp.1and1.com.
Escape character is '^]'.
220 smtp.perfora.net (mrus1) Welcome to Nemesis ESMTP server


and then of course eventually

421 smtp.perfora.net connection timed out
Connection closed by foreign host.

posted by churl at 2:12 AM on October 28, 2008


If you want to make the forwarding undetectable, you need to persuade the forwarder's SMTP server to do what you want. They may not make that possible. If all you want to do is get the sender address right, so that people who don't bother scrutinizing all your headers will see mails coming from name@my-domain.com even though you're sending them via some other SMTP server, you should be able to set up a send-only account in mail.app that does what you want: just give it a dummy POP3 server and use the same SMTP server you're using for name@me.com mails.

Or you can run the whole thing through Gmail. If you set up a Gmail account, and add your other mail addresses to it as secondary accounts, you can send mail via Gmail's SMTP server with a From: address that matches any of those secondary accounts (if you send From: any other account, Gmail will reset the From: address to your main Gmail address.

Gmail can also pull mails from other mailboxes via POP3, so you could turn forwarding off at the name@my-domain.com end (which you apparently need to do to get access to the SMTP server you want), and just have Gmail pull mails from my-domain.com via POP3. Then you can set up a Gmail filter that forwards everything to name@me.com.
posted by flabdablet at 3:22 AM on October 28, 2008


In Mail.app account preferences, for your email account, in the "Email Address" field, add your other account name. So that it reads "name@me.com, name@my-domain.com"

(I assume that this is possible with a me.com account. It works for pop/imap accounts.) There ma, however, be some indications that the mail is delivered through me.com. Looking cloesely at the headers, your mail is coming from Apple's me.com SMTP server. But the 'from:' line in your email messages should show the @my-domain.com address.
posted by andrewraff at 5:26 AM on October 28, 2008


Actually, in Gmail settings, once you've added a pop account to your gmail account, you can tell it to NOT grab mail from it. In the settings screen there's a "send mail as" option, where you can select the other email address as an option.

Then in the compose screen, you just select which FROM email address you want to use.
posted by TomMelee at 5:54 AM on October 28, 2008


I have a similar set up, and what I've done is to have a "real" account *and* a forwarder for the same account. I then have a mail.app filter which automatically tosses any mail it receives on non-me.com accounts. I don't know if this is something that your 1and1 account will allow you, but my service provider does, so I guess you're chances are reasonable. I've been using this set-up quite happily for a few weeks now.
posted by leakymem at 10:50 AM on October 28, 2008


I had the exact same issue with the exact same host, in fact. You're right - you need to set up a mailbox. If you haven't already done so, try this:
Go to your 1&1 control panel, click email. Set up a mailbox (yourname@domain.com). Add a forward to your me.com addy, if you so desire (1&1's spam filters can be a bit aggro, so I prefer to forward a copy of incoming mail to my ISP's email account).

Now, open mail.app and add a new email account. Your incoming mail server is pop.1and1.com, outgoing is smtp.1and1.com. Your incoming server port is probably 110, outgoing might be 25. If all goes as planned, you can choose to send an outgoing message from your @domain account. For more details, refer to 1&1's email
FAQ.
posted by prinado at 11:50 PM on October 28, 2008


Every answer here is awesome. I am sure that any of the methods described here would work, but a combination of flabdablet's suggestion to set up an alternate "send mail as:" account with Gmail and then use their SMTP servers instead of 1and1's, and andrewraff's tip to add my other email address, after a comma, to the MobileMe account in Mail.app got me exactly what I needed, in my mail client.

As a side note, I think it would have been 'cleaner' to use MobileMe's SMTP server instead of Gmail's (so I only had to juggle 2 email accounts, instead of 3), but as far as I could figure MobileMe would only let me send email that came from a *@me.com email address through their SMTP servers. Gmail let me send from any email address as long as it was added to their list and verified. If MobileMe ever adds this feature, I can cut Gmail out of the loop entirely.

For posterity's sake; after many hours of experimentation, these are the exact steps I finally took:
At mail.google.com:
- Set up Gmail account name@gmail.com.
- In Gmail > Settings > Accounts > "Send mail as:" , added name@my-domain.com as another "Send mail as:" address. (Google sends an email to name@my-domain.com verify you own the address, you need to click a link in that email)

In Mail.app, in Preferences > Accounts > MobileMe:
- Set up Gmail SMTP account, using name@gmail.com (not name@my-domain.com) for authentication. (This is next to Outgoing Mail Server (SMTP):, just choose "Edit Server List" from the pop-up menu and add it to the list.)
- In the MobileMe account pane, added name@my-domain.com to the "email address" field, so it read exactly:
name@me.com, name@my-domain.com
- Still in the MobileMe account pane, chose Gmail's SMTP as the Outgoing Mail Server, and checked "use only this server."
Again, this got me exactly what I needed in Mail.app; a largely idiot-proof setup where when a message came to name@my-domain.com, my reply also automatically came from that address.

Note that you cannot execute this sorcery on an iPhone. You cannot add a non- @me.com "from" address to a MobileMe account on the phone, (If you set it up that way in Mail.app and sync your email settings to the phone (as I did), it just strips out the other "from" addresses). Same thing with the me.com web interface, where you can choose from multiple addresses to send from but they have to be *@me.com addresses. Both of these would probably be resolved if I just switched from MobileMe to Gmail as my 'real' email host. I may eventually do that, despite being totally crazy in love with the MobileMe web interface.

You are all ass-kicking email-protocol heroes; thank you for saving the day.
posted by churl at 3:39 PM on October 29, 2008


« Older Help me cure my Wasabi craving...   |  Calling all Swedish mefites! L... Newer »
This thread is closed to new comments.