Join 3,572 readers in helping fund MetaFilter (Hide)

Tags:

How do I stay connected to my LAN when logged off?
October 5, 2008 2:24 PM   Subscribe

Why is Windows SP3 disconnecting me from the LAN whenever I log off...and how do I make it stop that?

Before I updated to SP3, this never happened. Now, whenever I log off (using the Windows+L shortcut), my LAN disconnects. I want to stay connected so programs like Pidgin can run while I am away, and I don't have to wait to reconnect when I come back.

It's Windows XP Pro SP3.
posted by jesirose to Computers & Internet (9 answers total) 1 user marked this as a favorite
 
Wired or wireless lan?

Have you run windows update since installing SP3?

Also note that the default behavior of Win+L is to lock the computer, not log you off. Did you change this? (need to know if you are actually being logged off)
posted by blind.wombat at 3:14 PM on October 5, 2008


Wired
Yes
You are correct, it is lock, not log off.
posted by jesirose at 3:43 PM on October 5, 2008


I'm trying to figure out exactly what it is that you lose connectivity to when you lock your computer.

Try opening a cmd window and entering the following command:

route print

One of the items listed will be the IP address of your default gateway, which will generally be the router on your LAN. The following commands will assume that this address is 192.168.1.254, so you'll need to replace that with whatever route print shows as your default gateway.

Ping the router:

ping 192.168.1.254

You should see a result that looks like this:

Pinging 192.168.1.254 with 32 bytes of data:

Reply from 192.168.1.254: bytes=32 time<1ms TTL=128
Reply from 192.168.1.254: bytes=32 time<1ms TTL=128
Reply from 192.168.1.254: bytes=32 time<1ms TTL=128
Reply from 192.168.1.254: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.1.254:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms


Next, ping it with a count of 30 instead of the default count of 4, and while it's pinging, hit Windows-L to lock your session:

ping -n 30 192.168.1.254

After unlocking the session, check the results in the cmd window. If you see a bunch of

Request timed out.
Request timed out.
Request timed out.
Request timed out.


then locking your session is making you lose connectivity between your computer and the LAN. If you see 30 lots of ping replies, your connection is dropping between your router and the Internet.

Post back the results of those tests, and you'll get much better guesses about what's going on.
posted by flabdablet at 5:20 PM on October 5, 2008


I will try that the next time it happens. It does not happen every time I lock the computer. I know I said "whenever" it had been happening almost every time and now has not happened today at all. *headdesk*

Also I am sure the problem is between my computer and the router because my husband using the same router does not loose connectivity.
posted by jesirose at 5:50 PM on October 5, 2008


When I updated to SP3, it screwed-up a couple of drivers. I may be completely wrong, but I'm a developer and don't think it would be outside the realm of possibility that there may now be a minor issue between Windows and your current Ethernet controller driver. Make sure you have all the Windows Update patches first in case it's a fixed bug.

For the driver, you can go to Control Panel > System > Hardware > Device Manager > Network Adapters, right-click for Properties and the Driver tab. Consider the driver date and whether it's reasonable. I'd try to update the driver, or roll it back if it's already up to date.

All I can think of, locking Windows shouldn't touch the hardware. Also, try to note what applications you're running when it does happen, versus when it doesn't.
posted by hungrysquirrels at 6:03 PM on October 5, 2008


While you are in Control Panel > System > Hardware > Device Manager > Network Adapters checking drivers (good idea), also click the "Power Management" tab and see what boxes are checked, and also on the "Advanced" tab, look for a WakeOnLAN entry in the Property list and see what the value is set to. If any of the WakeOns are disabled, try turning them on and seeing if that fixes the problem.
posted by blind.wombat at 6:14 PM on October 5, 2008


The sp3 install might have reset your power management settings so it goes into standby at 15 minutes (this is default on a lot of HPs). A quick google search shows that some people are having problems with sp3 and power management. If it goes into standby it will drop the network connection to save power. Set it to never go into standby or hibernate.
posted by damn dirty ape at 6:48 PM on October 5, 2008


It does not happen every time I lock the computer.

That's a pretty good clue that it is in fact related to some kind of standby timeout, as dda suggests.
posted by flabdablet at 6:58 PM on October 5, 2008


I have changed the power management settings, it was set to standby after 30 minutes. I haven't seen any trouble since. Thanks!
posted by jesirose at 7:54 AM on October 6, 2008


« Older Our Xbox 360 is scratching the...   |  How can I get more involved in... Newer »
This thread is closed to new comments.