Join 3,494 readers in helping fund MetaFilter (Hide)


Artist/album in itunes, not on ipod
September 21, 2008 1:57 PM   Subscribe

iTunesFilter: Songs/artists in iTunes not in iPod. Huh?

So I'm feeling in the mood for a little Kingston Trio, but when I search for them on the ipod, I can't find them - not under "Kinsgton" or "The Kingston". The "Greatest Hits" album is also not listed under Albums.

I was pretty sure I had synced up the ipod to itunes, so I plug it into the computer, and re-sync. Go back into ipod, still not there. What's up? I have 7905 songs (as per itunes AND ipod). That's 26GB out of 160GB. I'm stumped! (This might be happening with other artists/albums, but the Kingston Trio was the first I noticed, and I haven't dug much deeper.)

Damn it! I just went through all songs (on the ipod), and I was able to find MTA, Greenback Dollar, etc. And they're listed correctly (Artist = Kingston Trio). Why can't I find them by Artist or Album?!?! Grrrrr!!!!

Other details; running itunes 8.0.0.35 on Windows XP (SP3), Dell XPS 2.8GHz, with 2GB RAM.

Thanks!
posted by ObscureReferenceMan to Computers & Internet (13 answers total)
 
Is there a chance you're not syncing All Songs, but instead some subset of playlists? You can check when you're docked and look at the Music tab.

Another long shot: select all the tracks in the album, get info, and see if something odd got set to the Album Artist field. As far as I know that's only used for organization on your desktop, but...maybe?
posted by Remy at 2:18 PM on September 21, 2008


Any syncing I do is whatever the default is. (BTW, I am very much an itunes/ipod noob.) I have no playlists yet. Where can I check if I'm syncing All Songs? I looked in Preferences, and couldn't find any info on syncing.

I've checked each song in the album before, looking for odd things. Didn't find any. I selected the whole album, and did "Get Info" - nothing weird.
posted by ObscureReferenceMan at 2:29 PM on September 21, 2008


That happened to me with one of my albums (Cross by Justice) - it was classed by iTunes as a compilation under Various Artists. The only reason that I thought it might do that is because some of the Artist labels were 'Justice featuring such-and-such', thus making it technically by 'Various Artists'.
Maybe this is why you can't find it under Artist, but I don't have an answer as to why it won't show up under Album.
posted by ardinno at 2:52 PM on September 21, 2008


Is the album set as a compilation? It wouldn't explain why it isn't showing up in albums, but might cause it not to show in artists if you are grouping compilations.

Did you verify that there is nothing funky in sorting options for those tracks?
posted by thinman at 2:52 PM on September 21, 2008


The album is set as a Compilation. Hmmm... and I just found another (Marty Robbins) listed as a compilation, that is also not findable as Artist or Album.

So... Is the solution to un-check albums marked as "Compilation"? What does Compilation even mean? What's it used for?
posted by ObscureReferenceMan at 2:59 PM on September 21, 2008


Yeah, unchecking the 'Compliation' box should ensure that the artists will be present in the Artist search.

This link explains why some might want to class things as Compilations (although personally I'd rather see all the artists under Artist serach, one-hit-wonders or not).
posted by ardinno at 3:15 PM on September 21, 2008


The Compilation checkbox is most commonly used to keep albums which have various listed artists together in the same folder.
posted by Aquaman at 3:50 PM on September 21, 2008


Huh. I noticed that problem with the same Justice album last night; thanks for clearing that up, ardinno.
posted by vernondalhart at 4:00 PM on September 21, 2008


Happens to me too, got 4 Jon Spencer albums, 3 are listed, one is hidden under the album title only.

Doesn't even show up in Itunes unless I look for the album.

Not a compilation though, also curious as to why this would happen.
posted by Max Power at 5:28 PM on September 21, 2008


Under "Get Info", check the "Sorting" tab to make sure it doesn't have anything weird listed there, as changing things there can make the music show up differently in the sort order.

Also, check if the option to "only sync checked music" is enabled. Depending on if you keep your music is checked or not, it would affect the sync operation too.
posted by gemmy at 6:03 PM on September 21, 2008


Thanks, all! Now I've got to "de-compilize" my music...
posted by ObscureReferenceMan at 7:33 PM on September 21, 2008


Hey, you don't need to reset the Compilation flags to have artists appear in the browse window (and be searchable). Just go to the preferences pane, go to the advanced tab and uncheck "group compilations while browsing."
posted by Aquaman at 3:55 PM on September 23, 2008


Aquaman - Another good answer! I will be doing that AND uncompiling. Especially because I think certain albums should be compilations (Soundtracks, multi-artist performances).

And if anyone is interested, it seems that besides the two I listed above, it seems like a number of "greatest hits" albums (say, 25-30%) seem to be marked a Compilations.
posted by ObscureReferenceMan at 4:20 AM on September 24, 2008


« Older Is there any downside to buyin...   |  I've done some soul-searching,... Newer »
This thread is closed to new comments.