I do not want a Live CD, why can't you remember that?
July 22, 2008 8:01 AM   Subscribe

I am having problems making a persistent installation of Ubuntu on a usb thumb drive.

I am attempting to make a persistent install of ubuntu 8.0.4.1 on a usb thumb drive. I am not looking for a Live CD on a usb drive.

I have followed several different tutorials (most notably the ones here and here*). I can, seemingly, get through the whole process without a hitch. When I start the target machine (a mini-itx with no internal or external drives, only the usb key), it will boot as if it were a Live CD. It asks for Live CD boot parameters, and no changes I make (simple ones at that, themes, or desktop background) are saved. The BIOS is set to boot off the usb key.

I feel I am missing something incredibly obvious here, but have no clue what it might be. I'm comfortable, but by no means a pro, with "the Linux," and have zero idea where to start looking for a solution.

I sent an email to the pendrivelinux dudes, but doubt I will hear back anytime soon.

*I realize this second link is for xubuntu, but that doesn't matter so much to me as making the changes to stick.
posted by tip120 to Technology (3 answers total)
 
It's been a while since I've done this, but let me take a stab anyhow.

I used the pendrivelinux instructions, so that's what I'm going from now. The keys are in the custom syslinux.cfg and initrd.gz that you get from their site.

If it boots and you don't see the option for "Run Ubuntu in Persistent Mode saving and restoring changes" then you don't have the correct syslinux.cfg. If you do have that option, but it still doesn't save changes, then you may have a problem with the initrd.gz. There were some persistence problems with Ubuntu Hardy, but it seems the current initrd.gz from pendrivelinux fixed those.

Otherwise, I'd check that you formatted the second filesystem correctly (the "mkfs.ext2 -b 4096 -L casper-rw /dev/sdx2" line) and that that filesystem is mounted correctly on boot.

Ooops, I gotta fix a server a now. Let me know if none of this helps.
posted by mad bomber what bombs at midnight at 9:30 PM on July 22, 2008


Thanks mbwbam, for whatever reason I was missing the persist boot option in the syslinux.cfg. Looks to be working just fine now. The new question is, "How do I set the persist flag permanently." But that's one I can fudge about with on my own.
posted by tip120 at 2:11 AM on July 23, 2008


Glad it worked out. Editing the syslinux.cfg to make it the default is pretty straightforward. Change the first APPEND line to boot=casper persistent ... and lower the TIMEOUT value.
posted by mad bomber what bombs at midnight at 3:06 AM on July 23, 2008


« Older How's life in Burlington, VT?   |   Longterm affects of amphetamines? Newer »
This thread is closed to new comments.