screwy bullet lists
July 9, 2008 5:11 AM   Subscribe

Why do word processors screw up the size of bullets in bulleted lists?

I initially thought it was a MSWord issue, but I see the same behaviour now that I am using Open Office as well. Is it a problem with the .doc format itself? In bulleted lists, I often end up with the first bullet being a different (larger) size than the rest of the list - and often no amount of screwing about fixes it.

So I guess my question has a few parts:
  • Why does this happen?
  • Is there an easy, bulletproof way to fix it when it does happen?
  • Is there anything left to live for? After half an hour trying to get my promo flyer looking right I am ready for a bullet to be inserted into my brain.
  • Is there a specific individual who can take the blame for this incredibly frustrating bug? What is his name and contact info?
posted by Meatbomb to Computers & Internet (11 answers total) 2 users marked this as a favorite
Shot in the dark but have you tried printing it to make sure it's not just a rendering issue on your screen? Could be completely unrelated but I had an issue recently where Outlook was doing some weird formatting and it turned out it was actually doing everything right, it just didn't look right on the screen because of improper rendering.
posted by genial at 5:19 AM on July 9, 2008

I feel your pain. Sometimes this seems to be due to the font size formatting of the bad bullet being inconsistent with all the other bullets. So selecting the whole bulleted list (plus a line above the wrong bullet for good measure) and formatting all of it to one size can sometimes work.

When it happens in HTML-formatted Outlook emails you can forget about it...
posted by Dan Brilliant at 5:27 AM on July 9, 2008

I don't know the answer, either, but I've dealt with it by completely deleting the section with bullets, re-entering all that text as plain paragraphs, then selecting the whole section to be bulleted and doing the bullet format. That tends to work because it erases whatever stray code is causing the bad bullets. Same thing with random indentation variations. You should not have to do this, however. Bill Gates should send out another rant about it, that might fix it.
posted by beagle at 5:36 AM on July 9, 2008

My understanding of this is that the bullets are sort of like the invisible paragraph marker; they exist on your document as a result of formatting that is happening around them, but they can't hold their own formatting. When I have seen this happen it's usually because the way I did things was like this

- hit return to start new line with bullets
- click bullet button
- write out lists of bullets
- select bulleted text and make text different size

In this example, the first bullet will stay large [sometimes] because it's pulling its formatting information from the preceding paragraph. To fix this you need to select not just the bulleted list but up to and including the invisible paragraph marker at the end of the preceding paragraph. Click the "reveal codes" button to show you these.

Also I'd make the bulleted list LAST while you are making a flyer. A lot of people format form the top down, they format as they go which can lead to little annoyances like this. Type all your text first, then go back and do formatting. Also you may want Word/OO to not format as you type which is something you can turn off [in word] with the auto-correct/auto-format options. BEWARE, I think you actually need to fix this in two places in the preferences, not just one. After that, you can just write out the text and word doesn't do that unhelpful "Oh you're making a list let me help you wiht that..." routine which shoudl help you gain some control over bullets.

Hope this is helpful.
posted by jessamyn at 5:44 AM on July 9, 2008 [2 favorites]

I fix this by hitting enter after the correctly-formed bullet, re-typing the item next to the fucked bullet, and moving the new bullet into the correct place after deleting the old one. Yeah, annoying.
posted by desuetude at 6:23 AM on July 9, 2008

I don't know about OOo, but in MS Word, the bullet is styled separately from the text. The way to change this is not easy or obvious (and MS tends to revert your changes in the next list you make), but it is possible, with some screwing around.

I've got Office 2004 (Mac). I'm guessing this would work in other versions, mutatis mutandis. Try this:

Create your list and have Word apply its misbegotten bullets. Select the bulleted list. Go to Format > Style > Modify Style. Observe the "format" popup menu coquettishly hiding at the bottom and select "Numbering" from that. Click the "Customize" button. Click the "Font" button. This will bring you to a font dialog from which you can change the font (which is always taken from Symbol unless you change it, which probably accounts for why it looks so big) and size of that bullet. You can also change the character being used—I think the character from Symbol is something other than the normal • character that your usual font would provide.

Hey, I guess that was pretty easy and obvious after all, huh?

I wouldn't be surprised if OOo is following MS Word's behavior in the interest of compatibility.
posted by adamrice at 6:45 AM on July 9, 2008

Use the Format Painter. Click in the text which is formatted the way you like, then click the Format Painter and then in the text you need reformatted. The bullet will magically take on the preferred characteristics. The Format Painter is better than your friend: the Format Painter will do your shopping, find the one and only, fix the photocopier, make you look like a genius, match lost socks, and many other necessary things besides. Play with the Format Painter and it will love you back with a passion you never thought possible.
posted by firstdrop at 7:12 AM on July 9, 2008

Jessamyn has the why: the first bullet will stay large [sometimes] because it's pulling its formatting information from the preceding paragraph


firstdrop has the fix: Use the Format Painter

Everything firstdrop says is TRUE about the format painter! It is a fabulously useful tool once you are comfortable using it correctly.

I teach Office apps, and I can confirm that carrying over the styling from the previous paragraph is one of the brain-bendingly weird things about Word.
posted by SuperSquirrel at 7:49 AM on July 9, 2008

I usually find that hitting Ctrl-Q in MS Word will make most formatting go away - you can then highlight everything you want to bulletise and erm bulletise it. Ctrl-Q has saved many a frustrated hour in front of Word.
posted by car01 at 8:06 AM on July 9, 2008

@ Jessamyn: "A lot of people format form the top down, they format as they go which can lead to little annoyances like this. Type all your text first, then go back and do formatting."

Amen. If everyone did this the world would be a better place.
posted by I_Love_Bananas at 8:26 AM on July 9, 2008

Slightly OT, but I also recommend this practice (compose first, format after).

I've started using Google Docs to compose my documents, which is 90% of the work, and when collaboration happens (which Google makes super easy), then exporting them and formatting them in Pages (or Word or whatever) only when they are ready to be shared. (At which point I usually make PDFs out of them anyway.)
posted by crickets at 8:52 AM on July 9, 2008

« Older I cho-choose you   |   How does this usually work? Newer »
This thread is closed to new comments.