Cursors foiled again!
June 15, 2008 1:27 PM   Subscribe

Why is my keyboard cursor moving so slowly?

Using the arrow keys on my Acer laptop has become a drag. The cursor moves v-e-r-y slowly through text when I depress the key to repeatedly move. The same goes when I use the backspace key to delete. I'm experiencing no other keyboard-related problems.

Is there some Windows XP control panel function that I've screwed up? I already tried the repeat key settings. I ran the usual spyware programs with no luck. Also, the mouse cursor moves fine.
posted by sixpack to Computers & Internet (7 answers total)
 
Try it with another keyboard (one that works well on another machine). If that keyboard works fine, then you have your answer.
posted by The Light Fantastic at 2:13 PM on June 15, 2008


Has it always been this way on this computer, or has it only recently become a problem?

If you press and hold another key, say 'a', does it repeat at the proper rate? If not, I'd recheck the repeat key settings.
posted by Mike1024 at 2:59 PM on June 15, 2008


This is problem just cropped up this weekend. And the problem is the same for letter keys - very slow to repeat.
posted by sixpack at 7:31 PM on June 15, 2008


Does this happen with all programs, or just with browsers, just with word documents, etc? Which spyware programs have you tried?
posted by Phire at 9:12 PM on June 15, 2008


WinXP/Control Panel/Keyboard-there is a repeat rate setting and keyboard delay setting.

Also there is a keyboard repeat & delay setting in the bios (which you have to access by pressing a special key just as the computer is booting up). As a rule the WinXP control panel setting "trumps" the bios setting, but still might be worth experimenting with if you're having trouble.
posted by flug at 9:13 PM on June 15, 2008


Open up the task manager and see if there's some process taking up all the CPU time. Or, maybe its overheating and putting the processor into some kind of low speed throttle mode.
posted by gjc at 9:41 PM on June 15, 2008


Windows has all kinds of weird hotkeys to turn on assorted kinds of keyboard assistance for disabled folks. For example, I often end up turning on StickyKeys by accident if I pause for thought with my little finger on the right Shift key. As well as checking the repeat rate settings under Control Panel->Keyboard, you might want to poke around under Control Panel->Accessibility and make sure all the keyboard-related stuff there is disabled.
posted by flabdablet at 10:33 PM on June 15, 2008


« Older Meaningful places in India   |   How stupid would it be to trash the old financial... Newer »
This thread is closed to new comments.