How do I stop the noise from my motherboard coming through my speakers?
February 16, 2008 7:27 PM   Subscribe

I have an old bose acoustic wave radio serving as my PC speakers. Powered but not connected to the computer the speakers produce a gentle hissing. When plugged in (via a 3.5mm to RCA cable) I hear noisy static -- not pure white noise, far more annoying -- and an intermittent whine that changes pitch depending on what's going on in the computer. For example, if the processor is under greater than 30% load all the noises go away. This does not happen with headphones so I think it is some combination of noise in the computer circuits and the amp built into the radio. My question is how do I make it stop?

This is my only audio equipment and doubles as my alarm clock. Most of the time I can ignore the sound but sometimes it gets inside my skull and drives me nuts. There are all sorts of odd sounds I can't describe, when there are lots of read/writes to the ram I can tell by the sound. Very irritating. (Sometimes, like now, I end up with ringing in my ears which may or may not be related. Testing that is another reason I want to eliminate these noises.)
posted by Grod to Computers & Internet (11 answers total)
I had the exact same problem running a computer into a PA system. This puppy took care of that great.
posted by waxboy at 7:52 PM on February 16, 2008

I've had problems like that from time to time. I've found the best way to do deal with it is to use digital output. You can get a USB sound card pretty cheap, and that would probably eliminate it. There are three on newegg that are cheaper then that ground loop hum remover.
posted by delmoi at 8:02 PM on February 16, 2008

There's probably nothing you can do to fix the CPU noise. A USB sound adapter is a viable workaround.

A properly shielded cable should help the white noise.
posted by qxntpqbbbqxl at 8:02 PM on February 16, 2008

Response by poster: Hm. That's (the ground loop eliminator) a rather pricier fix than I was looking for but if it works it would be worth it. Those usb sound cards are also interesting however the only one on newegg that I've heard positive things about is currently out of stock and far more than I can spend. The E-MU 0202. Are the $20 sound cards any good, really?
posted by Grod at 8:10 PM on February 16, 2008

E-MU makes stuff for audio professionals. The E-MU 0202 is expensive because it has a 24-bit, 192 kHz analog-to-digital and digital-to-analog converters, and an XLR microphone input. I'm sure it sounds great, but it's total overkill for what you need. In contrast, CD quality sound is 16-bit , 44.1 kHz stereo. If the cheap USB card can do that, go for it.
posted by qxntpqbbbqxl at 8:25 PM on February 16, 2008

Response by poster: Does waxboy's explanation, that it is ground loop hum, explain hearing the processor load change and the memory paging? Because if so wouldn't something like this be more appropriate than his link, which seems designed for PA systems?
posted by Grod at 8:47 PM on February 16, 2008

Sometimes plugging into audio out on the sound card, instead of the headphones jack, will reduce that. You can also go into your sound setup and turn down the CD channel (if you're not using that) as it is an internal device and picks up its own noise as well.
posted by StickyCarpet at 9:02 PM on February 16, 2008

Oh and one more thing: you can move which slot your sound card is in to find one that gets less interference. The noise is basically radio frequencies, the case is supposed to contain them, but the audio card is inside the case.
posted by StickyCarpet at 9:04 PM on February 16, 2008

Grod: I have a cheapo one I got at best buy, it's listed on the newegg page at $25. I use headphones with it and it sounds fine. (It's the turtle beach one). One annoying thing is that the driver's are not that great. For example, the little volume control icon thing sometimes goes away, and it will only work on the USB port that it's pluged into when you install the drivers, which is kind of odd.

But the audio quality is as good as anything I've heard. I'm hardly an audiophile, though.
posted by delmoi at 9:42 PM on February 16, 2008

Chances are this is caused by the CPU going into a lower power mode when nothing is running, and then coming out again when the periodic clock tick routine needs to run. If your OS supports it, try setting the OS clock tick to something sufficiently high (or low) frequency that it's no longer audible. If you can't do that, how about running something like folding@home or GIMPS to use up your idle CPU cycles so it never goes into low power mode?

Of course, that's just a workaround to suppress the signal from being generated, the suggestions above for preventing the signal from reaching the soundcard/amplifier are more elegant. Still, as quick fixes go...
posted by fvw at 4:19 AM on February 17, 2008

Dude, get the USB soundcard. They are cheap and they are perfect for what you're trying to do. They isolate the sound production outside of the computer case.

But before you pull the trigger, see if your Bose has inputs on the rear other than the L-R RCA style inputs. If it has coax or optical then buy a USB sound card with the same. Otherwise find a shielded RCA cable.

(Also, if you have a newer, fancy motherboard it may have optical out - it's worth trying that first.)
posted by wfrgms at 10:38 AM on February 17, 2008

« Older pen island   |   Whence comes sediment-free after-dinner coffee? Newer »
This thread is closed to new comments.