Wireless timeout
January 29, 2008 9:46 AM   Subscribe

Wireless networking problem...help?

I'm using a Linksys WRT54GS wireless router with a Charter cable modem. My computer is using a USB Buffalo AirStation Wireless-G wireless connector. Win XP sp2. Using WPA-PSK TKIP encryption, but the problem is the same with WEP, and with or without firewall.

The connection times out about every 5 minutes or less. I looked up the previous questions about this. The weird thing is that when it reconnects (automatically), it shows 'connected' in Network Connections, and there is an IP address assigned, but there is no default gateway assigned--it's blank when I look at ipconfig. This is strange because I have entered as the default gateway in Windows for tcp/ip, rather than letting it assign a default gateway. So how could it be blank?

And even stranger, this happens sometimes, but sometimes it reconnects with the right default gateway, and a correct IP address, but in both of these states I can't access the net or the router configuration page. It will act properly after I reboot, for a time. If I 'repair' the connection, it will often work for a time. But if it re-connects automatically, it won't. I can't ping when it's not accessing the net.

This timeout also happens with my roommate's laptop (Thinkpad), but when he automatically re-connects, it does actually work and he can access the net.

Any suggestions? It's driving me batty.
posted by underwater to Computers & Internet (14 answers total)
First thing I would try (if I didn't have it hacked in some way) would be to upgrade the firmware on the wireless router.
posted by Burhanistan at 9:56 AM on January 29, 2008

It's a v.5 so there is no firmware upgrade.
posted by underwater at 10:04 AM on January 29, 2008

And it's not hacked in any way.
posted by underwater at 10:05 AM on January 29, 2008

I used to see behavior very similar to this on my WRT54G (v2). I would occasionally need to reboot my laptop in order to reconnect it (although I suspect that that was a consequence of some dodgy VPN software I had to use which didn't like to be spontaneously disconnected). Unfortunately I can't really give you good advice for fixing it, except what Burhanistan said. I eventually wound up wiping the firmware out and installing OpenWRT on mine, at which time I stopped getting dropped, but that's a pretty radical solution.
posted by whir at 10:08 AM on January 29, 2008

Do you have drops or timeouts when you're plugged directly into your cable modem? Sometimes there are synchronization issues with the ISP's circuit even when you have apparently fast download speeds.
posted by Burhanistan at 10:08 AM on January 29, 2008

No, when I'm directly connected it's fine. I can't wipe the firmware b/c it's my roommate's router and he would never go for it (although he's fine with me configuring it in general).

I'm not running a VPN or anything unusual.

Thanks for the suggestions so far.
posted by underwater at 10:12 AM on January 29, 2008

Since this is happening with both computers, it probably isn't an issue with the computers themselves.

I'd recommend the following:

Check the firmware. You have a WRT54GS v.5, but if you haven't updated the firmware in the past six months, there's a new one available at Linksys.com.

Also, change the default channel on the router. Linksys (and most Netgear) routers come out of the box on Channel 6. Change it to Channel 1. This should help with any interference issues. I'm assuming since you added security that you changed the SSID as well. If you haven't, make sure it isn't "Linksys," as Windows can't handle two adjacent networks with identical SSIDs.
posted by Psionic_Tim at 10:16 AM on January 29, 2008

You could also look at setting a static gateway in the wireless adapters, but that could cause problems if you take the laptops to other networks.
posted by Psionic_Tim at 10:18 AM on January 29, 2008

Is 802.x authentication turned off? (under the the network connection's properties...2nd tab I beleive. Having that on will cause the problems you are having iirc).

Another idea is to change your wireless channel to another one...it could be interference from another AP or cordless phone operating at the same frequency. Lastly, if you hover your mouse over the connection icon does it ramp down in speed a lot? (from 54mb to 1mb?) That's usually the behavior of frequency interference or a weak signal.
posted by samsara at 10:19 AM on January 29, 2008

I'd tell your roommate that if he wants to troubleshoot the connection, the first step would be to update the firmware. You can fiddle with settings all you want, but if it's a known issue with the router that's fixed with firmware, you'll never troubleshoot it without an upgrade.

If you upgrade it through a wired connection, it has a VERY low chance of bricking the router. I've upgraded hundreds of Linksys routers, and only one stopped functioning after the upgrade.
posted by Psionic_Tim at 10:24 AM on January 29, 2008

not sure what firmware you're running, but Firmware 1.50.5 says it "Resolves issues with WPA allowing Shared key selection". newest version is version 1.52.2.
posted by sharkfu at 11:12 AM on January 29, 2008

I noticed the same behavior with my WRT54GS and a wireless client that I added over the weekend.

I simply changed the wireless channel to a new (arbitrary) channel to resolve the problem.
posted by meifool at 12:12 PM on January 29, 2008

Seconding trying different channels. Wifi was 3 non-overlapping channels 1,6, and 11. Try a different one.
posted by damn dirty ape at 12:32 PM on January 29, 2008 [1 favorite]

Windows is trying to be helpful and failing. My money goes to Dead Gateway Detection. Disable it.
posted by bfranklin at 12:41 PM on January 29, 2008

« Older Who really owns your cell phone number?   |   Leather, etc: Animal product, or byproduct? Newer »
This thread is closed to new comments.