Colour IS spelt right you annoying little paperclip...
August 6, 2007 4:19 AM   Subscribe

How do I stop text pasted into MS Word turning American?

I know how to set the default language, and I know how to change the set language for sections of text. So I know one way to fix this... but I'd like to stop it happening altogether.

My default langauge in Word is UK English. But if you copy and paste text from Internet Explorer, the set language for that text becomes US English. So spellings such as colour and organise get flagged.

This has happened to me as a matter of course on many different computers with many different set ups. But today I have finally cracked, I can put up with it no more. Is there a way to tell Word to keep to the default language settings?

I know, I thought that was the whole point of the 'default' setting too...

For the record, at the moment, I'm using Word 2003 and IE6, but the versions don't seem to have much effect on this niggle.
posted by Helga-woo to Computers & Internet (6 answers total) 3 users marked this as a favorite
 
Using "paste special" to paste as unformatted text should do the trick I think - it will then just appear as whatever your "normal" font style is defined as, in this case UK English...

Just as a thought, though, is it a language setting in IE, rather than in Word? Mine is set to "English (United Kingdom) [en-gb]" and when pasting e.g. the title of this question into Word (not paste special) then it is still treated correctly as English...
posted by Chunder at 5:02 AM on August 6, 2007


See this post for a great utility called PureText that will probably prevent this from happening.
posted by chr1sb0y at 5:40 AM on August 6, 2007


Are you using Word's Normal template? If not, maybe the template you are using has US English as the default.
posted by mealy-mouthed at 6:34 AM on August 6, 2007


OK, so a bit of clarification and more information from me...

Thanks to Chunder, I've realised it's not all web pages (what's that term for when you think something is true because you notice it? Confirmation bias maybe?) But as an example, I too can paste the title of this post and have no problems, but when I paste text from this page, the pasted text in word becomes US English.

Pasting it as unformated text doesn't help, and I just checked my language settings in IE (didn't know that was there...), and I only have English (United Kingdom) [en-gb] listed.

My normal.dot is fine (I checked that before I posted here).

And I can't install extra programmes on this computer at least, because I'm on my company network, and I can't even change the icons on my desktop (ugh!)
posted by Helga-woo at 7:10 AM on August 6, 2007


Have you tried pasting the text into Notepad, and then cutting it out of Notepad, and then pasting it into Word? I think that would remove any language information. Bit of extra work, unfortunately, and I think this is what PureText would take care of automatically.
posted by Emanuel at 8:30 AM on August 6, 2007


If at all possible, stop using Internet Explorer, preferably today. Firefox and Opera are highly viable options on Windows.

Pages may (and, according to Web standards and accessibiltiy rules, must) declare their language. lang=EN can be interpreted as any form of English, including U.S. and even if the page uses U.K. orthography.

Only a minority of pages bother with an optional specification like lang=EN-GB or EN-CA. (Not even all of my pages have EN-CA and Canadian English is one of my topics.) Quite possibly, on the pages correctly coded as EN-GB your text will retain that attribute on pasting into Word.

Pasting as unformatted text tseems the brute-force method to solve the problem.
posted by joeclark at 11:20 AM on August 6, 2007


« Older Who should I return my faulty camera to?   |   Winter holiday festivals in Alabama, Mississippi... Newer »
This thread is closed to new comments.