Why won't this site load for only one computer on the network?
July 5, 2007 8:33 AM   Subscribe

One certain site always times out for me. It does not for other computers on the same network. What (if anything) can I do to get it to work?

I have a wireless network set up at my place, and ever since it's been set up (the last week and a half or so) I haven't been able to access elbo.ws/vanilla/ . At first I thought the site was down but last night I noticed it had a recent date in Google's search results for the front page.

So I tried going there through a proxy--in fact, through a half-dozen proxies in three different browsers--and none of them reported the "timed out" message; they all pulled the site up quickly.

My roommate can access the site directly on a Mac. I'm on a PC and can't access any part of the site in any way at all except through a proxy.

We've both tracerouted to it; the packets go through the router to the modem to the ISP and then to Verizon, where they stall at either static-72-88-198-27.nwrknj.fios.verizon.net ( or static-72-88-198-28.nwrknj.fios.verizon.net. I don't know why they stall there since the IP for elbo.ws is actually My roommate always gets the one ending in .27 and can always pull up the site. I always get .28 and can't. I've tried typing in the .27 IP and still can't.

Even though the route stalls there, for him the site loads and is fully interactive but for me the site doesn't load at all.

I haven't denied cookies from the site and it's not set up to time out if cookies are off anyway.

Neither elbo.ws nor are in my HOSTS file.

There's no sort of internet filtering on the computer, at least not intentionally.

AVG reports the computer as clean; Spybot S&D complains about a remnant of the Alexa toolbar, a potential DSO exploit due to having IE 6.0 (which I use only for CSS compatibility testing), a Doubleclick cookie, and an atdmt cookie.

elbo.ws/vanilla isn't set up to be denied from the router (and it would be surprising indeed if it were, since my roommate's computer can access it).

This is the only site I visit that consistently does not work.

I've already talked to the site administrator and he's stumped. Short of contacting my generally unhelpful customer service, how do I go about troubleshooting the problem?
posted by Tuwa to Computers & Internet (13 answers total)
a long shot but you might try doing a dns flush. (ipconfig /flushdns)

admittedly a long shot but it has cleared a similar issue for me on occasion.
posted by chasles at 8:56 AM on July 5, 2007

Response by poster: Thanks, I didn't know about that. I tried it, but it didn't work.

I think now I'm more interested in the problem in general than the site in particular: why is this odd thing happening? ^_^
posted by Tuwa at 9:10 AM on July 5, 2007

It's possible that your IP has been blocked in that site's firewall. If so, there is nothing you can do except plead with the owner to unblock you.

I know that I have a quite long list of IPs and groups of IPs that I've banned over the years, mostly due to abusive behavior (e.g. out-of-control spidering).
posted by Steven C. Den Beste at 10:42 AM on July 5, 2007

Response by poster: Hm ... I think Brandon would have mentioned it when I talked to him; also, wouldn't the Mac would have an identical external IP address as the PC?
posted by Tuwa at 10:52 AM on July 5, 2007

I know this is way too obvious but have you tried a different browser? The traceroute info doesn't sound promising but it's at least worth trying.
posted by 6550 at 11:33 AM on July 5, 2007

Response by poster: Yes. I tried going there through a proxy--in fact, through a half-dozen proxies in three different browsers--and none of them reported the "timed out" message; they all pulled the site up quickly.

The traceroute info is puzzling because, as I said, it times out for the Mac but loads the site anyway, and times out for the PC but doesn't.
posted by Tuwa at 11:37 AM on July 5, 2007

I betcha that there is ICMP blocking giong on at the far end, which is why your traceroute ends before it gets all the way there. It could be that your MTU is too big, and the far end is not sending that back to you, and that is not being reported back to you, because ICMP is blocked.

Try lowering your MTU, and see if that fixes your issue.
posted by stovenator at 12:42 PM on July 5, 2007

Or actually, try checking the MTU size on the Mac, and then matching that setting on the other computer.
posted by stovenator at 12:51 PM on July 5, 2007

I think stovenator has it — the far end has a misconfigured firewall (many people block ICMP without understanding what it does).

Rather than reducing the MTU on your machine (which will reduce performance for all connections, albeit not very much) you could see if you can enable PMTU-black-hole detection on your machine. The Mac probably has it enabled by default. I don't know from Windows, but googling suggests that you should be able to turn it on with a registry tweak.

(Modern hosts try to dynamically adjust the mtu for each connection to the largest it can be without causing fragmentation/reassembly midstream; this is called "path MTU discovery". But if someone is blocking the relevant ICMP status messages this can fail, resulting in a part of the net you mysteriously can't talk to, aka a "PMTU black hole".)
posted by hattifattener at 3:06 PM on July 5, 2007

Response by poster: I decided to research this a bit before gumping around in the registry. Apparently my ISP has an MTU of 1492. Pinging my ISP directly with "-f -l 1492" returns the message that the packet needs to be fragmented but DF is set.

I'm really puzzled about this since I can quite clearly go to most sites. How is it that it requires an MTU of 1492 but that the test shows that it doesn't?

Regardless, I tried changing the MTU on the router. That didn't solve the problem.

Then I tried tweaking the registry to detect PTMU black holes. A reboot and a retry, and still the same problem. Cache is emptied automatically on Firefox close, so it's not a caching issue.
posted by Tuwa at 6:48 PM on July 5, 2007

Response by poster: And further search shows that my ISP's MTU periodically "slips," or at least did as of two months ago. It drops for no apparent reason and then, a couple of weeks later, drops again. Hm.... It would be an explanation, but I'm not sure it's the right one, since someone who's already gone through this has determined that it's been fixed.

Off to bed, in any case. Enough of this for today.

Thanks for your input, everyone. I'll keep looking into this and post back if anything resolves it.
posted by Tuwa at 9:44 PM on July 5, 2007

Response by poster: So my router defaulted to an MTU of 1500 and my ISP claimed an MTU of 1492 but only responded to pings with an MTU of 1460 or smaller.

Thinking that this article about DSL and MTU size and this Microsoft article with a walkthrough on how to troubleshoot Black Hole router problems both sounded useful, I decided to reset the router, my wireless connection, and my (unused) wired connection all to use an MTU of 1460.

Now, after reboot, "ping elbo.ws -f -l 1460" no longer works, and the largest MTU that gets a response on a ping to my ISP is 1392.

So I've just reset everything to how it was before I started trying to troubleshoot, and this one will go in the Jimmy Hoffa and JFK file.
posted by Tuwa at 9:26 PM on July 9, 2007

Response by poster: I quit trying, found that in a couple of weeks I didn't miss the site much.

I'm still curious why none of the solutions solved it, but only idly so. I guess if this affected, say, imdb.com, then I'd take a different attitude to it.
posted by Tuwa at 9:45 AM on October 5, 2007

« Older Pardon me sir, but is that indeed a diminutive bag...   |   How to get the faulty english of my thesis revised... Newer »
This thread is closed to new comments.