My main PC stopped browsing the internet, but can ping IP and Adress.
June 29, 2007 1:50 PM   Subscribe

[Networking filter] 2 PC's, Router on ADSL: PC 1: Cannot browse the web, can ping IP, can ping address, can use MSN. PC 2: Works normally. Sniffer shows odd results...

Hello Hive,
I am at my wits end..
I have 2 PC's connected using a OfficeConnect Wireless 11g Cable/DSL Router.
Laptop is connected via Wireless. Desktop is using wired.

After rebooting the desktop, after it was on for 2 weeks, i lost the ability to browse the web.
The desktop has connectivity since i can ping IP's and addresses and MSN messenger is able to connect.
Firefox and IE however, cannot connect to any site - either via web address or IP address. Not even to the router itself on 192.168.1.1

So far i tried:
0. reboot PC/ reboot router
1. checked MTU. MTU was set on the router to 1400. I changed it to 1452.
2. Flushed DNS and did ARP -d * to ensure DNS cache is clear - ping and MSN still work.
3. Uninstalled blue-tooth stack which i recently installed

I installed a sniffer (WireShark) but i will admit i don't fully understand what it gives me..
According to the sniffer, requests i make on IE don't even register.
When i fire FF, i see:
Source 192.168.1.51 (desktop).
Destination: 192.168.1.255
Protocol: NBNS
Info: name query NB MAIL.GOOGLE.COM
This is probably one of the extensions, since entering an address doesn't generate a line on the sniffer.

I am completely lost...
posted by sierra13 to Computers & Internet (17 answers total) 1 user marked this as a favorite
 
What happens when you try to ping with incrementally bigger packet sizes? This could be a wireless connection issue that only manifests itself when the frame is bigger. To do so, try:

ping -l 500 192.168.1.1

I don't know why Firefox would be trying to use Netbios (NBNS) to do name lookups for mail.google.com, but it would seem to me that DNS is screwed up somehow. Can you disable netbios (Client for Microsoft Networks)? Not being able to browse by IP tends to lead me to believe that DNS is not the issue, but you may need to remove and reinstall the TCP/IP stack. Possibly the winsock is screwy. You don't mention what OS version you're running.

Is there any WEP/WPA involved? Does the laptop work if you plug it in wired?
posted by stovenator at 2:05 PM on June 29, 2007


Have you installed or un-installed any firewalls recently? I had similar problems after removing a firewall once. Re-installing the app then un-installing through THEIR un-installer was the fix.

What version of windows is this? (Is it windows?) Have you checked the LAN Settings in IE? Disabled any installed firewalls?

Also try the winsock fix if you haven't already.

I'm at work, but will check back later to add some steps/questions if it's still not working
posted by TheDukeofLancaster at 2:08 PM on June 29, 2007


This is probably the same things as the winsock fix but it's available at the command line:

Start/Run/cmd.exe (click OK)
enter this command: netsh winsock reset (press enter)
reboot.

Put DNS entries for 4.2.2.2 in the DNS entries for your internet connection.
Disable all other network connections.
In Services, turn off the Windows firewall.

In Internet Explorer's Connections/LAN settings area, ensure that no proxies are set and that the check boxes for "automatically detect" and "Proxy" are disabled.
posted by disclaimer at 2:18 PM on June 29, 2007


"Protocol: NBNS"

I believe this means that it's trying to use a WINS server (NetBIOS Name Service) to resolve names.
posted by rhizome at 2:24 PM on June 29, 2007


Check if your router is proxying DNS queries, toggle that setting and reboot everything if it's offered.
posted by Skorgu at 2:31 PM on June 29, 2007


eeek. in my haste to enter much data, i forgot the basics.. it is windows XP fully updated.

@Stovenator:
The Wireless is the laptop which works fine. Also the WII.. the problem seems local to the wired desktop.
Anyhow:
Pinging the router:
From the desktop: max is 1472 bytes.
From the laptop: max is limitless..
Reply from 192.168.1.1: bytes=16700 time=15ms TTL=255
Pinging the web:
From the desktop: max is 1464 bytes.
From the laptop: max is 1464 bytes.
anything above times out.

@ TheDukeofLancaster:
I didn't uninstall any firewall. In fact this PC runs without one at the moment.
LAN settings in IE was my first port of call - just in case, but the desktop doesn't use a proxy.
I will try now the winsock fix and report.
Thanks.
posted by sierra13 at 2:33 PM on June 29, 2007


Sorry, I got confused as to whether the wired or wireless was the one not working.

It's probably not a frame size issue, as large packets go through okay. I would guess winsock or something in the TCP/IP stack is messed up.
posted by stovenator at 2:55 PM on June 29, 2007


@TheDukeofLancaster
Tried the winsock fix - nothing changed.
@disclaimer
IE lan settings: empty of proxies.
F/W service: Disabled.
Winsock Reset: Done.
DNS: The router is responsible for the ADSL connection.
It is a PPPOE connection and DNS addresses are given by the ISP.
However, i entered 4.2.2.2 as DNS on the n/w card that's connected to the router.
Alas - windows was not impressed.
@Skorgu:
The router doesn't caches/proxies the DNS
@rhizome
I don't if this is indeed a weird fluke on IE behalf's or just me misunderstanding the sniffer..
posted by sierra13 at 2:56 PM on June 29, 2007


hmpf. also tried something i found at MS site to fix TCP/IP stacks:
netsh int ip reset c:\resetlog.txt
Didn't work...
posted by sierra13 at 3:08 PM on June 29, 2007


What devices do you have listed in Local Area connections? Which is default? (Right click on "My Network Places" and select Properties in case you don't know how to get there, although it seems like you may.)
posted by TheDukeofLancaster at 4:41 PM on June 29, 2007


Also, what are the results of the following at the command line :

ipconfig /all
route print
posted by stovenator at 4:43 PM on June 29, 2007


To be honest, i might give up this and walk the well trodden path of new windows installation.. it's been a while and i am surprised it carried me this long..

@TheDukeofLancaster
under network i have the two NIC's the desktop has.
one network card is connected to the internet the other is not used.
(btw, i tried using the other one - no good).
Other than that, i have the "broadband dial up connections" i used when the modem was directly connected to the pc. non is default.

@stovenator
the command output is as follows:
C:\Documents and Settings\x>route print
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x2 ...00 0f ea f7 39 05 ...... NVIDIA nForce Networking Controller
0x10004 ...00 0f ea f6 ba 35 ...... Marvell Yukon 88E8053 PCI-E Gigabit Ethernet Controller
===========================================================================
===========================================================================
Network Destination...............Netmask................Gateway...............Interface...............Metric
0.0.0.0.................................0.0.0.0...................192.168.1.1..........192.168.1.6............20
127.0.0.0.............................255.0.0.0................127.0.0.1..............127.0.0.1................1
169.254.0.0..........................255.255.0.0............192.168.1.6..........192.168.1.6............30
192.168.1.0..........................255.255.255.248.....192.168.1.6..........192.168.1.6............20
192.168.1.6..........................255.255.255.255.....127.0.0.1..............127.0.0.1................20
192.168.1.255......................255.255.255.255.....192.168.1.6...........192.168.1.6............20
224.0.0.0.............................240.0.0.0................192.168.1.6...........192.168.1.6............20
255.255.255.255..................255.255.255.255......192.168.1.6...........192.168.1.6.............1
255.255.255.255..................255.255.255.255......192.168.1.6............10004.....................1
Default Gateway: 192.168.1.1
===========================================================================
Persistent Routes:
None

C:\Documents and Settings\x>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : sierra13
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Router Port:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
Physical Address. . . . . . . . . : 00-0F-EA-F7-39-05
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.6
Subnet Mask . . . . . . . . . . . : 255.255.255.248
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1
Lease Obtained. . . . . . . . . . : Saturday, June 30, 2007 08:39:16
Lease Expires . . . . . . . . . . : Saturday, June 30, 2007 20:39:16

Ethernet adapter Free Port:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Marvell Yukon 88E8053 PCI-E Gigabit
Ethernet Controller
Physical Address. . . . . . . . . : 00-0F-EA-F6-BA-35
posted by sierra13 at 11:17 PM on June 29, 2007


Is your netmask really 255.255.255.248 ? Why are you using CIDR on a private network?
posted by stovenator at 12:45 AM on June 30, 2007


Also, you realize that the broadcast address should be 192.168.1.7 if this is truly your netmask.
posted by stovenator at 12:46 AM on June 30, 2007


@stovenator:
I am but a simple man.. my networking knowledge is quite limited.
I'm afraid i didn't even know i was using CIDR

here is what i know:

The router acts as a DHCP server with the 192.168.1.1 IP.
I selected the subnet mask of 255.255.255.248 just because i didn't need a large IP address block for my network. in the past it was 255.255.255.0.
The router doesn't offer a lot of other settings under the LAN tab.
All i have is: Set router IP and subnet, Check for the router to act as DHCP server, and a button for auto IP range (192.168.1.2 to 6).

The NIC on the desktop is set to "obtain automatically"
This setup worked for me in the past while keeping me blissfully ignorant.. A state of affairs that i feel would change now..
posted by sierra13 at 1:32 AM on June 30, 2007


Some more info:
On the desktop: telnet 64.233.187.99 80 (google.com) fails.
On the laptop, same command - works.
Here is something really strange:
Oddly, when i run the sniffer on the desktop and do a ping the sniffer intercepts it.
But if i do telnet on port 80 or 53, the sniffer remains blank.

Something is blocking it on the windows level.

I created a new user with admin rights on my windows, and logged on with it, thinking that perhaps some app running on my main account is blocking my access..
no good.
posted by sierra13 at 2:13 AM on June 30, 2007


**** News Update ****
I went through my services and disabled any service that i didn't like.
Rebooted the PC and lo-and-behold! the browsing started working again!

Amongst the services there i found a service for the "Comodo Firewall" which is a freeware firewall i had on my PC for a while and uninstalled months ago.

After i removed all the services, i started re-enabling them one by one and rebooting.
After re-enabling the Comodo service i lost browser connectivity again, once i disabled it - it came back.

I would like to thank you all for the effort, interest and expertise spent at my expense.
I would also like to openly admit my stupidity and my shame for not assuming that a firewall was the culprit.
For my defence i will say that Comodo was removed months ago and the service was humming in the background without my knowledge all that time without interfering. Something i did recently must have triggered it.

This concludes 2 days of my life suspended because of this issue.
I hate computers and the control they have over me, but now my flow of fix has returned..
posted by sierra13 at 3:18 AM on June 30, 2007


« Older Rustboy?   |   Poking my iMac in the eye, AKA disabling the... Newer »
This thread is closed to new comments.