OSX Mail ate my homework.
April 16, 2007 12:16 PM   Subscribe

Help me make the OSX Mail program stop mangling my attachments.

I use the standard OSX Mail program and by-and-large am very happy with it. It has only one major flaw: when attaching files, particularly images, they often arrive unopenable or unusable for a Windows-based recipient.

I always select the "send-windows friendly attachments" option, and no, it isn't a file extension issue (I know that file extensions are sometimes dropped in the OSX/Windows conversion). It appears as if Mail tries to "embed" the images in the e-mail, rather than just attaching them as files.

Is there a setting to change, or a plugin I can use to correct this? I don't want to change mail programs, as I am otherwise 100% satisfied with the program.
posted by mrmcsurly to Computers & Internet (8 answers total)
I'm reasonably certain that there aren't any settings that change the way Mail embeds files. If you're only seeing the problem with images, your best bet might be to archive your images into a zip file before attaching them.
posted by chrismear at 12:51 PM on April 16, 2007

Two questions:

What is your "Windows-based recipient" using? (Something that complies to the published standards? What does, e.g., Thunderbird or Eudora do?)

What does the recipient actually see? Suppose they save and you compare what they have with what you sent. What's the difference?
posted by cmiller at 12:54 PM on April 16, 2007

I get this issue when sending PNG files to Windows-based clients. I've gone back and forth with them over the phone trying to explain that I don't see any difference between "embedded" images or "attached" images. My Mac-using brain still finds it hard to accept that they can't just drag the image out of the e-mail, or right-click on it to download it.

My hunch is that the problem is with Outlook on Windows, and not with Mail, although I can't confirm this. Regardless, I've found two solutions:

1. Send JPG's instead of PNG's.

2. If you have send PNG's, zip them first.
posted by designbot at 1:09 PM on April 16, 2007

(That's "if you have to send PNG's…")
posted by designbot at 1:10 PM on April 16, 2007

Another data point: if I use Mail to send an attachment to a particular (Windows, Outlook-using) company then I have to make sure that I drop the attachments onto the end of the email. If I drag-and-drop an attachment into the middle of the email, the part of the mail following the attachment gets truncated. Very frustrating.
posted by blag at 2:14 PM on April 16, 2007

If you don't want to pay $6.00 for WCityMike's suggestion, you can also control-click on the attachment and select "View as Icon" which should stop in from in-lining. Having said that, I had never seen Iconizer before and it looks incredibly useful, so thanks WCityMike! I think this is just a matter of how Mail displays attachments, not how it sends them, so it probably won't help the questioner, but man that's a nice thing to have.
posted by The Bellman at 2:53 PM on April 16, 2007

You already check windows-friendly attachments. Here's two other things to try:

Use the paperclip icon in the new message window to attach documents, rather than drag-and-dropping them into the message body pane.

Set Preferences -> Composing -> Message Format to Plain Text.

Lots of luck. The problem isn't Mail.app, it's with Microsoft's proprietary and non-standard way of dealing with attachments.
posted by ikkyu2 at 6:34 PM on April 16, 2007

Response by poster: It's an OSX Mail to Outlook thing. It appears as if JPGs become embedded BMPs. I always use the paperclip, not drag/drop.

I will try the plain-text and the ctrl-click solutions.

Thanks Mefites!
posted by mrmcsurly at 7:59 AM on April 17, 2007

« Older Subletting appartments in Los Angeles. Help!   |   Why Mid-April? Newer »
This thread is closed to new comments.