iTunes is driving me batty
March 20, 2007 8:26 AM   Subscribe

How do I make iTunes remember my column setup? Every time I open iTunes, I right-click on the columns and set the "Track #" column to be visible. And every time, iTunes forgets! How do I make it remember?

I'm using iTunes 7.1.0.59 under Windows XP SP2.

The listing that I'm browsing is for my iPod, which I of course disconnect and reconnect every day. However, this seems to be the case for all track listings.

I have tried checking and unchecking the "Remember view setting for each source" option. I honestly don't really understand what it does.

I prefer foobar2000, but iTunes handles my iPod better, and that's where all my music is while I'm at work.
posted by qvtqht to Computers & Internet (4 answers total)
 
Note: I'd love to use foobar2000 and the foo_pod plugin, but according to that very page, it's "not recommended" due to compatibility rot.
posted by qvtqht at 8:29 AM on March 20, 2007


odinsdream: The iPod is formatted as FAT32, so there's no such thing as permissions and ownership. I did just check for the read-only flag being set on any of the files, and it isn't.
posted by qvtqht at 8:43 AM on March 20, 2007


iTunes stores which column is viewed for every library and playlist you have. So if you're just looking at "Music", and have your columns set up the way you want, then look at a playlist, your columns will default to something else until you change them. Try making sure that Track # is turned on for EVERY source you might click to view.
posted by wubbie at 9:46 AM on March 20, 2007


wubbie: I generally only view one source -- "Music" under my iPod. When I switch to a playlist, it changes to the default view, but when I switch back to Music, it includes the Track # column again.

When I disconnect and reconnect my iPod, the view is reset to default.
posted by qvtqht at 10:25 AM on March 20, 2007


« Older 1920's Party Help   |   Good scientist, good boss? Newer »
This thread is closed to new comments.